LG V20 phone can no longer run Roon app

Hi - ever since the last Roon update, my LG V20 phone can no longer run the Roon app. The phone is on Android 8.0 (the last update from Verizon). The phone freezes when the app runs. I tried rebooting phone, uninstalling app followed by a reboot followed by a reinstall of app, and in each situation the freezing still occurs. I created a thread under Android for reference: LG V20 can’t run Roon app

I’m hoping some kind of software update might be needed. I don’t have a lot installed on my phone. Would be great to know if any other folks with LG V20 device runs into a similar issue since the last update. Thanks for the help!

Looking for compatible Android versions, I just found this article here:

I didn’t know it before. Well … at least something you can stick to to be on the safe side when you decide to buy a new phone … :disappointed:

Hello @timmo ,

Thanks for reaching out and sorry to hear about the difficulties here! We are looking into a similar issue for @Axel_Lesch , and we wonder if your report might be related.

Can you please send us a set of your Androdi ADB logs for review? Accessing these logs can be done by connecting the Android device to a computer via USB and using ADB (Android Debug Bridge).

To retrieve logs please:

  1. Install ADB from the link here (all platforms)
  2. Connect the Android device before reproducing the error
  3. Type adb shell in terminal
  4. Type logcat v (ref: Logcat command-line tool | Android Developers )
  5. Reproduce the problem and let terminal print logs for 3-5 more seconds
  6. Select the output from the moment the reproduction of the issue started until the very end
  7. Save and send the logs via a file-sharing service (Dropbox / Google Drive / etc.), if you don’t have access to similar services, let us know and we can provide an upload location

Any questions, just let us know and we can clarify, thank you!

Just to report, I also am using an LG V20. Roon is running fine on my phone (though I prefer the much more information-rich tablet version).

1 Like

thanks for the awesome information.

Thanks for the responses, @noris and @Mike-48. Given that this is working for someone else on the LG V20, I’m going to try to do a factory reset on the phone to see if that gets it working for me. If I still have problems, I’ll send the logs to @noris. Thanks again, everyone!

I’ve had the V20 for 4.5 years. As you know, it’s an older model. The biggest problem I’ve had was when the SD card became faulty. It was extremely difficult to diagnose, with a variety of confusing symptoms. One was that newly taken photos (directed to the SD card) soon became unreadable. Another was that the phone wouldn’t boot properly unless connected to a charger. Apparently, when such cards go bad, they go into read-only mode, which caused all those symptoms – installing a new SD card solved everything. I thought I’d mention that in case you are experiencing any similar issues along with the problem with Roon Remote.

1 Like

Thanks for the tips. After my initial post on this, I booted down the phone and took the case off and saw a bulging battery. I replaced it with another battery I have and hoped that would resolve the problem, but the same symptoms occurred with Roon only. I did a factory reset today and it worked great for a few hours, but now it’s back to the same problems again (and I don’t have an SD card in it, but that’s a good tip to know). So … I think I’ll do the logs thingy and send to @noris to see if there are any clues. To me it seems like a memory issue with the Roon app (maybe the phone can no longer handle Roon). All other apps work no problem … it’s just when I open Roon that it all starts to go downhill. Would be nice to get more life out of this phone if I can.

1 Like

Yes, I also suspect this could be a memory issue.
Since the last update I noticed this change:

Mostly, not always, when I reboot Rock OS core running on a nuc and IMMEDIATELY open the roon remote app on my phone, the jellyfish appears for a while until the nuc has rebooted, and next the normal Roon Home screen appears.
Music can be played and everything works, but as soon as I tap on show “Home”, the screen freezes again and nothing works anymore.
Other functions can be operated, such as calling up playlists and albums, changing speakers, etc.

1 Like

Hi @timmo ,

Thank you for the additional information, if you have a chance please do send adb logs over, thanks!