LG V30 Andoid app - Clicks and gaps

Hey David – let me first say you have our apologies for the frustration here.

Just to be clear, we are actively looking into this issue, and absolutely intend to resolve this, whatever is actually going on here.

When you initially reported this to the support team, I took a quick look and we have a significant number of users using Roon with this phone. It’s possible most are using it for control (as opposed to playback) but it’s surprising we only have a couple of reports like yours. That’s why we’ve initially been focused on troubleshooting here. It’s important we determine if this is something affecting everyone with that phone, or just certain configurations/environments – the questions we’ve been asking are largely focused on confirming that.

I should also mention that we are in the process of overhauling Roon’s audio playback on Android. This work is in the early stages, and I don’t have a time frame for exactly when those changes might go live, but it’s worth mentioning that those changes are coming, as there’s a good chance they’ll help with this issue.

Finally, if we’re able to conclude there is a bug here, we’ll do everything we can to fix it David. Fixing bugs that only reproduce on specific hardware generally takes a bit longer to resolve, as we need to be able to reproduce the issue in our QA lab to move forward, make changes, and confirm the problem is resolved.

That said, if something is broken, we’ll investigate and work to close the issue. For now, I just want to be clear that this issue isn’t being ignored.

We appreciate your patience, David. If battery optimization is disabled for Roon, that’s helpful feedback here, so we’ll be discussing this further with the dev team, and then we’ll be in touch.

Thanks!

Hi Mike and Dylan. I should say how impressed I have been with how responsive and unfailingly polite Roon support (i.e you both) has been. It’s quite unusual, and a great model for the rest of the industry - and also quite probably why there are so many Roon fanatics out there. I’ll wait with interest to see if there are any possible fixes.
@support

1 Like

Hello, I wish to add that I am having the same issues with my LG V30+. No issues playing from other Android devices, iOS devices, multiple desktops and laptops etc.

The LG V30+ is working well when using Tidal / Qobuz / USB Audio Player Pro etc.

Same here. I mainly use the app on my V30 for remote control, but I have these issues whenever I try to use it as an endpoint. When I first purchased the phone last October this wasn’t an issue, so I would guess the issue began with a semi-recent update.

Same here. I bought recently a V30 not only for mobility or remote but also to use it as an endpoint for earphones but sadly I have the same problems that other V30 owners have.
No similar problems with other apps and V30 or with an android tablet and Roon.
I hope devs team will be able to fix this problem because V30 is a stunning audiohile smartphone.

Thanks

Andrea

Hey @Traveller @Ronald_Tracey @Andrea_Tacchetti,

The team is currently investigating this, and I was hoping to get some more information from all of you regarding your setup, as well as gather diagnostics reports for these cases. This additional data will assist the team during their investigation.

First, may I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

The next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here. First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Have there been any changes in your setup since this has become an issue? Any networking changes or new devices that have been added to your setup?

Thanks all!
-Dylan

Hi Dylan - thanks for the reply.

I was able to replicate the issue beginning at 10:26PM EDT with a number of file types and with TIDAL. The stuttering begins almost immediately in all cases.

The only thing I can think of that might have changed before it stopped working is the addition of the Netgear extender. However, I was still able to replicate the issue with that turned off, beginning at 10:31PM EDT. Hope that helps.

Here are my setup details:

What version of Roon you are running

  • Version 1.5 (build 334)

What operating system you are running

  • OSX 10.12.6

Basic information about the device you’re using

  • Mac Pro 5,1 (Early 2009)
    • 2.66 GHz Quad-Core Intel Xeon
    • 14gb 1066 MHz DDR3

Describe where your music is stored – this includes hard drive description and interface type

  • WD Red 4tb SATA drive in MacPro

Let us know your collection size (approximate number of tracks)

  • About 85,000 tracks
    • Mostly ALAC and MP3 format
  • TIDAL

What router are you using? When did you last update the firmware?

  • Netgear Nighthawk X4 R7500v2
    • Firmware V1.0.3.26 (latest)

Is there any other networking hardware involved?

  • Netgear Nighthawk X6S EX8000 Tri-Band Range Extender
    • Firmware V1.0.1.164 (latest)
  • Various Netgear ethernet switches

Is everything wired, wireless, or is there a mix of wired and wireless gear?

  • MacPro (Core) is wired
  • V30 is wireless, 5Ghz and 2.4Ghz access points

What output are you using?

  • Android OS Mixer

What brand and model are you using

  • LG V30 (VS996)

How is the output configured

Are you using anything else in your chain

  • No

Does this issue happen with different kinds of media

  • All types

Best,
Ron

Thanks @Ronald_Tracey.

I’ve enabled diagnostics and will be sending the report, along with your setup info detailed here, over to the team to aid in their investigation. I’ll be sure to keep this thread updated as progress is made.

One additional question — Do you remember when you last successfully used the LGV30 as an endpoint? I know you said it wasn’t an issue in October, but did you use it at any point after that?

-Dylan

@dylan Hi Dylan thanks for your reply and sorry for the delay but I’ve been very busy the last few days.

Here’s my setup
Here are my setup details:

What version of Roon you are running

Version 1.5 (build 334)

What operating system you are running

Windows 10 Pro 64bit Build 1803

Basic information about the device you’re using

Desktop PC with corei7 2600K, 16GB RAM, SSD Samsung 850 EVo 250GB

Describe where your music is stored – this includes hard drive description and interface type

Storage   USB3 IcyBox with Red 4 to 10 tb SATA drive in MacPro

Let us know your collection size (approximate number of tracks)

About 279,000 tracks
    Mostly FLAC or DSD and few MP3s+ TIDAL

What router are you using? When did you last update the firmware?

Provider's router Vodafone Station Revolution Firmware 5.4.8.1.316.1.28.2.13

Is there any other networking hardware involved?

Dlink powerline DHP700AV

Is everything wired, wireless, or is there a mix of wired and wireless gear?

Desktop is connected via Powerline
V30 is wireless, 5Ghz and 2.4Ghz access points

What output are you using?

Networked Android 8.0

What brand and model are you using

LG V30 

How is the output configured


immagine

I tried with DSP enabled and disabled with any changes

Are you using anything else in your chain

No

Does this issue happen with different kinds of media

All types

I played to my V30 this evening 15.07.2018 between 20.52 to 20.54 with Quad DAC enabled and between 20.55-20.56 with quad DAC disabled witout any changes. The issue (clicks and gaps) is showing imediately and constantly.
Since I bought my V30 almost a month ago I’ve never been able to get sound without issues in Roon but I use it everyday with other software (both physical and streaming files).
I also add that i own an Iphone 6 that works perfectly with Roon in the same network

Thanks again and bye

Andrea

Hey @Andrea_Tacchetti

I’ll be sure to pass all of this along to the team. Thanks for sending us the info!

-Dylan

@support

…Bump. Silence for 2 weeks?

1 Like

Hey @David_McAughtry,

Thanks for reaching out, and apologies for the silence here. The team is working on some big changes to Android playback that we hope will resolve this issue.

These changes are in progress, but they’ll take some time to implement and thoroughly test, so we can’t make any promises as to when these changes will be released. What I can promise, however, is that I’ll be sure to keep this thread updated as new information becomes available, and we’ll do everything we can to get this problem resolved as soon as possible.

Thanks for your patience here David, we truly appreciate it!

-Dylan

@support. Dylan, while your developers are busy on the Android update, here’s a couple of simple usability suggestions. On Android Tablets, Roon will only display vertically - it is presumably optimised only for the phone. On iPads, Roon only displays horizontally. It’s really inconsistent, but in general horizontal is better.

Also on both iPad and Android, Roon is not enabled for split screen. Split screen would be really useful so that other system controls or apps could be displayed at the same time (e/g for my Devialet system, or Tidal).

Neither of these are hard to do as far as I know.

That depends on the tablet, its resolution and how the tablet is reporting itself to Roon. My Tab S2 is now and always has been in landscape mode.

LG G7 ThinQ and LG V30 here. I am considering not renewing next year due to continual challenges with the LG Quad DAC and Roon.

There have been quite a few reports of issues, but your support forum layout is working against you now. I think it’s becoming too difficult to find common issues across multiple threads.

austingonzo

I have the same issue as above! Lg v30 pops and clicks!
I bought the phone in hope it will work with roon, but no it does not!
Its a shame!

I have an LG V30 and was thinking of trying Roon for my phone and home systems. I think I will wait now until this issue is resolved - just adding my voice to the chorus. LG V30 is the only audiophile phone.

@dylan Hi it’s been three months from the last news. Any news from the team?
Thanks

Andrea

I can also just chip in and confirm that I experience problems with the LG G7 and Roon, to the extent that I don’t use the combination. However I tried again today for a few hours today, thinking that previous experiences have been anomalies, until I got strange distortion and had to switch back to Tidal app.

Here too, same issue: highly distorted playback on LG V30 as endpoint when backgrounding Roon app. Happens for all formats, sampling rates etc as far as I can see. I mean hear.

1 Like