Library connection lost

Hi @David_Dome,

Can I please request that you note the exact local time + date in your country when this behavior next occurs and then manually send me a set of logs by using these instructions? I would like to take a look to see what happens right before and after the audio zone disappears.

I’m not aware of any other changes you can make on the Roon side if you have already set the rescan period to 24 hours, but logs should provide some more context for this behavior.

https://www.dropbox.com/transfer/cap_pid_ft%3AAAAAAH1CoxpeiqcFG-HI4zG__x8uAgnv4otUCI-Ch9LeADG2P0i-MS4

@support See attached link. Dropped out regularly when playing hi-res files. Time was 6,40pm, 18 Nov 2019, Wellington New Zealand. There should be a few logs of a playlist playing fine up until this happened on the hi-res files.

I also played a few hi-res (96/24) tracks after the scanning had finished and it was fine, but when i tried switching to another hi-res album, it crashed again and audio zone disappeared (btw - this was after the logs were sent)

Hi @David_Dome,

Thank you for sending those logs over and I appreciate your patience while I had a chance to review them.

Looking over the logs, it appears that this might be some kind of networking or performance issue, I am seeing periodic loss to our account servers and a specific type of error called sleeping in read in the logs.

Both of these error indicate to me that either the network is not stable or when the Vita is in the scanning process that it does not have enough processing power left to complete the scanning and play the music at the same time, or both. My suggestions would be as follows:

Let’s simplify the network a bit and get this configured as per our Networking Best Practices. We have often seen ISP provided routers have sub-part performance in the past, and might be one source of unstable behavior on your end.

You mentioned you were using a mesh expander, I suggest using a full mesh-style network such as Orbi/Eero instead and letting the Vodafone router act just as a Modem (before passing the Ethernet feed on to a proper router).

Let’s separate the storage location of the media from the audio endpoint it’s playing on. Since the Roon Core has to follow this chain: Roon Core -> Network -> Vita Storage -> Network -> Core -> Network -> Vita Audio Endpoint, I think it’s best that we remove a few of these hops.

Keep in mind that all the audio processing has to happen on the Core, so the Core will essentially grab the file from the Vita, process it, and send it back. This puts a burden on the network and if you have the storage on a USB drive or NAS share, it would help alleviate some of the stress that it is putting on the network.

USB storage is fairly cheap now-a-days, so a 2TB hard drive that you can keep connected to your Core or a NAS on the network will very likely help with the issues you are having and will eliminate some of the congestion that I see in your setup.

I look forward to hearing your thoughts on my above suggestions.

Thanks @support Noris will give the above a try and see where we get to.

However, i see a new software version has been released. I updated the core and apps/Nativ. Now the Google Store is now saying the app is no longer compatible with my device (the Nativ) and Roon won’t display on the Nativ anymore.

What’s happened? And is there a way around this?

Hi @David_Dome,

The Android app update is still rolling out to the Play Store, please see @dylan’s post here:

My other Android devices have updated no problem - just not the Nativ. I’ll try uninstalling and reinstalling.

Nope, Roon Remote is not in the Google Store on the Nativ. It’s there for my other Android devices and updated no problem. Only Roon Essentials is in the store on the Nativ @support

@David_Dome - Can you please check again today and let me know if this is still the case?

Just checked. Error message now says “This app isn’t compatible with your device anymore. Please contact the developers” @support

Hi @David_Dome,

Thank you for letting us know. I have forwarded your report to our hardware team, we plan to get in touch with Nativ support with your findings.

Thanks. Have just sent Nativ some screen shots of the Google store screen as reference.

1 Like

Hi Noris - good news, the app updated itself tonight. Not sure why, but it went thru on the Nativ without going to the Google Store. Haven’t had a chance to check it out yet but will do so.
Next step is to try out connecting the music database direct to the core as you suggested above.
Thanks for the help so far!

1 Like

Ok, so updated the Roon software, now there are a couple of issues:

  1. Roon is not currently seeing the Naitv as an Audio Zone. This is not unusual as sometimes i have to reboot the Nativ so Roon can see the Nativ. However, this has not worked. This despite Roon scanning the music database which is stored on the Nativ. Why does Roon no longer see the Nativ?
    EDIT: have managed Roon to see the Nativ again using Audio and music plays

  2. As per the suggestion above, i copied all my music onto an external HDD and plugged it into the NUC. I think the HDD must be formatted incorrectly. What format should it be? (Nb: the Nativ exported the database in Ext4)
    I copied a few albums across onto a smaller USB and it seems to have done the trick - the drops outs stopped on hi-res albums (which sound fantastic by the way!). Issue is that all the albums i’ve copied onto the Nativ are now exported into a file that’s not recognised unless there is a work around?

Advice @support?

Hi @David_Dome,

It looks like you made quite a few edits to your message. Just to confirm, this is the only remaining issue?

I’m not sure why you are copying the tracks to the Nativ? If they are working off of the USB, I suggest to keep using that as keeping the files on the native would have the increased latency I mentioned earlier in the thread.

I exported my music from the Nativ but it exported it as Ext4 which the NUC did not recognize. Redid it as exFAT and it’s working fine now. Am going to give it another go tonight and see if there are any problems - but last night with the external HDD formatted exFAT and plugged in direct to the NUC running as the Core i didn’t have the drop outs i was getting when it was over wifi. I’m hoping nothing’s changed overnight!
Going forward all music will reside on the external HDD and Nativ will be the end point only (and not used for storage)
Thanks!

2 Likes

My Roon via my Naitv Vita no longer connects to the core (ROCK with an external HD connected via ethernet to the ROCK).
My laptop and tablet can both see the ROCK and Nativ as the Audio Zone, but the Nativ itself can’t connect to the core, altho it does see ROCK when i search for it under ‘‘Configure Roon OS devices on your network’’
I did upgrade my broadband to fibre during the week and i needed to update a few of the connectivity settings to make it all work again, which it did, until this issue today.
Any advice please??

Hi @David_Dome,

What exactly do you mean by the Vita does not connect to the ROCK Core any longer? Do you mean to say that it is not showing up in Roon Settings - Audio?

The Vita wouldn’t show up there - this area is only for devices running RoonOS such as ROCK or Nucleus.

What exactly did you change? If you have two routers with this change, you have to check to make sure that the DHCP server is off one of them so that all your devices are on the same subnet (meaning all devices including ROCK and the Vita have the same IP except for the last 3 digits).

What i mean is that everytime i boot up the Vita, it won’t see the core unless i unplug the core, re-select ROCK which is running on it and then it searches for the core again and can see it. Every time i switch the Vita off i have to go thru the whole process of rebooting the core so the Vita can see it
The only change i have made is our upgrade to an unlimited fibre connection.
There is only one router.

The Vita wouldn’t show up there - this area is only for devices running RoonOS such as ROCK or Nucleus.
No, what i mean is that ROCK (running on the core) shows up when Roon boots up, BUT unless i restart the core it won’t connect connect to the core.

Hi @David_Dome,

Is this still your network setup even after the unlimited fiber upgrade?

We have often seen ISP-provided routers cause issues with Roon, so it may be worth trying a consumer-grade router instead.

Yes the router is the same, just the fibre connection upgraded
But it’s a good idea to swap it out
It’s not a huge issue to reboot every time, especially as if i did purchase a consumer one i’d want to make sure it was a decent one so it might cost a bit!

1 Like