Library contamination

Core Machine (Operating system/System info/Roon build number)

Mac OS 10.15.6/Roon 1.7 build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

The library double count the moved files. “Cleaning up library” or re-scanning drives doesn’t solve the situation. The result is so many albums that can’t be played. Further, this situation wrongfully and randomly designates the missing album as the primary album, which causes huge trouble.

Post a screenshot of your roon settings, storage.

Here it is.

From your initial screen shot, it appears that MusicData2 is a sub-folder under MusicData.

Therefore it is being accessed/counted twice.

2 suggestions, 1) can you post a file explorer pic of those directory structures so we can see what they look like outside of Roon. and 2) why don’t you try disabling that 1st entry, MusicData2 and then see how things look, as your previous pic shows MusicData > MusicData2. Somehow that looks like something is wrong, do you have a link to MusicData2 down inside MusicData?

Thank you, guys.

Ah, yes. “MusicData2” is a separate drive, as well as the sub-directry under “MusicData” (which is a different drive).
These two are basically different, but some files are similar.

Wow, that is a confusing way to name drives and folders.

I’m not all that familiar with macOS, so I will take your word that MusicData2 is not sub-folder of MusicData, but it sure looks that way.

Tagging @support for you.

Hello @Kroon, and thanks for your report! Could you send me a screenshot of your storage location in Finder for these files? Also, have you deleted one set of these files from one of the folders? If the item is in both folders, then we’ll have duplicates show up like this.


Thanks for your reply!
Here it is.

I haven’t deleted the files, but moved some from “MusicData2” sub-directory to “MusicData2” drive. (That’s why the name is identical.)

So, what is the solution?

I think the solution is to stop Roon from watching the MusicData2 drive as those files are already being captured in the MusicData2 sub-directory.

The OP says no.

It’s confusing because, for some reason, it seems he named a drive the same name as a folder on the other drive.

Thank you, guys.

Yes, stopping watching one is not the solution as they are different.
So, could it be a simple solution to rename the subfolder? Without clear yes, I’m afraid of doing this, as I do not want further contamination…

Whats in RoonBackups ? If it contains copies of your music and is not listed in the Ignored Paths, then that could be a source of your Dups

This don’t keep Roon backups on music drives they should be on a seperate drive or network share that is not used for music.

Thank you guys. This is a backup used before. I understand that this shouldn’t be in the same drive as music. But, I want to keep these old backups as long as this is identified as the cause of the contamination. (And, as the backup doesn’t have any music, I believe that this would not be the cause of this trouble.)

So, any possible solution for worth trying??

Just FYI, in Settings - Storage - Edit Storage Location you can add paths to the Ignored Paths box to basically Not Watch them.

Thanks! I knew that, but didn’t have such an idea! Just did to ignore the backup folder. Thanks again!

Hello @Kroon, did adding an ignored path clear up the issue?

No, it didn’t…

Let me know any progress. I have received no official support yet for this issue… This is so serious and critical, so it needs to be resolved.