Local audio devices disappeared (again) on Mac OS X

Roon Server Machine

Macbook Pro x86 Mac OS X 14.2.1

Description of Issue

Roon cannot see local audio devices (Speakers or attached USB audio devices).

It already happened a few weeks ago and it “auto” solved itself.

Now they are gone again.

What I tried:

  • Removed any other applications with audio drivers (MS Teams)
  • Several restarts of both the host and Roon Server

All other audio applications on the Mac are working fine.

This is becoming frustrating, please help.

Hi @Gabriele_Cannata,

Thanks for writing in! Could you please test out reproducing this issue without and active Muse/DSP settings?

With that, could you please reproduce the issue and share the specific date, time and name of the track playing when the issue occurs?

Once you let me know this info, I’ll go ahead and enable diagnostics for your account so I can review the logging for clues.

If you’d rather do it yourself manually, please use the directions found here and send over a set of logs to our File Uploader.


Thank you very much for your support. Unfortunately I cannot track when they disappear. They are reappearing and disappearing whenever I open Roon on My Mac OS X since I updated to Sonoma.
My Roon Server is on a Linux Docker. I uploaded the logs from RoonServer using the File Uploader.
It looks to me something related to Roon for Mac. I also restarted coreaudiod just in case, and of course Roon itself and the whole Mac.

Thank you very much

This would have been kind of pertinent information to add in the old thread or at the start of the new one. How is anyone to know?

Docker is not a supported configuration and there’s some specific stuff to take care of. The device discovery happens over the network layer (even on a local device) and hence I guess it’s most likely a network configuration issue.

I’d recommend looking through the Docker thread or asking there:

Could you clarify why the deployment architecture of Roon server should affect local devices of Roon app? Network devices are the only ones that kept working flawlessly even after I updated Mac OS X to Sonoma.

Many network centric applications do local things over the network layer. It simplifies things because the developers don’t have to build different code paths for the remote and local scenarios. Instead, the application just uses the localhost address for the local case.

It’s certainly possible that something in your setup is occasionally interfering with localhost addressing although it works with remote addressing

Hi Gabriele, Have you had any progress on your issue? I recently updated to Sonoma 14.2.1 and am having similar problems. All aspects of my Roon system work with the exception of losing the audio devices on my Mac Mini. I am forced to reset my RAATServer and/or “sudo killall coreaudiod” to maybe bring it back. It’s gotten too frustrating to use my Mac as an endpoint.

Hi @RichC , not much. I noticed that local devices “reappears” after a Mac OS restart, but disappear after a while. I cannot tell if Roon app was open when they disappear from Roon.
I tried everything with coreaudio:

  • killing coreaudiod
  • killing all audio processes
  • removing any /HAL audio driver

with no success.
I am quite sure this has nothing to do with Roon Server though.
I will keep you posted.

Quick update, today I had to restart the OS and local devices disappeared again.

This topic was moved from Support to Tinkering, probably because Roon Server is on a docker container instead of some officially supported distribution, albeit this being clearly a local Mac OS X specific issue.
I feel I am paying the price of being a lifetime customer, so they don’t have to win me over anymore.
I am really disappointed.

When they disappear in Roon – are they still visible in the “Audio MIDI Setup” app of macOS? If not, you might be having an issue with the device drivers.

They are visible and working everywhere else except Roon app.
They are visible in the Audio MIDI Setup panel, in the sound settings, in the volume control, in other apps, and so on.
I am talking about native Mac devices (Speakers/Headphone jack).

Is it possible to try taking your Roon Server out of the Docker and trying it on the raw Linux platform? It might give you some insight. I agree it should make no difference but Roon is a .NET app ported to Linux. Who knows what the emulation layer does.

Currently “This Mac” is visible. As soon as it will disappear, I will connect to the Mac itself as Roon Server and report back.

OK, now “This Mac” is not visible. I tried connecting to the “local” server, but in order to do so, I should “unauthorize” my main server and transfer the license. Honestly I am not so keen on doing that.
In the meantime both Roon App and Server were updated to build 1359.

@RichC as you can see this support request was demoted to Tinkering because my Roon Server is on a docker container. If you are on a “supported” server and you still have this issue, would you mind opening a support thread?

Thank you

Hi Gabriele, I’m sorry you’re still having the issue. It was very frustrating but it did stop happening to mine. I made a backup of my Roon data and completely wiped my Roon server and reinstalled (ROCK on Intel Nuc I7). I also uninstalled Roon on my Mac then reinstalled the software, connected to the new server and rebuilt the library using the backup. It took a while, and I don’t know why it worked, but I haven’t had the issue since the rebuild. Good luck.

Today I updated to build 1365 and “This Mac” reappeared after a long time. I hope I won’t have to wait for each subsequent update every time local device will disappear! Note that I had already reinstalled the application several times in the past trying to solve this issue.

1 Like

Unfortunately they disappeared again… I don’t know what to do anymore… the lack of support from Roon is frustrating…

Are you still running Roon in Docker? Your original post was moved to Tinkering for that reason - it’s not a supported configuration.