Local audio output

hello,
using roon windows client I am not able to select local audio card as an output device. Its possible using roon osx client.

roon server is running on remote linux machine.

Thanks

1 Like

Try turning off all firewall on the of and see if the audio endpoints show up. If so, then you need to white list roon and stay in your firewall.

2 Likes

Hi @John_Smith,

As Daniel suggested, definitely try disabling any firewall on the Core machine and let us know if the issue persists.

Has this endpoint previously shown up in Roon?

looks like misunderstanding, on the client pc i can see roon server and connect to it. What i was saying is that roon client installed on my windows cant see “local audio device” ie laptops soundcard. I can playback only to other devices as airplay, etc… not to local soundcard.

HI John, Did you try my earlier suggestion? Based on your symptoms, I think that is the issue.

The local client doesn’t “see” anything about the local sound devices, that is actually handled by the server. The server sends discovery queries to the client and the server builds the audio endpoints based on the responses. If your PC has a firewall going, the server queries and/or responses will be blocked; the server will not receive the responses to create the audio endpoint and will not display the local audio devices.

Turn off the firewall on the PC to see if the devices show up. If they do, then white list Roon and RAAT.

1 Like

ah okay, i thought client is responsible for the local audio devices. Will try and let u know later on. thank u

i disabled win7 fw and it pop up in audio section, well i cant disable FW, is it possible to create some rule? what port is responsible for local device? thank u

Hi @John_Smith,

Thanks for giving that a try! Since that resolved things for you, you’ll need to enter exceptions into your firewall for Roon and RAATServer. Once you do so things should be working for you.

Thanks!

hi,
so what are the porst numbers?

normally my fw asks for each new connection request to be accepted or denied… but with roon nothing is happening.

You will want to whitelist RAATserver, RoonServer, and if you have it RoonAppliance. If you need ports, I think the relevant ports are in the post below:

ok. i added roon.exe and raaatserver.exe into win fw and it works. thanks

Hello one more issue:

roon server is running at 10.0.1.50 (LAN) —> router (openvpn server 192.168.8.1) <-INTERNET-> openvpnclient (192.168.8.2) running on win7(LAN 192.168.1.10) , there is installed roon client.

From roon server (10.0.1.50) i can ping 192.168.8.2 and 192.168.1.10 also from pc where roon client is installed i am able to ping 10.0.1.50.

I disabled FW on pc with roon client and started roon client app, local soundcard appeared but after few secs disappeared.

Roon server log contains:
04/03 00:58:45 Info: [brokerserver] Client connected: 192.168.8.2:49367
04/03 00:58:45 Trace: [SOOD] Adding User IP 192.168.8.2
04/03 00:58:46 Trace: [raat] RAATServer discovered: RaatServer roonclient-pc @ 192.168.8.2:49361
04/03 00:58:46 Info: [raatserver] GOT SERVER XXX @ 192.168.8.2:49361 roonclient-pc PROTOVER=1 RAATVER=1.1.33
04/03 00:58:46 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] connecting (attempt 1)
04/03 00:58:46 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] connected
04/03 00:58:46 Info: [brokerserver] Client disconnected: 192.168.8.2:50158
04/03 00:59:26 Info: [brokerserver] Client disconnected: 192.168.8.2:49367
04/03 00:59:26 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] lost client connection. Retrying
04/03 00:59:26 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] connecting (attempt 1)
04/03 00:59:26 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] client connection failed. Retrying in 500ms
04/03 00:59:27 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] connecting (attempt 2)
04/03 00:59:27 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] client connection failed. Retrying in 750ms
04/03 00:59:27 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] connecting (attempt 3)
04/03 00:59:27 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] client connection failed. Retrying in 1125ms
04/03 00:59:29 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] connecting (attempt 4)
04/03 00:59:29 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] client connection failed. Retrying in 1687ms
04/03 00:59:30 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] connecting (attempt 5)
04/03 00:59:30 Trace: [raatserver] [RaatServer roonclient-pc @ 192.168.8.2:49361] client connection failed. Giving up
04/03 01:00:33 Info: [brokerserver] Client connected: 192.168.8.2:49386
04/03 01:00:33 Trace: [SOOD] Adding User IP 192.168.8.2
04/03 01:02:13 Info: [brokerserver] Client disconnected: 192.168.8.2:49386

any idea why i can see local sound device for few seconds and then it disappear?

Hi @John_Smith,

Can you share a screenshot of what you see in Settings > Audio?

Can you confirm that the drivers for the Windows 7 remote device that is experiencing this issue are up to date?

Roon only works in the same subnet.

in case it works only in the same subnet can i somehow simulate it? if one uses openvpn it wont be same subnet, right?

There are some whom have gotten vpn to work. Those threads are in the Tinkering section. You might give them a read.

looks like roon ignore standards, and they are not willing to fix it to work with l3… :frowning:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.