Looses each four day connection with Roon ROCK 1.6 on NUC 8i5


Running ROCK on 8. generation of Intel NUC i5 my setup looses connection to Roon Core. Reboot solve each time the issue.

The spooky thing is that this happens consequently after 4 days, completely repeatable. I have the issue from wired PC and iPAD.

Roon ROCK NUC server is constantly on, no sleep or hipernate applied.

I have no issues with other servers in my network, so it should not be a router issue.

Everything else is working perfectly.

Anyone other with this issue?

Hi @Kim_Kruse_Petersen,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

When this behavior occurs are you able to access the Web UI?

Server: Intel NUC 8 i5BEH
Router is: Dlink DIR-880L
NUC firmware: 0156
ROCK OS 1.0 Build 174
Roon ROCK 1.6. build 401

I have the issue both from PC and from iPad.

I will inform, if issue have been solved with new ROCK OS version.


I have not got enough time window to verify that issue may be solved by recent new OS build 174.

The Web UI is running normally, uptime counter working, so when I from the Web UI request reboot of server, everything is again running.

@support: The issue is still in live with OS 174, but the sequence of four days between issue is now changed to be random.

The Web Gui tells tha ROCK is running, time is updated and reboot via the GUI gets ROCK up and running again.

Any suggestions?

No one at @support with a status of this issue?

Hi @Kim_Kruse_Petersen,

Thanks for confirming that you’re able to access the Web UI when this occurs.

When the disconnect occurs for one remote does is it happening at the same time for the other remote?

Can you confirm how your Core and remotes are connected to the network? Are you using any switches or other networking hardware?


Thanks for your answer. Very much appreciated!

The disconnect happens on both IOS devices as WIN10 PC as well.
Remotes are connected, as other connectivities is working.

I have a network switch D-LINK DGS-10008D between router and Intel NUC with ROCK installed.

Hope this helps


Hi @Kim_Kruse_Petersen,

Thanks for the info! Is the PC wired directly to the router or to the same switch as the ROCK device?

If you temporarily take the switch out of the equation and connect the Core directly to the main router does the same behavior occur?

I have tried connection directly to router Same issue consist - cannot find core after some days.

Is there a setting in the router that might help?


Thanks for giving that a try, @Kim_Kruse_Petersen!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi Dylan,

Time experienced: 01-April-2019, Time: 8.08 (CET)
It was running the night before. I have no information of when it stoped during the night.
It has never stopped, when in use.

Thanks, @Kim_Kruse_Petersen.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @Kim_Kruse_Petersen,

I spoke with the team about this and wanted to reach out with the next steps here. The next time you’re in this state, please do the following:

  1. Navigate to the Web UI
  2. Restart RoonServer
  3. Respond here when you’ve restarted RoonServer with the time that you restarted

Please do not restart your Core machine, just RoonServer. Once you’ve done this I’ll enable diagnostics once more so the team can take a look.


Hi @dylan
Time: 7.40 CET 04-APR-2019, restart Roonserver.
However, this does not getting the Roon up and running.
Still returns “choose your Roon Core”

Roon Core seems not to be running. No update on the time running.
After a couple of minutes server states “not running”.
So server will only getting back in operation by reboot.


Thanks, @Kim_Kruse_Petersen.

Diagnostics have been enabled once more and I’ll get the diagnostics report over to the team. I’ll update you once I hear back from them.

@dylan: Strange that issue now again occuried after four days: thursday morning (reported) and now monday morning. Next time maybe friday?
Could it be filled memory, or full log? Or a nice hidden setting in the NUC?

Hi @Kim_Kruse_Petersen,

I just spoke with the team about this and they’ve requested that the next time this occurs, please let me know here without rebooting the machine. As the device is in this state we will enable some further diagnostics that should give us greater insight into this.

Thanks for your patience here, Kim!

Hi @dylan
Thanks for your endless efforts to constantly getting Roon better and better.

Now the issue is again present. I will leave the state of the server as suggested by your team.

Time: 7.50 09-apr-2019 CET

Hi @Kim_Kruse_Petersen,

Thanks for letting us know! Diagnostics was enabled and our team took a look at the diagnostics report. They’re seeing some signs of networking issues in the report and were hoping that you could give something a try. Please reboot your router (but not the Core machine) and let us know when you’ve done so. I’ll enable diagnostics once more so the team can have another look at the report after this is done.

This afternoon Roon was again running without any reboot. The GUI tells that it has been running for 4 days.

Now I have rebooted router. You may have a point that it might be a net issue. However, no others devices has issues with the net.

Indeed strange! But on behalf the Roon product I am happy that it looks like itnis only an issue for me.