Losing Roon Radio after playback of local or tidal albums

I must chime in here as well…been watching this post as I have had all the above same issues on an iPhone 11 and iPad both running the latest versions of software - including loss of Roon Radio during and following playback of local albums or Tidal tracks. I also get daily crashes, freezes, or black screens of the Roon app on both devices. I never have issues with my Sonos network of speakers throughout the house when using Tidal or other streaming services - I have total confidence in my LAN/WAN infrastructure. @support (Tried to make this an additional post in this thread but ended up just using the “Reply” button)

Hey Bob, would you mind letting us know a bit more about your setup? If you could, please provide more detail about:

  • Your Roon Core machine (operating system, model, CPU, RAM)
  • Network details (model of any routers/switches, and how your devices are set up on your LAN)
  • Your audio devices
  • Library size

This will help us to get a clearer picture of how you’ve got things set up, thanks!

My Roon Core V1.8 build 795 lives on a sonicTransporter sti5 v2.8 w/2TB internal SSD and 8GB internal RAM —> Sonore ultraRendu w/linear PS —> Wyred4Sound 10th Anniversary DAC —> SimAudio MOON PA. Routers are both Asus AC1900’s running in AiMesh mode connected with hardwired backhaul. My library is about 21000 tracks of mostly Redbook resolution FLAC and some higher res FLAC and DSD files. I am connected to the internet via a Comcast gigabit modem.

Hello @Bob_Tanner ,

Since you are using an ASUS router here, can you please confirm if you have this setting from our Networking Best Practices Guide in place?

ASUS Routers

We recommend enabling “Enable Multicast Routing” option in settings.

Also, can you please confirm you are on the latest firmware for the router? Updating firmware has helped another user with similar issues in the past:


@noris I have confirmed my router has Multicast Routing enabled. I tried updating the firmware to the newest but they’re not taking it - will continue to try manual uploads. BTW, the slave in the AiMesh network is an RT-AC68u and master is the 1900P. I’m not experiencing loss of Roon Radio at all or as often. This may be a different topic but I AM experiencing the Roon app freezing often on my iPhone 11 running the current iOS version.

I suggest:

  • Disable any firewall in Roon Core computer and router
  • Disable router AiProtection
  • Disable router QoS
  • Disable router Traffic Analyzer
  • Disable AiMesh in all units
  • Set the master as Wireless router mode (default)
  • Set the slave as Media Bridge
  • Enable multicast routing in all units

See if things work better this way.

1 Like

Hi @Bob_Tanner ,

Did any of Peter’s network suggestions help with the issue?

Is the behavior the same if you uninstall and reinstall the iOS app?

Even after deleting and reinstalling, the app still randomly freezes on an iOS device…when it freezes, I swipe it to close…reopen and it is a black background with “Roon” centered but still frozen….I swipe it closed and reopen … then all is ok. Sorry, I haven’t had time to try Peter’s suggestion - kind of a major reconfiguration.

Multicast has always been ENABLED
AiProtection has always been OFF
QoS has always been OFF
Can’t find how to disable Traffic Analyzer
Sonictransport sti5 doesn’t appear to have a Firewall to disable
Am nervous about disabling Firewall in router (IPv6 firewall as well) so didn’t
Couldn’t complete the conversion of AiMesh slave to Media Bridge - my laptop no longer has an ethernet connection to connect directly to it so am keeping the AiMesh configuration until I here back from you.
@noris @wklie

You can use disconnect this unit, factory reset it. Connect your laptop to it, then you can do a first-time setup again and set it to Media bridge.

Remember to reapply multicast routing and IGMP proxy.

@wklie my Lenovo does not have an RJ-45 connector…my old Dell does but I’m not sure this exercise is worth it…will get back.