Lost connection to Linn Streaming (Klimax DS/2)

Core Machine (Operating system/System info/Roon build number)
Core on a separate MacMini, latest Catalina version (only used for Roon, version 1.7 build 610)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
No switches or whatsoever in network.
Roon Core and QNAP NAS, both connected via CAT6 to powerline adapter in my office.
Linn connected with CAT6 to the power line adaptor in my living room.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Linn Klimax.

Description Of Issue
This week Roon lost the connection to my Linn Klimax. It was working flawless before and I never had any issues since I installed my system. The Linn Klimax is still displayed but it doesn’t play any files. I tried to switch to AirPlay - this works. When I use the Linn own Kazoo app it is also working flawless.

So the problem doesn’t seem to be the network itself? Also when I am streaming from Roon to my Naim devices (also via AirPlay) it works. In the meantime I have tried many hints from this forum here (power off/on, Firewall settings, etc) but nothing has solved this issue so far.

(Just another user with a partly Linn setup) Linn streaming is working for me, latest Roon versions everywhere. Two things stand out in your report. 1) You are using powerline adaptors. I tried those when I first went into digital audio (before Roon), and gave up because I could not get them to work consistently, even after trying multiple different models. They would work for a while, of part of the day, and then start dropping packets, just enough to mess up audio streaming but not enough to stop communication totally. I concluded that there was something in the power distribution network outside our townhouse then that occasionally flooded the power lines with high-frequency noise that disrupted the powerline adaptors. When that was the case, I could see the problem as low-grade packet drop rate with a ping app. 2) What still works for you is all Airplay, which does not use your wired network.

The following options have worked for me when I cannot run actual Ethernet cable between two locations: 1) Actiontec MoCA adaptors for Ethernet over cable. My current home has coax for cable TV in every room, but the way it is designed and built would make it hard to run Ethernet cable within walls or under floors. My living room Klimax system connects to my office server this way, very reliably. 2) WiFi mesh with Ethernet jack on relevant endpoints: I have an AmpliFI mesh at home, with an additional AmpliFi endpoint with an Ethernet jack. I used this temporarily when I moved to this house before we got the MoCA setup going.

Thanks for your hints, will give it a try with the WiFi mesh. Nevertheless I do not understand why the same setup with the power adapters is working well with the Linn Kozoo app … ??

Good point. In general, I’ve found that different ways of pushing music to digital audio gear have different behavior when there are network issues. As far as I can figure it out, Kazoo uses UPnP/DLNA to tell the Klimax hub to retrieve tracks from your server. My recollection of DLNA is that tracks are retrieved as whole files. Some level of packet loss is tolerable in that situation because TCP/IP retransmits lost packets. The hub will just play the track from its internal buffer memory. In contrast, the Roon>Linn connection uses the Songcast Direct protocol. From my reading of the protocol spec, I’m not sure how low-grade packet loss might affect it, but it is a different protocol.

If you haven’t already, check to make sure Roon has the correct subnet for Linn streaming. Go to Settings>>Setup and look at the very bottom of the page. You should have an item “Subnet for Linn Streaming,” and the ip subnet listed should match the subnet for your Linn, which should also be the same subnet in which Roon resides. If it doesn’t show anything, or the wrong subnet, the only cure I’ve found is repeated reboots of the Roon server.

Subnet is the same, checked this already…

Guess that wasn’t much help. I have two Linn boxes, a Klimax Katalyst and KlimaxRenew, and Roon not picking up the subnet on reboot is the only problem I’ve had, and haven’t had that happen for some months now. I hope you figure it out. I think Fernando might have a point re the power-line network.

Already ordered a WiFi Mesh repeater with 2 Gigabit LAN ports - hope this will solve the problem.
Still, I am wondering what caused this issue as exactly this setup worked well for about 1,5 years?
I have a strong suspicion that the build 610 has caused it - quote from Roon software release notes: “Signal path: Fixed copy for Linn outputs”. But maybe I am wrong…?

Hi @Stefan_Gutheil,

This was a visual fix for this issue:

Also hoping that the Mesh will resolve this issue, do let us know how it goes and if further troubleshooting is needed after it arrives, we can take a closer look.

@noris, I do not think it has anything to do with any mesh wifi, I think it has happened a lot with the Roon 1.7 build 610 regardless whether I run the Roon Server on a Windows 10 or a MacOS machine.

After installation of 2 mesh repeater it is working again. Thanks for the hint Fernando!
You may call it a solution - BUT I still wonder why my previous setup was working flawless for 1,5 years and suddenly (after the 610 build) it stopped. :frowning_face:
I would have also expected some more support from the Roon team here instead of other users, but that‘s just my „old school“ opinion…

1 Like

Maybe it is working for you now, but maybe you will need watching for the issue to return?

I have a Klimax DSM/3 and everything is hard-wired and it has been rock-solid before the latest release, and then it is happening now.

The issue can happen a few times a day or may be once very few days randomly, and especially if you enable DSP to max PCM or DSD 128.

I even disabled DSP upsampling but my problem stayed. Hopefully it will be stable now, nothing is more annoying than listening to your favorite music and suddenly… silence…

Yes, exactly what has been happening to my klimax DSM/3, music and then silence, zone disappeared, then re-appears 5 or 10 mins later.

It’s been working well for me, with a couple of glitches over the last few months that were fixed by power-cycling the Linn system, but everything I play is PCM, and very rarely above 96kHz sampling rate. The relationship between Roon and Linn seems kind of arms length (maybe I’m wrong but that’s how it looks to me). Roon has to use Songcast to drive Linn equipment, which is not Roon’s native RAAT protocol, so I can imagine bugs creeping in as Roon and Linn push out new releases and their respective implementations of the protocol get out of sync. That kind of bug might well not show during Roon’s in-house testing, since it could depend on the specific Linn endpoints, firmware releases, and music material.

1 Like

Power cycling the Linn streamer seems to fix the issue temporarily.
@Fernando_Pereira, how do you find Roon SQ, in comparison to Linn Kazoo? Personally I do not find any differences, but Roon GUI is better.

No SQ differences that we can detect. When I bought the Linn system, we tested that as carefully as we could, my wife has very good musical hearing and she couldn’t find any differences in an informal blind test. I wanted to use Roon because we had non-Linn systems already on Roon.

The fact that power-cycling fixes the issue, at least temporarily, suggests that Roon and the Linn hub are getting out of sync somehow. That should leave some traces on Roon’s logs, but that’s really something for @support to dig into.

1 Like

I think Roon and Linn should figure out what is going here. Linn has just release the latest firmware for the Linn Klimax DSM/3 and Roon also did recently, and I think there is something in there.

Now I stop using Roon, and reverting to Linn Kazoo.

1 Like

I think I know the problem, previously I hooked the Linn Klimax DSM/3 to a CISCO switch, I then decided to hook to the streamer to one of my Netear Orbi satellites, turns out the Netgear Orbi does not support IGMP snooping, this then causes Roon not to discover my streamer. Hooking the streamer back to the Cisco switch fixes the issue.


Hi @Stefan_Gutheil,

I wanted to check in with you to see how the system is running after your latest message, is the mesh network still working as expected? If you see any new issues, just let us know and we can take a look!