M.2 SSD in NUC8 keeps dying

HW: NUC8BEH with 250GB M.2 SSD for ROCK and 4TB SATA SSD for Music

I’m having a very strange problem with my NUC8. Now already for the third time my M.2 SSD in the NUC died after 2-4 weeks operation.
I get an error message at the system start, which says “SMART status bad, backup and replace”. This message has to be confirmed with F1 to continue booting.
Roon OS still boots and is reachable, but on the ROCK status page is displays “Roon Database & settings: Not ready”. Pressing the Reset button doesn’t help.
I also tried to repair the Roon installation with the bootable USB stick. When I do this, I get an error message “Failed to mount /identity”

As I said, this now happened the third time since I have the NUC. When I replace the M.2 SSD, it works without problem for 2-4 weeks, then above mentioned problems start again.

Could it be a problem of the NUC? My HW store is a bit clueless, since they don’t know ROON/Rock at all and everything outside the standard Windows routine seems suspicious.

Any help to solve this topic is appreciated.


Have you verified that the M.2 you are using is certified as compatible with your NUC by Intel (there is a list on their website of compatible hardware).

Have you seen this thread?

Yes, it’s a Kingston A2000, which is on the compatibility list.

Please copy me in on all responses, this happened to me just once but it is rather worrying to hear of these ongoing problems as I have the same Intel NUC as Mathias

I was using the Transcend M2 SSD that was recommended by Roon

I’ll be watching this too.
Also have a NUC 8, i5 version.
Im actually using an M.2 that is not listed as certified by Intel as I had it laying around when I assembled the NUC and cheaped out not buying new.
My M.2 is Adata brand.
No problems, so far…
Will see what happens.

Hope you have a well designed backup schedule. :wink:

Daily, to two different drives: one in the NUC and one on a NAS.
100 days worth of each backup saved before rotation.

1 Like

No hint from the Roon experts? :cry:

@support - do you have any views as to this thread please?

1 Like

Hi @Supersonic,

I’ve moved your thread over to the #support section, for reference, this section is the only one regularly monitored, so you need to post here for tech support.

Can you please share a screenshot of this error?

Have you also checked the RAM on the NUC? I wonder if the RAM might be failing in the SMART checks, I would run Memtestx86 to check this aspect as well.

A set of your ROCK RoonServer logs when this message is visible would also be helpful, you can access Roon logs by using these instructions, logs might provide some more clues.

Hi Noris,

thanks for your reply.

The Memtest finished without errors.

When I connect to the ROCK Server via Samba, I can’t find any logs. The only structure, I can see is the following:


You need to look under RoonServer - that’s where the Logs folder is kept…

The shown folders are the only ones left. There isn‘t a RoonServer path available anymore…

OK, then there is something very bizarre going on with your NUC…

Hi @Supersonic,

Thanks for sending those screenshots it is helpful.

This error sounds like there is an error trying to access the SSD itself, which is hardware related.

I would check the SSD and see if you can re-seat it and ensure that the sockets are clear of debris.

Hi Noris,

I did that every time. The fault behaviour somehow indicates a different problem. Every time, I install a new SSD, it works flawless for 2-4 weeks, then it dies with the mentioned symptoms. Last time my HW store tried to do a low level format on the SSD (on a different computer)n and even that failed.

If you have no other hint, I would assume it has to be a HW defect in the NUC. Would you support this assumption?

Hi @Supersonic,

This does sound like a hardware issue, but let me reach out to our QA team to see if they can offer some feedback on the error messages as well, and hopefully they will be able to confirm further.

Are you using the same model every time? So your second and third are RMA replacements?

Are you using the original 19V power supply for the NUC8, not LPS?

Yes, they all were the same SSD model replaced by my HW shop.

I’m using the original power supply, that came with the NUC.