Mac mini always on full cpu while running Roon

Not sure why, did today’s update and… CPU running smoothly.

I can play Roon again.
Thanks so much.

1 Like

Rejoiced too soon.
Roon using over 300% of my CPU, Mac is gong nuts.
I have to close Roon once again.
Can I get a permanent solution?


Another data point for you. I have the same problem as soon as I updated Roon Client on my 2018 Mac Mini from 1.6 to 1.7. Never a problem on 1.6. Now 400% CPU by Roon whenever I start the app.

I have not tried rebooting yet, but it sounds like the problem comes back anyway. For reference, I’m still running Mojave, so it is not Catalina specific.

Any updates on this topic. My mac mini is also running 200% on the roonserver.

Mine has gone back to normal after the last (or second last) update; no issues anymore, Roon running at all times on the Mac.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

I have another issue with Roon throttling my Mac Mini. I had had the same issue a few months ago and it went away without a known reason. It has returned since 2 weeks and I’ve tried a SMC reboot, to no avail.
Any help would be happily accepted.


Core Machine (Operating system/System info/Roon build number)

Mac Mini 2018 build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

dCS Bartok; Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Roon makes CPU run at 290%; I can/t leave Roon running as the mac fan will explode!
Problem went away 2 months ago without a reason, back since 2 weeeks ago.
Did a SMC reboot, no change.

I can confirm mine is using 300+% I am also analyzing my files so that may be part of it.

Just checked after analyzing, still at 300+%

Hi @Bernard_Aubin,

I have merged all your posts together so this history is in one place.

Tagging @support for them to follow this up with you.

Hi @Bernard_Aubin / @JohnC,

Is there any change in behavior if you try toggling WiFi on/off in the Mac Networking settings? We are still investigating this issue, but we have heard from other users that toggling WiFi can help with this behavior, so I’d like to see if this is the case for you as well.

Hey Noris,

Toggling WiFi makes no difference. I suspect the results you were seeing was a result of someone using WiFi as their network connection. In my case I am using ethernet. I could try toggling the ethernet connection off then on. let me know what you think.

I started Roon back up (can’t run it, CPU thru the roof) and it immediately reached 300%. I did toggle as you suggest even though I also am wired,and Roon came down to normal levels. I am certain it was not due to the toggling.
I left Roon on, and will recheck when I get back home tonight.
I’ll keep you posted… Ideally, I’d like to send a system report when it is racing and another one when it is not so that you guys can find the culprit app.

The weird part of this, I haven’t shut my mac mini down. I have rebooted it a few times to test things out, but never turned it off. It has been running full out for three days now.

Hi @JohnC,

We have heard the WiFi toggle works to resolve the issue, even if the WiFi is not in use. So in your case, you could check toggling the WiFi first on and then off. If that does not help, please try toggling the Ethernet adapter off/on.

@Bernard_Aubin - Other reports suggest that this is related to the network stack on MacOS. We are still investigating the root cause of this behavior, but system reports won’t be too helpful at this point since we are trying to identify the root cause, not just the after-effect in logs. The investigation is still ongoing, but this is what we have found so far.

Hi, Roon running at almost 400% CPU; any news on this?

Hi @Bernard_Aubin,

We are still looking into this, you can find the most recent post regarding this subject from the team here:

Roon unusable for weeks, running at 400% cpu still. I’m using other softwares to listen to music but miss my Roon.
Any updates on this annoying bug?

Hi @Bernard_Aubin,

We’re working on this issue, but nothing to announce at this time. I would be on the lookout for an update in the linked thread above once we have progress to share. Thanks for your patience here!