High CPU Usage on Mac Mini 2018

Unsure what it is. But I have a 2020 MacMini running 24/7 as my Roon Server. No issues found so far. Runs cool & quiet!
Loaded on it is Roon Server (I kept it minimal) not the full Roon, as it’s just a server running headless. When needed I use Remote Access on my MB-Pro to approach it. The music files reside on a Thunderbolt drive (LaCie).
The Roon database is on the MM (on its 256 GB internal SSD).

Weird, isn’t it?

By the way, it’s the 16 GB RAM i7 version. Latest OS always. No other software running apart from what the OS needs, plus of course what’s needed to approach it via sharing. I let Roon upsample everything to Double DSD, and it’s always doing that at c. 10x speed.

Not that weird, the issue comes with the Roon client (interface) you are running it headless as background service. Do the test, install the Roon interface, start using it, then you will see…

well, I was at a very low % after a reboot and Roon has slowly crept up to where I’m at 50% total again…

Roon need to fix this problem

OK, so I may be lucky (?) to run just Roon Server. That does then also mean that the issue must be outside the server function. Now, I know that grahics-heavy applications (like movies, games) sometime are very heavy on the CPU (meaning they are badly written, they need to hand this off the the GPU). Could this be an issue with Roon?

Have you tried to install & run only the server part, so not the full package? Is a download option when you get Roon.

Hi everyone

First, I’d like to say that we appreciate your patience as we’ve continued to investigate this issue. After gathering data from a number of reports, as well as our own testing, we’ve traced this issue to a specific chip that appears to not be handling Roon how we’d expect.

While we don’t have this resolved just yet, our QA team is in the process of acquiring this specific hardware for further internal testing in our labs. With this specific hardware in house, we believe we will be able to see first-hand why certain devices are not reacting to Roon the way we’d expect and can then get a report to our development team to resolve the issue.

Hardware-specific issues like this can require some in-depth testing to fully understand, so we can’t offer any specific timelines just yet. With that in mind, we want to assure you that this is a top priority for us. We want to make sure that we get this right, and we know it’s already taken longer than anyone would have liked.

The team remains confident that bringing this hardware in-house will be a big step toward getting this resolved, and we will be sure to keep everyone in the loop as soon as we have further information on this. Thanks again for the patience you’ve shown as we work to resolve this, along with the great details you’ve all provided to us to aid in our investigation.

Roon Technical Support

7 Likes

Thanks for the update, this would be greatly appreciated as It’s still an occurrence for myself as well sometimes.

Dylan,

Still experiencing this for quite a while on my 6-core i7 2018 Mac Mini. UI client only – core is running on a separate linux host. It seems to be consistent and easily reproduceable here. Love the Roon service, but this has been a continuous thorn.

Perhaps this thread provides a list of customers where you can help verify/correlate/observe this issue. I’d be happy to assist in any troubleshooting you need to do for verification, and I suspect others here would be happy to do the same.

@Dylan

Thank you for this detailed update, Your candor and transparency certainly helps. Most of us understand that these issues are often tricky and need to be replicated to be properly addressed.

I hope you can continue to update us a to your progress.

I have the same issue on iMac 2019

MacOS 10.15.5
iMac 2019 (Core i9 9900K/40 GB RAM/NVME SSD)
Roon 1.7 build 555

Thank you, I appreciate your efforts.

Roon UI just auto-updated on my iMac 2019 running Mojave (10.14.6) to build 571 - and CPU usage spiked again, at 420% according to iStat Menus.

Reboot, and presto - CPU usage back to the usual few %. It’s always the same thing…

My Mac mini is connected via ethernet. I used to leave wireless on to facilitate apple watch unlock etc.

Since turning wifi off the problem rarely occurs. When it does, turning wireless on, then off again usually fixes it without a reboot.

I leave wireless off most of the time now. I’m pretty sure even if you leave wireless on, you can turn it off and on again for a similar effect. For those of you also suffering through this, playing with this just might save you a reboot. Its not a fix, but it might help - if it does, it’s waaaaaay better than closing everything and rebooting.

Sounds like Roon are getting closer to finding and fixing the issue.

Mac OS 10.15.5
CPU usage over 300%.
Roon 1.7 build 571
Roon not playing anything.

try turning off wifi assuming you have an ethernet connection…this does seem to help

1 Like

I’m reporting the same problem. I just got a new MacMini 2018 a few weeks ago, and this is the third time I noticed the problem of Roon using 300% of CPU. MacMini gets hot and the fan runs wildly.

MacOS 10.15.5
Roon version 1.7 (build 571)
NUC ROCK core
MacMini is just a remote machine
MacMini is directly connected to ethernet, with wifi off.

Restarting Roon doesn’t solve the problem. Rebooting the MacMini makes the problem go away for a while until the next time.

I have another MacMini at my desktop which doesn’t seem to have the problem. Only the second MacMini attached to my TV has the problem.

I just removed Roon app, deleted the Library/Roon folder and reinstalled Roon. It is running at less than 10% now, so let’s see how it goes. I kept the old Roon folder with all the log files which I can forward to you if you want.

Just wanted to report that my other MacMini 2018 (exactly the same setup and used as another remote on my desk) had the same issue today. I have restarted and reinstalled Roon as with the other MacMini. It looks like the problem is still not resolved.

playing with the wifi won’t work as well for many of us…

I’d like to update the status that the same problem keeps happening in both of my MacMinis being used as a Roon remote. In my case, wifi on/off has nothing to do with the problem. The problem happens over time as the Roon is kept on for a while. Once it happens, the only fix is to restart the MacMini. Restarting Roon alone doesn’t solve the problem.

It’s been almost a month since the last official response by @dylan. Any updates from the support team? I was excited to get a new upgraded MacMini and this is a big disappointment.

1 Like

If you’re like me and have a Mac running Roon Bridge or Server that you’re not constantly watching, I cobbled together a small script that checks Roon’s processes for high CPU usage, and if any of them are unusually high it will send me an email and automatically turn wifi on and back off again. As is, the script is configured for my setup, a 2018 Mac Mini running Roon Bridge with wifi normally turned off. I’ve included comments in the script for how to change it if you’re using Roon Server instead. I use an app, LaunchControl, to automatically run the script every 15 minutes. Until the Roon devs can hunt the root of the problem down and fix it, the script lets me keep Roon Bridge running unattended on my Mini without me having to check periodically to make sure that the CPU usage hasn’t been running out of control for perhaps hours on end without me knowing it.

To be able to send mail with the mail command, you may need to setup Postfix and a relay through a service like GMail: https://www.justinsilver.com/technology/osx/send-emails-mac-os-x-postfix-gmail-relay/

#!/usr/bin/env bash
echo "====START `date`===="

#===========================
# The following lines get the CPU usage % of Roon's various processes.
# This is setup for a Mac running Roon Bridge. Please read the comments
# for how to modify this if you're running Roon Server instead.
#===========================

# Replace all instances of RoonBridge with RoonServer if you're running Roon Server instead
read pct_server name < <(top -l 2 -F -o cpu -stats cpu,command | grep RoonBridge | tail -1)

#=! If you're running Roon Server, uncomment the following line and comment out the line after.
#read pct_app name < <(top -l 2 -F -o cpu -stats cpu,command | grep RoonAppliance | tail -1)
pct_app=0

# This line shouldn't need to be changed in either setup
read pct_raat name < <(top -l 2 -F -o cpu -stats cpu,command | grep RAATServer | tail -1)

# CPU usage can spike temporarily while Roon is backing up. Replace "02" with the hour
# your automatic Roon backup actually runs.
HOUR=`date +"%H"`
BACKING_UP_STR=""
BACKUP_HOUR="02"
if [ "${HOUR}" = "${BACKUP_HOUR}" ]; then
  BACKING_UP_STR=", but it may be backing up"
fi

# You can change the cpu usage % threshold you want the script to take action with here.
CPU_THRESHOLD=50
SUBJECT="Roon high CPU usage${BACKING_UP_STR}!"
MY_EMAIL="youremailhere@yourmail.com"

BODY="RoonBridge: ${pct_server}%
RoonAppliance: ${pct_app}%
RAATServer: ${pct_raat}%"

if (( ${pct_server%.*} >= ${CPU_THRESHOLD} )) || (( ${pct_app%.*} >= ${CPU_THRESHOLD} )) || (( ${pct_raat%.*} >= ${CPU_THRESHOLD} )); then
  echo "${BODY}" | /usr/bin/mail -s "${SUBJECT}" "${MY_EMAIL}"
  echo "Exit code for mail was $?"
  echo "Roon seems to be using lots of CPU${BACKING_UP_STR}!

${BODY}"

  # If you normally have wifi on, just swap the 2 networksetup lines and fix the echo lines.
  echo "Turning wifi on and wait for 10 seconds..."
  networksetup -setairportpower en0 on
  sleep 10
  echo "Turning wifi back off..."
  networksetup -setairportpower en0 off
else
  echo "Roon seems to be ok!

${BODY}
====END===
"
fi

2 Likes