Mac Mini Late 2012 Roon 2.0 Crashing [Investigating]

So wiped the Mac mini and did a complete reinstall of Mac OS Catalina (the most recent version of MacOS this older mini will support).

Was able to re-install Roon core and bring library back from a backup.

Now it seems I’ve got different problems. I’ve got audio devices that seem to come and go. Some devices will play briefly … then stop. I go back into Roon only to discover the device does not show up. Then I try again later and it returns.

I’m currently doing some network troubleshooting but so far everything appears to be fine. I can ping all the devices without issue from the core. Some devices are wired … and others are wireless. Doesn’t seem to make a difference.

Here’s a screenshot of audio devices.

And another screenshot just a minute later.

I also have a RPi that is no longer showing up in Roon, even though I can access it via the browser from the Mac mini running core.

Seriously frustrated now! :frowning:

And to make things even more interesting … I open Roon and start to play something and it appears to be playing (the timeline in the Roon UI is showing it playing and moving in time) but the devices are not outputting any sound.

I’ve tried this with both the Chromecast devices (using both Toslink and Analog out) and the microRendu (connected to a Lyngdorf and to a Chord Mojo) and no output even though it appears to be playing.

I did manage to get the RPi recognized (after reboot of Mac mini core and RPi) and it does work now (go figure). Still can’t get the mR nor chromecast devices to output any audio.

I had something akin to that the other day, Roon showed playing but no sound. It turned out to be the dac that needed rebooting. Doesn’t sound like your case, though.

Thanks … the microRendu feeds the Lyngdorf directly (and uses it’s excellent DAC).

I have an assortment of Chromecasts Audios around the house (and they are also merged for “whole house” entertainment). Here’s what they are connected to:

  1. Cary Cinema 12 PrePro
  2. Lyngdorf TDAI 1170
  3. Peachtree Deep Blue
  4. Peachtree M24

These all use Toslink connections to the devices respective internal DACs. I tried to plug headphones into the Chromecasts as well to see if there was any analog output and no luck with analog either.

I don’t think the Lyngdorf DAC is an issue since I’ve also got a WIIM Mini that feeds it via toslink and it works just fine, but I restarted it anyway. Oddly enough, after a restart of power on EVERYTHING the chromecast that feeds the Cary and the Deep Blue are working … but the other two are not (perhaps it’s a chomecast issue … next step is reconfigure all chromecast devices).

But most strange is the microRendu. I’ve tried rebooting, etc. but still can’t seem to get it to stream. The UI via browser works fine and everything seems to be working. I looked through the logs (as much as I understand them) and nothing jumped out at me.

I think I’m going to take it to my local HiFi shop and have him play with it to see if perhaps by chance something went wrong with it.

The good news is Roon Core hasn’t crashed yet … so the clean install seems to have eliminated the problem. Now if I can just get the devices working again.

Any other advice would be welcome.

1 Like

Hey @Eric_Taylor,

Glad to hear we’re making small steps towards getting you back to your music!

If you could share a timestamp of when this happens, and when it seems like the microRendu should be outputting audio. From there, we can enable diagnostics on your core to take a closer look :+1:

As we say in Hawaii … I think the menehune are up to no good!

I did some troubleshooting on the mR and seems that firmware update and reboot fixed the problem. Now the mR has worked without issue for the last 12 hours.

Now I think I’ve got a completely separate problem since ALL of my chromecasts have gone missing (not only in Roon, but also in my Google Home app. What the … !!?). Anybody else ever see this with Chromecast devices?

I’m also having a few dropouts with RPi which is connected via 5Ghz Wifi even though it’s only about 4 feet from my router/AP. I figured Wifi would be better an keeping any electrical noise from router away, but maybe my router (Asus RT-AC88U) occasionally “chokes” on the packet volume?

Also, just got this when restarting Roon Core:

Was pretty quick to update. Stay tuned!!!

1 Like

Hey @Eric_Taylor,

Thank you for the update and for taking the time to test!

Do you have a lot of other devices on your 5G channel? It might be worth testing on the 2.4G channel to see if anything changes in behavior.

Are you able to share a specific timestamp of when this occurred? Or, if it happens again, please share that info here. it would be helpful to enable diagnostics to take a look over your Roon logs to see what might be going on :+1:

If it it does it again I’ll get a timestamp and let you know. So far the troubles (other than the lack of chromecast devices) seem to be working themselves out.

I will try switching the RPi to 2.4 Ghz.


1 Like

Sorry for the delay … but I’ve been experimenting with network to see if it’s a network issue or something else. I’m still having issues with some of the audio devices (chrome cast and RPi) disappearing from Roon, even though I can see them online (I’m able to ping them on network etc.). I haven’t been able to figure out if there is anything specific that results in them disappearing but it seems totally random. Sometimes there are there, then they disappear.

The microrendu and apple devices always show up so it seems to just be the chromecast devices and the Raspberry Pi.

And like I said … even though they don’t show up in Roon, I can see them on the network.

Anybody have any other ideas to check for root causes for this?

Hey @Eric_Taylor,

Grabbing time stamps would be helpful to further investigate why your Chromecast and RPi are dropping connection. If you’re able to share some more specific dates and times, that would be a good next step.

With that, another test I’d be curious to know, is if you experience this same issue while running Roonserver (rather than running the Roon all in one.) You can learn more here:

Let me know if you’re able to test this out :+1:

How do you recommend I grab the timestamps … what logs would you like me send over? I’m not that familiar with MacOS so it may be a bit of a learning experience. Half the time I don’t even realize the item is gone until I go in later and attempt to stream to it.

Didn’t realize “Roon Server” (with no UI) was available. I may give that a try since it’s on a headless Mac (I usually just remote into it).


OK … deleted full Roon Core on headless mini and installed Roon Server. Everything worked great until I tried to restore from backup, after which my Roon clients could no longer see the server. So deleted the server, cleaned up mini and reinstalled. I also switched my RoPiee to use 2.4 Ghz wireless instead of 5Ghz.

It’s only been about an hour but so far so good!!! Only downside is loss of some playlists and having to reimport all my local music (which shows up under “recently imported” now). Not a big deal but something people should be aware of.

Hey @Eric_Taylor,

Thanks for the above info! I’m glad to hear Roonserver is functioning better for you. It’s interesting to hear loading a prior backup brought you back to connection issues. It could definitely database related in this case.

If you’d like to continue troubleshooting, we could get a copy of the database causing problems uploaded and have our team take a closer look into. Let me know and we can move forward :+1:

Aloha Benjamin,

So the problems are far less frequent but are still occurring though not very frequently. For some reason the Chromecast endpoints and the RPi occasionally disappear from Roon, but I can still see each of these devices on the network (I can ping all the devices and I can still see/manage the chromecast devices via Google Home app, and I can manage the RPi via HTTPs), so it doesn’t appear to be a network issue.

If you can provide detailed instruction on how to upload the database I will provide to your team for further analysis.


Hey @Eric_Taylor,

Sorry to hear your issues persist! To confirm are you also still experiencing a crash on your mac mini? Or, are you now running into connectivity issues with your endpoints?

If possible, getting a timestamp of when this issue occurs would be helpful - I don’t think we’d need to scan your database with an issue like this :+1:

Now that I’m running the server version I haven’t had any crashes. It’s been totally stable.

Just problems with the chromecast audio devices and the PiFi (RPi) disappearing from Roon. I don’t have timestamps since I don’t know when it is occurring. Sometimes I go to use Roon and stream to one of these devices and they are there, other times they are not. When they don’t show up I usually run a ping test and see if I can access them via web/app/etc. to make sure they are still “up” on the network. Connectivity doesn’t seem to be the issue.

The MicroRendu and the WIIM mini have been rock stable (they are always on the Roon Audio Device list). Occasionally one of my Chomecasts will appear, but the others don’t (and the grouping disappears).

Just let me know next steps to troubleshoot.

Hey @Eric_Taylor,

Thanks for the info! After taking a closer look into RAAT diagnostics, I am seeing a few reoccurring network-based errors popping up, which seems odd if you’re able to ping the devices outside of Roon.

If possible, could you test our hardwiring the devices in question directly to your router, and see if the behavior changes?


The chromecast audio devices don’t have a wired option (they only work via wireless). The only control interface is via Google Home app, but I can still ping the devices to see that they are active on the network.

I’ve plugged the RP in to ethernet and will see if that alleviates the issues there.

1 Like

Hey @Eric_Taylor,

Are your Chromecasts grouped via the Google Home app?
I would try un-grouping there if so and see if they appear individually.

With that, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Mac’s firewall.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Lastly, it could be a simple case of interruptions over Wifi. Do you have the option to switch between 2.4 and 5hz? I’d test the devices on both to see if your issue continues. After that, even temporarily moving them closer to your router/core would be helpful to know how things function.

Let me know, thanks Eric!

I’ll ungroup the chromecasts (they were grouped using Google Home app).

The macmini has the firewall turned off and not antivirus. After reformatting I’ve left it pretty clean.

It could be Wifi issues but it it was Wifi related the WIIM should go offline as well and it’s been rock solid. Of course it could be some issue with the wifi radios in the chromecast. I’ll see if there is any way I can setup some monitoring on those.