Mac Mini Late 2012 Roon 2.0 Crashing [Investigating]

I’m having similar issues.

Roon Core Machine

Mac mini (late 2012), 2.3 GHz Quad-Core Intel Core I7, 16 GB RAM, Mac OS Catalina 10.15.7

Networking Gear & Setup Details

Asus RT-AC88U Router

Mini is connected via ethernet.

Connected Audio Devices

microRendu (ethernet) - feeds Lyngdorf TDAI-2170

Raspberry Pi (ethernet) - Feeds Cary Cinema 12 Processor

Chromecast Audio (4 total wireless) - Feeds Peachtree M40, Peachtree Deep Blue, Cary Cinema 12, and Lyngdorf TDAI-2170

Wiim Mini (wireless) - feeds Lyngdorf TDAI-2170

Number of Tracks in Library


Majority of library via Tidal. I have an assortment of ALAC, FLAC, and even a handful of DSD tracks stored on Drobo connected to the Mac Mini via thunderbolt.

Description of Issue

Roon 2.0 runs very slow and ultimately crashes. It appears there may be a memory leak as the Mac mini reports low resources as Root runs over time. Eventually it crashes and I get a massive crash report that I can share later.

Hey @Eric_Taylor,

I’ve split your response into a new thread for better visibility. If you could please upload the full system crash log here:

That would be helpful. Thank you!

Apologies for the delay. I couldn’t find the thread again for some reason but now that I’m back I see it. I will upload the next crashlog as soon as it occurs (I’ve been doing restarts on daily basis).

Thank you for your assistance!

The error report has been uploaded to the link provided.

@Eric_Taylor thank you for submitting the crash report! We’re currently investigating this issue further as we’ve seen a handful of reports come in with similar experiences.

If possible, could we also grab a set of manual logs from your Mac core? Please use the directions found here and send over a set of logs to our File Uploader

Other than that, I don’t yet have any immediate next steps for you, but I will keep you updated as new information is presented :+1:

Thanks for your continued patience while we get to the bottom of this!

The logs have been uploaded under

Another issue … when Roon is working it seems to have some issues staying connected to some of the endpoints (they just vanish … then reappear). My network hasn’t changed and I never had these issues prior to Version 2.x

Also, when using some of these endpoints I get dropouts. I’ve done network testing and I don’t believe it’s a network issue. I think it’s the mac mini core “stalling” from what I’ve seen.

Do you have any other problems with Catalina? I ask, because until I did clean install of Catalina on my late 2012 mac mini, I had many problems with it. Basically, after a certain time it would just stop and the only way out was a hard reboot.

I have a 10k track library running under Roon core, and I have no problems.

It’s not a clean install … it was just the upgrade. This was actually a computer I used as a HTPC for some time until I upgraded. Now all it does is serve Roon but a lot of the other “junk” is still on there. I’m guessing a clean install might be a next step if support can’t figure out the issue.

When Catalina was released, IIRC, a couple of major changes in approach were implemented by Apple.

  • They split the OS and data into two partitions.
  • They moved from HFS to APFS, although this would not have changed when you upgraded to Catalina from Mojave.

Its not that difficult to do a clean install, there’s plenty of information on Apple support pages.

1 Like

Hey @Eric_Taylor,

If possible, could you please snap a screenshot of your Audio MIDI setup with Roon running under the same conditions that would lead it to a crash?

I haven’t touched the setup since I don’t output any audio from the computer directly.

yeah … I’ll probably go that route if/when Roon Support can identify the issue. In the meantime I’d like to see if we can determine root cause (best for me and the community).

At that point I may just do a clean install given I don’t use the box for anything else.

1 Like

Hey @Eric_Taylor,

You’ve attached a screenshot of your sound settings rather than the Audio MIDI settings. Head into Utilities>Audio MIDI and let me know how things are looking :+1:


Catalina changed the navigation. I sent what appears when clicking on “Audio Midi Setup” in the Utilities folder. Here’s a full screen shot where you can see the open application is “Audio Midi Setup”.

Am I in the wrong place. Catalina has made this much more difficult IMO

Hey @Eric_Taylor,

Ah, my apologies! You are correct here.

The reason I ask - we’re investigating whether there might be some issues between Roon and virtual audio devices. Seeing that you have Sunflower which falls into this category, would you be able to temporarily remove it from your Audio Devices, and see if your crashing occurs? I would give your Mac Mini a reboot after removing the devices, and before starting up Roon.

Let me know! :+1:

Benjamin … funny you mention that since I was actually looking at trying to do that earlier today but couldn’t figure out how since it doesn’t show up in my applications folder. I’ll look into that further and if that doesn’t work I will likely just reformat the computer and reinstall the OS (unless you really want to figure out what the root problem is … I’d love to know but I’m getting anxious to have a trouble free server.

OK … I’m struggling to remove Soundflower.kext. I can’t do it via the GUI so I tried to do it using terminal but got the following:

sudo rm -rf /Library/StagedExtensions/Library/Extensions/Soundflower.kext

rm: /Library/StagedExtensions/Library/Extensions/Soundflower.kext/Contents/_CodeSignature/CodeResources: Operation not permitted

rm: /Library/StagedExtensions/Library/Extensions/Soundflower.kext/Contents/_CodeSignature: Operation not permitted

rm: /Library/StagedExtensions/Library/Extensions/Soundflower.kext/Contents/MacOS/Soundflower: Operation not permitted

rm: /Library/StagedExtensions/Library/Extensions/Soundflower.kext/Contents/MacOS: Operation not permitted

rm: /Library/StagedExtensions/Library/Extensions/Soundflower.kext/Contents/Info.plist: Operation not permitted

rm: /Library/StagedExtensions/Library/Extensions/Soundflower.kext/Contents: Operation not permitted

rm: /Library/StagedExtensions/Library/Extensions/Soundflower.kext: Operation not permitted

Not sure what I’m doing wrong here.

Dear Eric_Taylor:

The current developer of Soundflower has posted instructions for removing the Soundflower software at GitHub. Here is a link to the instructions: Have you tried creating a new temporary local admin account on the Mac mini to remove these files?

Best of luck!

That’s beginning to look like the easiest option, isn’t it ?

No such luck. For some reason the system won’t let me delete the file. Looks like it time to reformat the computer.