Mac OS crash - Albums focus

Roon Core Machine

Macbook pro 2018 running Mac Os big sur 11.6.3 (20G415).

Networking Gear & Setup Details

Connected Audio Devices

System output

Number of Tracks in Library


Description of Issue

When I try to focus/filter on the albums page, Roon hangs. This happens whether I am playing something on the system’s output or not . So far I’ve tried filtering by Genre and then by Format; by Genre and then Stars; with the same outcome.

Any help from support? @ashley

Hey @Elece,

Thanks a lot for reporting this and sorry about the trouble. We’d really like to help.

If I understand correctly, when you take certain actions in Roon (like using the focus or filter features on the album view), Roon freezes.

Is there any way you can get out of that state, or do you have to quit the app?

You mentioned that you get the same outcome with different filtering. I wonder, could you please:

  • restart the Roon Core
  • reproduce the behavior
  • write down the local date and time when Roon crashes
  • grab a set of logs, zip up the entire folder and upload it to our drive

We’d love to take a look and see if we can figure out what causes this.

Hello Beka, thank you for the response. Yes, for the moment I’ve only identified this problem when focusing using two filters on the albums section. Roon completely hangs and the only option is to force quit the app. I’ve reproduced the error at 10.09am local time and have uploaded the logs (my email as the zip name). Let me know if you find the problem. Thank you

1 Like

Hey @Elece,

Your swift reply is truly appreciated :relaxed:

I’ve passed on the logs to our technical team and I’ll follow up as soon as I hear back.

(Please note they only get back to work on Monday.)

Hello. Any news on this?

Any news @beka ?

Hey @Elece,

Thanks a lot for following up and sorry about our silence. Please, allow me to circle back with our technical team and get back to you.


Hey @Elece,

Thanks for your patience while we investigated this. We believe that some of the work that went into the latest release, might help with the issue you’re experiencing.

Would you be able to please update to the latest build? All the details about it are here.

Hello. Unfortunately, updating didn’t resolve the issue. Tried focusing on Classical + Picks and Roon hanged again.

Hey @Elece,

Thanks so much for keeping us in the loop. I’ve checked with our technical team and we think the latest build (913) should help with this. Could you please try the update?

Hello @beka. Updated and same result. The bug fixes are clearly not addressing the problem with my system/installation. Let me know if you have any news/hotfix.

Hey @Elece,

Thanks for letting us know of thee effect of the update — next to none. Since we’re positive that the changes we’ve made should have an impact on this issue, I was wondering if you’d be able and willing to share another set of logs. The instructions are the same:

  • restart the Roon Core
  • reproduce the behavior
  • write down the local date and time when Roon crashes
  • grab a set of logs , zip up the entire folder and upload it to our drive

Many thanks :bowing_woman:

Sorry for the delay, I was on vacation. Logs uploaded.

Thank you.

Hey @Elece,

Welcome back home :house_with_garden: !

Thank you for the logs — we got them. They are now with our technical team. I’ll follow up as soon as I hear back.

Please, stay tuned :slight_smile:

Hi @Elece ,

Are you still seeing this issue on the latest Roon release? It doesn’t look like there were any crash traces contained in your previous log set, do let us know if this is still ongoing, thank you.

Hello @noris . I’ve just updated and the crash still exists. Don’t know why it is not on the logs, I may have forgotten to reproduce the error prior to copying the logs or something like that, but the problem persists on the latest version.

Hey @Elece,

No worries at all. If the issue is still happening on this very latest build, would you please make sure the crash happens, write down the local date and time and upload those logs again? The drive is the same.

I did a fresh intall of the operating system for other reasons and for the time being, it is working fine. I’ll re-ask if I see the problem again.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.