Mac Roon client fails to connect to remote Roon Core

I’ve experienced the following multiple times, although without an obvious repeatable pattern. I have the latest Roon Core running on Ubuntu on an Intel NUC. I can connect to it reliably from Android Roon clients. However, when I start Roon on my Macbook Air (Sierra 10.12.1) on the same wireless network, Roon hangs waiting for the remote core. Even though that core is happily streaming music under the control of my Android phone. I’ve been able to connect to that Core from this Macbook before. Can’t find anything about Roon in the Macbook’s system logs (at least, nothing obvious). Then, waiting a few minutes, it all works. Baffling.

Hi @Fernando_Pereira ----- Thank you for the report and my apologies for the inconvenience here. To help me better understand this issue you are experiencing, may I kindly ask you to please provide the following information:

  1. An expanded description of your current setup as here. The more detail you can provide, the better.

  2. Please provide the details of your network configuration/topology, as well as provide some insight into any networking hardware you may be implementing in your setup. I want to get an idea of how your devices communicate and what tools you are using to make those communications possible.

  3. Can you think of anything that has changed in your setup since you’ve noticed this problem? OS updates? Firmware / driver updates? New equipment (both audio and networking related)?


Thanks, @Eric! My setup is as follows:

Roon Core version 1.2 (build 165) stable (64 bit) on Intel NUC (i5-6260U CPU @ 1.80GHz, 4 cores, 8GB RAM, 220GB local SSD), Ubuntu Linux 16.04.1.

Music storage (watched folder) on SMB share from Synology DS216+II, DSM 6.0.2-8451 Update 5.

All of the above connected with Cat 6, Netgear ProSAFE 1Gb switches, with routing and DNS supplied by an Ubiquiti EdgeRouter PoE 5.

Roon clients, all 1.2 (165), connect through a UniFi AC UAP-AC wifi access point connected to the router with Cat 6. Android clients work fine. The client that gets stuck is on a MacBook Air (13-inch, early 2014) running macOS 10.12.1 (Sierra).

Roon endpoints are Sonore microRendus with the latest software, all on the same Cat 6 network as the NUC and NAS.

The Mac Roon client does not always get stuck. Just now, it was live. I exited it. On starting, it got stuck looking for the core. Stayed that way as long as I was composing this message, including looking for all the relevant info. I quit the stuck client. I restarted it, it connected to my library fine.

Any other info you need?


I wonder if its taking some long delay to get and assign the DHCP address and router/gateway/ info this not being able to see the core as a result…Have you tried setting a fixed IP address and DNS settings?

All the non-mobile devices on my network (NAS, NUC, microRendus) have fixed IPs (just double-checked), very easy to do with the EdgeRouter.

Hi @Fernando_Pereira ----- Thank you for the follow up and taking the time to answer my questions. I would like to gather some logs form this device so our developers can have a closer look at what may be causing this problem to occur. I will be contacting you via PM momentarily with instructions.


Did you find a solution? I’m experiencing the same issue with a similar setup (Core on Windows 10 PC with Music on Synology 414+). All my iPad clients connect without problem, but the MacBook is very unreliable.

The one problem I found eventually was that the Mac built-in firewall was somehow changed to block Roon incoming connections. I did not do that, so it looks like some bug somewhere. When I manually configured the firewall to let Roon accept incoming connections, the problem disappeared and has not returned.

good for you¡¡¡ I´m hopefully getting help shortly on solving my issue, to see if support can help me figure out what happens when using my main remote (samsung tablet) with core, which is one of the elements of my setup that has been causing most of my troubles, on the other hand, do you happen to have some Tidal playback intermitence?? trouble playing files and getting the Tidal playback error message?

I don’t use Tidal.

I´ve found it to be quite nice, the sound quality is really good, and the library you have available is rather large. Tidal is what I usually use roon for. That is why it is such an important part for me. Anyway, it´s good when things work the way they should. It´s good you had your issues sorted out.

I typically listen to pretty exotic jazz, modern classical, and world albums that are not well represented in Tidal or other streaming services.

Thanks a lot Fernando, this was the same firewall issue. After manually changing the firewall configuration for Roon to accept incoming connection, it’s now working.

It used to work before and I didn’t make any changes to the firewall configuration. Could be useful to add this to a FAQ…

Glad it worked!

There’s some info on Roon and firewalls:’t_Roon_Remote_Connect%3F

but nothing on the firewall “spontaneously” starting to block Roon. I don’t know if that’s a Roon bug, and MacOS bug, or a side-effect of installing new Roon or MacOS versions.

FYI, I just experienced something like this. Mac client couldn’t find the core server. iOS client found it fine. Mac was searching for about 30 minutes with no success. Having the mac client search for a new server fixed the problem (i.e. it then found it).

Setup: Core server on Ubuntu w/ fixed IP address (private IP, not public). Hardwared ethernet. Music collection on Synology, also ethernet. Fancy router (Mikrotik), but not firewall. Mac on same network connected via WiFi served by apple airport in bridge mode.

I was having the same problem. My MacBook Pro couldn’t connect. Now I know why. My main computer with the Roon core was connected via ethernet and my laptop thru wifi. Ethernet and wifi have a different i.p. address so Roon couldn’t connect. If you change the ethernet on your main computer to wifi the problem should be fixed. So in short the i.p address on both machines should be the same for Roon to connect to the remote.