Macbook no outputs

Roon Core Machine

Mac Studio, latest MacOs 13.1

Networking Gear & Setup Details


Connected Audio Devices

none on MacBook, also M1 13.1

Number of Tracks in Library


Description of Issue

I have had my Macbook m1ProMAX for a year now. From the beginning I could only use it as a remote since it only shows the Mac Studio’s outputs where my Roon Core ist installed.
I gave it another try, deleted the Roon and Raat folders in my library, emptied the trash, reinstalled Roon but nothing helps. Tidal, Qobuz, Apple Music, Spotify, everything works, but not with Roon.

Since I already payed for a lifetime of Roon troubles, please help


Have you enabled your MacBook’s outputs from Settings>Audio on the MacBook?
My settings page looks like this:
(I don’t have my DAC connected to the MacBook right now so my outputs are not enabled)

A Screenshot of your Settings>Audio page might help us here.

of course, but “This Mac” is not the MacBook, but my Mac studio core.

I can’t even see my MacBook pro’s outputs.

My morning brain misread your post.
I thought you couldn’t see the MacBook on the Studio or something. I’m not even sure what I was thinking :sweat_smile:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.


I already posted about that, but still got no help. My core is a Mac Studio ultra with 128 GB RAM. My iPads work fine, but on my MacBook Pro M1 under My Device I see only my core’s outputs. I cannot play Roon via speakers, headphone out, even not via connected DAC. I never see these outputs. I renamed my core system output, the MAC-adresses are not the same.

Mac Studio core:

MacBook Pro 16 M1 Max:

As you can see, my MacBook Pro only shows the Mac Studio core’s outputs under “this Mac”.

Please help. I have been searching for a solution for a year now…:frowning:



Add images

Hi Kurt,
I’ve seen this once at another user. I do not remember what was the solution :frowning: I’ll try to search. It was something caused by the airplay sharing preferences on both machines having the same apple username. If I remember the right way he gad to disable airplay and nearby sharing from one account. If in your case they are not disabled pls try and pls let me know if any change. Reboot after changing sys prefs.

Thanks for the fast answer, I’ll look into it.



Not about the airplay and handoff, but he did a new username and that was the solution.

Quoting his problem:
Going to Settings->Audio I was surprised to see the Mac Mini under “this Mac”, instead of the M1 MacBook. A safety check intsalling Roon on my wife’s MacBook (she got my former 2019 Intel one) shows the MacBook under “my Mac”.

hope it helps


you’re a genius! Made a new account, switched to it, didn’t even have to configure Roon, just started it, and my outputs are there and working!

Thanks a million times, cheers



Happy listening

Hi, I’ve reopened your original topic and merged into it.

Let me tag @support for you.

so not seemless, found some drawbacks.

I tried to rename my original account and user folder. It seems that the user folder is the issue. If I just change the name Roon won’t find the outputs. If I change the folder Roon will find the outputs but I would have to spend a day or so to change all licenses, passwords and so on. So at the moment I will use one account for work use and one for Roon playback and still hope for a better solution.

But thanks anyway, it’s still a great workaround…



I think I had the same problem. And did not find a way to have 2 users running in the same time on the same machine. Or run a user and just one app as another user. Anyway it should not behave in this way but I guess this is osx. Maybe a fresh roon server install would work just with the username change

stranger but even better.

I restored now my original account, and after finding the outputs on my MacBook Pro (maybe also because I used airplay to mirror it on my tv), now it’s showing the outputs, but not under “my Mac” but under the “my mac where it shows my core Mac Studio outs”. So it seems and I hope I won’t have to switch to listen to Roon on my MacBook. See my new outputs:

1 Like

quite a mess

I hope so.

I remembered now. I was struggling with osx users while having hdds sharing problems. The end of the trouble was when I shut down all osx sharings and users and etc from the Roon Core mini… but I’m using that mini only for roon.

alas, the outputs have disappeared again. Seems at the moment I will have to switch accounts to use Roon. Hoping for a fix any time soon…

But at least I can use it with a workaround, thanks to your tip.



1 Like