macOS USB bug (thank you fixed) COST ME $!


After several months of posting to THIS message board (and support) AND to some Roon FB groups, I gave up on Roon for a few months because all my devices (OSX, two W10 machine) didn’t work with my PS Audio Stellar DAC

I was TOLD it was my DAC, so I replaced it, costing me $$$ to a nice Mytek (which I am happy with)

Then the Mytek started to not work with Roon USB from both OSX and W10. And I opened up new tickets, and sent a bunch of logs — which sounds like it helped find an issue

And now I find it was a Roon bug. I think you owe me a few months free……



Roon Build 904 is now rolling out for macOS only. No updates to Windows, Windows (64 Bit), Roon OS, Linux , Android or iOS this time.

Version 880 of Roon Bridge is also available for Windows, Windows (64 Bit), Roon OS, Linux.
All platforms and apps should update automatically.

You can confirm you’re running Build 904 by checking the About section of Preferences.

Changes for Build 904:

  • Resolved inability to play to local audio zones on MacOS 10.13 and older

Are you sure this bug fix related, as it’s to fix an issue with older versions of MacOS …

And this 2019 post states a later version…


And the “fix” contained in build 904 for 10.13.6 and older was ONLY because it got messed up with build 903 the day previously…

Not with prior builds…to my knowledge.


I feel it is broken again in 2.0

I upgraded to 2.0, and now my W10 machine can not connect over USB. Same thing as before: OS sounds come through, other apps play through USB normally

Thankfully my DAC also has Ethernet, else I would be dead again

If you look me up on this board, you will see I have had on and off problems with ROON working with USB with 3 different DACs:

PS Audio Gain Cell DAC – USB worked sometimes during 1.8, and I finally gave up and sold it

Schitt DAC - like the PS Audio, it only worked for some of the 1.8 releases. I moved it upstairs for a different TV

Mytek Brooklyn Bridge - same problem (1.8 and 2.0). I can only get Roon USB to work if I plug in the core, none of my Mac or Windows laptops connecting to that core work.

In EVERY instance, in both MacOS and Windows, the base OS (MacOS, Windows) sees the USB, can can play sound. Also, other apps on those laptops (Amarra, BitPerfect, Audrivana) work.

I am convinced there are bugs (some original, some fixed, and then new ones) that are causing USB to not work with Roon.

So, I have been using Roon through Network to my Mytek, and that works 99% of the times. Sometimes music mysteriously stops playing.

I love Roon, but I have had a really crappy experience with it and all of my DACs.