Major problems with Roon (new user) [Resolved - Build 222]


Two days ago I registered to roon. I have both Tidal account (about 500 albums) and about 1000 albums in iTunes. I installed Roon on a new Qnap ts-251+ (4 cores, 8G RAM and SSD external disk for the library) and I’m using my new MacBook pro as a client. Both updated to latest version. I only configured my Tidal account and added a few (less then 10) high res albums and I’m already having major difficulties. I was hoping to get some help because when it works I really like the experience but more then 50% of the time it doesn’t work:

  • A couple of albums on my library (not from Tidal) are timing out when I try to access them (more then 50% of the times I’m trying to view them). It happens mostly on specific albums. I tries to completely start from scratch (delete the library and start new) but it didn’t help. Also, it doesn’t seem that the NAS is under a lot of load when it happens.
  • The second issue is much more serious. When I try to play on the client my high res audio, more then 60% of the time I get some kind of static noise in the form of beats or stutter (not sure how to describe it) in various levels - most of the time it completely cover the played music - and sometimes the playing is completely stopped and the sound devices disappear from the bottom toolbar for several second. It doesn’t happen when I play lower resolution (48/16 flac) or Tidal.

In terms of audio configurations, I use the default System Output of BuildIn Output devices with default settings.

As I said in the beginning, when it works it’s really nice and I love the experience, but currently it’s unusable. I would appreciate any help.

Thanks in advance.

How does your network configuration look like?

Hey Harry,

Thanks for your response. I have an Airport Extreme that acts as the router, the Qnap is connected to it via ethernet and the laptop is using Wifi.

I seriously doubt though that the problem is the network. During both of these problems I was connected to the Qnap admin interface (web) and had a SSH session open. Also, the Roon server itself wasn’t dead. When the album displaying problems occurred I could (in many cases) listen to other albums.

While the problems occurred last night I was monitoring the RoonServer.log but there was nothing interesting, just Initializing, Running, etc. When I looked again now I saw a few errors:

[AAC/oop] GOT 44100/16/2 7410 samples mf=0x7f786c0965c0 underlying_objecttype=2 underlying_sfidx=4
[AAC/oop] GOT 44100/16/2 3575 samples mf=0x7f7850109200 underlying_objecttype=2 underlying_sfidx=4
[AAC/oop] GOT 44100/16/2 14853 samples mf=0x7f788c127640 underlying_objecttype=2 underlying_sfidx=4
[AAC/oop] GOT 44100/16/2 19490 samples mf=0x7f7868009590 underlying_objecttype=2 underlying_sfidx=4

But I experience both problems now and the log doesn’t output anything so I don’t know are these errors.



Just as a test can you connect your laptop via Ethernet?


Hey Russ,

Not in the next few days. It requires an adapter that I have to buy and it’s a holiday here. I will try it (just out of curiosity) in a few days.

However, I did try pinging the Qnap while these problems occur (they seem to happen 90% of the time now) andI never missed a ping, with more then 90% are between 1 - 4 ms and only a few reaching two digit. It also doesn’t explain how come only the same 2 albums are timing out. Many times it doesn’t show the disconnected screen, it just hangs on “Loading Album…” (even after restarting the client).

Regarding your second issue, use Built-In Output in Settings > Audio, click the gears icon next to it and select Device Setup. Under the Playback tab, toggle on Exclusive Mode.

Let’s tag @crieke and ask his help regarding the NAS. Crieke, is this a Jumbo Frames issue?

Cheers, Greg

Thanks Greg :smile:

This indeed solved my second problem.

Hey Greg, @crieke,

I also checked my network settings in the NAS and I don’t have jumbo frames enabled. my MTU is 1500.


Any way possible you can move your server to a different system that is more suitable for your env?
Just for testing.

Hey Fernando,

Thanks. I’m not sure what more suitable means, however I only have the Qnap as a server that can be connected directly to the Receiver (which I still have to test).

The Roon knowledgebase is a good starting point. This What are the_minimum requirements will tell you your NAS is underpowered to run Roon. That isn’t to say some have used lower powered devices sucessfully but you seem to be having performance related issues.

1 Like

This. To me it looks like your NAS is under powered.

My sol opinion… I keep thinking that people putting their music server on a NAS is just a big mistake.

Hey Fernando and Tony,

Thanks for the info. I’ll make sure to consider that when I decide wether or not to keep the account.

However, My remaining issue (timeout rendering specific albums) is not a power issue. The NAS is relatively idle (in all aspects - CPU, Memory, IO and general load).

@support may be able to help but they will need to know the albums, format, resolution etc

Thanks Tony,

@support, The album that it happens the most is Sigiswald Kuijken/La Petite Bande playing Matthaus Passion by Bach (see attached screenshot). The format is flac 192/24. I’m not sure what do you mean by resolution.

Hi @Haim_Ashkenazi
How did you check that it is not under heavy load? Did you try to open the “Resource Monitor” in the QTS and watch the CPU graph in the “system resource” tab? Check if there are any spikes when trying to play that high-res album.

Regarding your SSD: I am not sure if I understood you correctly here. Is your library (=audio files?) stored on it or the Roon database?
Where did you store your music files?

Hi @crieke,

I was looking at the resource monitor many times in the past few days. As I’m writing this response I’m trying to access several albums including the two problematic ones. The big(ish) spike in the middle (reaching about 60% CPU) happened when I was trying to access one of them and it didn’t succeed (it stayed at Loading Album… a long time after the spike was over. Also trying to go to other albums didn’t succeed. After a minute or so I was able to browse more or less freely but when I tried to access the second problematic album it got stuck again (this time no spike at all). During this time I was able to play and stop the music without a problem. BTW, it’s been several minutes since and I still can’t browse (although as I said I stop and start the music at will).

Here’s the screenshot:

The database is located on the SSD (as the documentation instructed). The flac files are on the regular 7200 RPM disks.

Thanks :slight_smile:


Is it possible to connect an USB audio device directly to your QNAP? (best would be if it is capable of 192khz/24bit).
I would like to rule out any network issues and in this scenario everything will happen locally on your qnap.

Hi @crieke,

I’m not sure I follow. The problem happens regardless where I play or even if I play. This morning I played directly via the Qnap HDMI and it still occasionally timed out the album. There’s something in these two albums :frowning:.

BTW, only one of them is 192/24. The second one is 44.1/16.

Thanks :slight_smile:

ok, understood. :slight_smile:
Just for confirmation: Other HighRes files play fine without issues?
Do these 2 said albums have anything in common?