MCH from Roon to XMC-1

How can I get Roon to send MCH to the hdmi input of the XMC-1?



The following Knowledge Base (KB) article may help:

No joy - it doesn’t address hdmi over Ethernet to xmc-1

Hire a networking professional or custom installer. Running HDMI over Ethernet is non standard networking unrelated to Roon, thus not the purview of Roon support.


That’s an unsupported configuration. I assume before attempting this you have successfully had multichannel working using a direct cable connection?

Direct cable meaning hdmi out of computer to hdmi in of xmc-1? I haven’t tried that as I would have to move a computer next to the reciever. I don’t want to move the Roon Server as it is large. I could move a laptop to make a direct connection. How do I set up the laptop as an audio source?

Yes, that’s what I was suggesting. The following post walks through some solutions to your problem including a Surface Pro, so a laptop may work for you. The preferred option appears to be low-spec. NUC running ROCK as a multichannel endpoint.

Well after trying unsuccessfully with a laptop I’m thinking my next move will be to relocate my sonic orbiter server out of the spare bedroom and within hdmi length of the xmc-1. I’ll try that next weekend.

1 Like

I got this to play from a lap top through the hdmi output to the xmc-1.

The hdmi in the laptop is configured to 5.1 output. I’m flaying a Flac file in 5.1

Roon still downmixes 5.1 to 2.0. I’ve tried channel mapping and downmix as needed but it still won’t send out multi channel…

What is your “Channel Layout” according to Roon? It’s easy to miss because it’s hidden under Advanced Settings in Device Setup, but I think it defaults to 2.0 regardless of your HDMI configuration in Windows. This could explain why Roon is still down-mixing, so make sure it’s 5.1/7.1:

(Note: On my previous computer, for some reason the HDMI device actually appeared twice under devices. One could only be configured for 2.0 while the other was multi-channel capable. So if you can’t change the Channel Layout in your current device, it might be worth checking to see if there is another WASAPI device listed for that PC that you can try.)

Thanks - I don’t see that screen when I go to advanced under device set up (from my iPad) perhaps I need to access it from the core? My screen does not have a black background and does not have options other than channel mapping or downmix as needed.

My picture was from a Roon Remote running on a laptop so you shouldn’t need the Core to access all the settings. (And black vs. white just depends on which theme you use for the remote, so no need to worry about that.)

I’m not sure why “Channel Layout” is missing unless maybe Roon hides it now if the endpoint is only 2.0. I’m currently away from my system, so maybe someone else can get you the answer faster. If not, I’ll check the following later and report back:

  • If Channel Layout is a setting for 2.0 endpoints (maybe they hide settings now if they can’t be changed)

  • Compare Advanced Settings in iOS vs Windows (should be the same, but you never know)

In the meantime, looking at your picture more closely I notice the final stage is Realtek ASIO. I’m not familiar with that, so could it be 2.0 only? Does Roon give you any other options like WASAPI? If so, they might be worth a try. If not, is there any configuration you can do in Realtek related to 2.0 and 5.1?

Thank you - I’ll check it later tonight when I’m at home.

Here are my findings:

  • Channel Layout setting for 2.0 endpoints --> I can confirm Channel Layout was not visible on my Oppo 203 (see below) which is limited to 2.0 so the fact you don’t see this setting probably indicates that your Realtek ASIO connection is only 2.0:

  • Advanced Settings in iOS vs Windows --> they were the same as expected (my iPhone was even still on the Light theme):

At this point, my best guess is that Realtek is limiting you to 2.0 which is why Roon won’t give you the multi-channel layout options. If you can’t change any settings in Realtek to make 5.1 work, I would check what other connection options you have in Roon under Audio Settings. I use WASAPI primarily for my Roon 7.1 connection (on a WIndows PC.) But I also downloaded and installed ASIO4ALL to test ASIO and that worked as well:

This shows my working signal path for WASAPI in case it helps:

Well you were right - the correct device is waspi. I am able to set it up for 5.1. Now I’ve got the infamous “transport - device in use” error to solve.

That’s good news. Sounds like you are almost there. Try disabling the Realtek connection in your Roon audio setting. It may be “using” the HDMI and have it locked. Hopefully you’ll be listening to your music soon!

Working, thanks all for the help!

After playing with it for a while I realized that it would work with the multi-channel files but would not work with radio - tidal or any of my ripped flac files The interface scrolls through all listed files without playing any of them.

Any idea what might be causing this?


I haven’t experienced that problem in my system (and I don’t have a XMC-1), so I’m probably not going to be much help.

Maybe someone who successfully uses a XMC-1 and HDMI can check your settings. Based on his comments in another thread, I’ll flag this post for @Mike_Rife since he appears be using a XMC-1 and HDMI. If you can post pictures of your current device settings, maybe he can compare it to the settings that work for him and let you know if anything is different.

I’ll flag this for @support as well because they probably haven’t seen your post about skipping tracks since this topic is under Audio Products. Maybe they’ll already know a solution.

So problem is solved if I check the send stereo to 5.1.

So if that is true - I have to switch this toggle every time I want stereo?