DTS 5.1 worked a few days ago, but not now

Suddenly my DTS 5.1 sources aren’t playing 5.1 output. Strangely, it does play the source. Just not in 5.1. Previously, before I got 5.1 to work, it would play the hiss/static thing. Now it plays, but not in 5.1 output which is kinda strange to me. Thought it would be either 5.1 or hiss/static. I know I’m playing the correct version because on my other endpoints that don’t support DTS 5.1, they are outputting hiss/static. I also know it’s not 5.1 because I have one track that starts out with a guitar solely output from the right rear channel. That’s not happening anymore. It comes out of the 2 front channels.

Could it be something to do with Roon 1.7? This change happened right around the same time I upgraded although I’m not sure of the exact timing of the upgrade vs. this change in 5.1 output. But there’s nothing else I can think of that I have changed. But if it’s not 1.7, I must have done something.

I found this thread, but it didn’t seem to help me: MCH from Roon to XMC-1

Also read this out of the knowledge base with no help: https://kb.roonlabs.com/Multichannel

Thanks for any help.

Hi @eddieb,

Would you kindly share a track that’s experiencing this issue with us? You can send this in a private message via a shared Dropbox link or any other file sharing service. Once we have the track I’ll pass this along to the technical team so they can investigate further.

Thanks!

OK, I can do that via a shared Dropbox link. But how/where do I send it through a private message?

Nevermind. I figured out the message thing. Just sent it to you. Thanks.

Make sure Volume Leveling isn’t on, that tripped me up a few months ago with DTS FLACs

Volume leveling isn’t on, but thanks for the suggestion.

Hello @eddieb,

Thank you for sending us the test file. We we able to confirm that DTS 5.1 playback is working correctly with the HDMI AVR we have in the QA lab. We used the HDMI output from a NUC running ROCK for this test. When playing the file, audio is outputted from the rear channels as expected.

Here is a screenshot of our device setup for the HDMI zone:

-John

Thanks for doing the testing. From a quick try to see if this setup helps me, it didn’t seem to work. But we’ve got family here that are monopolizing the home entertainment system, so it may be a few days before I can try testing in more depth.

But when I did try to validate the setup, I discovered the Channel Layout was gone from setup. Long story short, I found this thread: Lost Channel Layout setting.

The poster’s experience was also my experience as well. Once I turned off Zone 2, Channel Layout came back, but it was set to 2.0. But when changed back to 7.1, it didn’t seem to fix things. Seems I can’t have Zone 2 on the same channel, which is OK for me.

When I get significant access to the main zone again in a few days, I will test more and report back.

Finally got to test this a little more extensively with John’s Device Setup settings. Set mine up identically to those provided in the post a few above this one. But it still outputs in 2 channel stereo even though the source is DTS 5.1.

So I decided to compare the input/output formats shown by my receiver for: 1)the DTS source on Roon; 2)The same song track on Roon, but not in DTS 5.1 (2 channel stereo). A different source track, but the same song; 3) The CD the DTS 5.1 track was ripped from playing on my DVD player.

Results: 1) Input: DTS 5.1 channel. Output: Theater-Dimensional 3.1 channel; 2) Input: PCM 2 channel. Output: All Channel Stereo 5.1 channel; 3) Input: DTS 5.1 channel; Output: DTS Neurel:X 5.1 Channel.

This input/output info is coming from my =receiver which is a Integra DRX 4.0. The DVD playing the CD (#3) is the only one that is true 5.1 going in and coming out. Even though my sound select settings are identical for all inputs on the Integra, I’m getting different results depending on the source format. The DTS Neurel:X thing in #3 is one of the settings for output on the Integra and is identical for all input sources, yet this is the only one that shows that as the output. Not sure at all what the Theater-Dimensional 3.1 thing is in #1. Sounds like a receiver setting, but I can’t find it.

Not sure if this problem is something to do with Roon or my receiver settings. If we think it’s the receiver settings, then I would need to close out this thread and pursue that on my own. But what’s perplexing, and frustrating as I’ve said initially, is that I had this working properly as of about a week ago. Other than Roon 7.1, I’m not sure what else, if anything, has changed. I