Mcintosh C 48 won't play in Exclusive Mode [Solved]

My Mcintosh USB audio does not accept Exclusive mode.
I have
-PC HP ProBook 4540s

  • USB cable -Vertereacoustic Pulse D-fi double
  • Mcintosh DAC which is into preamp Mcintosh C 48

Mcintosh USB audio play only when Exlusive mode is not selected.
If I select Exlusive mode signal is muted.
Thank you

Hi @Vlatko_Vasileski – can you try enabling Event Driven Mode, and let me know if you have better results?

If not, can post a screenshot of the audio output settings as described here? Anything else in the chain besides the ProBook and the C48?

I have the MA7900 and also never got Exclusive mode or Event Driven mode to work properly. Both the C48 and MA7900 are from more or less the same period so I assume that they use the same DAC implementation.

As an example. In Exclusive mode in can only play 16/44 as soon as I choose a track with a different resolution, roon displays the “negotiation failed…” message.

When you use the ASIO driver from McIntosh everything works as intended. I suspect that this has more to do with the implementation on the side of McIntosh than with roon.

Thank you for your prompt replay.
It was enabled Event Driven Mode , but now ( after your mail) I disabled and now is OK.
Signal Chain: Lossless and I am happy.
Max Sample Rate (PCM) is UP TO 192kHz
DSD Playback Strategy is Convert to PCM.
But Now there is another problem because only tracks with 24/192 can be played.
If tne track is 24/96 or other , signal again is muted and I have to change seting instaed of Mcintosh I go with System output.
Thank you

I do not think that is up to Mcintosh , because I am using also Jriver 21 and there is no problem with Wasapi or Asio mode ar all.

Can you give me a little more information about what you’re seeing when this happens? Does playback appear to start? Is there an error? Are you able to reproduce this immediately after you’ve restarted Roon?

When I have specified Mcintos USB audio with Exlusive mode I can play only tracks wihich are 24/192. If I tray to play another track immidiately, down on the taskbar is shown : " Transport: Playback has failed due to playback parametar negotiation with the audio device ".
It is not shown Error .
If I play RADIO and selection is again Mcintosh USB audio Exlusive mode, again only tracks with 24bit /192 kHz are played and when that song will finish ROON is trying to find next song with 24/192. Otherwise same message is shown : " Transport: Playback has failed due to playback parametar negotiation with the audio device " for every song wihich is not 24/192.
If I change audio zone to System Output , ROON immediately star reproduce but Signal Chain is not Lossless.

I have a McIntosh USB “DAC” (C2500) - and can attempt to create this issue you are having. Can you tell songs your talking about?

I can see the steps that you are creating…

Hey @Vlatko_Vasileski – I just sent you a PM with instructions for gathering some more information here. Give it a read and let me know how it goes.


Good suggestion from Bill. Maybe @mike when both me and Bill also try to recreate and provide some logs to roon. From what I have read on AA the DAC section in th C48 / C2500 / MA7900 and others around that period are almost the same. Maybe seeing logs from three almost identical DAC’s gives roon a better idea what is going on.

I receive instructions from Mike and I am in procedure to solve this subject (Mcintosh c48 dac can not play in exlusive mode). With Mike’s help I belive that it wil be solved and I will let you know every step .

1 Like

Hey @Vlatko_Vasileski – we’ve got the diagnostic report. We’ll be analyzing it soon, and then we’ll follow up and let you know what we find.

Is there news regading diagnostic report for the subject Mcintosh c48 DAC does not work in excluive mode.

Reminder ?

Dropping a flag for @mike to help with the reminder.

Dear Mr. Mike
Thank you for your answer. I want to inform that in mean time I downloaded instruction from Mcintosh site ( products support ) and I did setup driver as per their instruction.
I saw that Roon not support upsampling and that was the problem. With this setting only ASIO mode is working but Wasapi mode still not working.
Best regards