Memory leak causes search slowness and play stoppage

Roon Core Machine

Windows 10 Dell XPS420 2.4GHz quad core, 8 MB RAM
Running 2.0 build 1223 64 bit

Networking Gear & Setup Details

Asus RT-AC88U, powerline Ethernet

Connected Audio Devices

Number of Tracks in Library

62,742 tracks

Description of Issue

Memory leak causes very slow search and Roon stops playing. When stop occurred, memory was at 6GB+ used.

This has happened repeatedly this weekend. Roon stopped playing Qobuz and tracks from my own library.


Ah yes!

Came here for the same issue! Same symptoms!
Using Linux in my case, running 1223

697599 root 20 0 24.8g 6.5g 58752 S 90.4 84.3 2799:38 RoonAppliance

Using about 6.5GB of memory!
Looking at the graph is the 4th when the new update hit?


I opened a topic on Saturday with the same issued (after many hours trying to resolve) it appears that my Roon Core on iMac streaming to my Roon Remote on iPhone or iPad is spiking memory but not actually swapping memory to SSD but the Roon Remotes become unusable.

When close the Roon Core window and wait 60 seconds and then reopen = all remotes function for around 15 minutes then they get sluggish and I need to restart Roon Core again by closing and starting the Roon app again. I would love to know how to solve this problem.

1 Like

And here we go again… dropouts again!
The dip is when I did a restart, after posting here!


This problem continues. Is Roon working on a fix?


My problem also continues. A restart of the server fixes it for a few hours.
I should probably make my own thread :smirk:


I’m having the same issues… been running Roon on this NUC for years without problems… When this happens Roon is mostly unusable, stops all the time and generally sluggish all over. The fan is going nuts on my NUC when it happens, and I’ve tried running Win Update, cleaning it for dust, restarting, letting it rest with RoonAppliance running for a while… sometimes it works, other times not, and it seems there are no system to when it starts going of the rails.

Have been hoping for a fix for a while but seems to be persistent.


Lolz… :neutral_face:

I made my own ticket… it was moved to #tinkering as I run on a VM (The only VM on the host!)
I’ll just wait until more “serious” users kick off enough to fix the problem.

If I see it correct you’re using powerline Ethernet. Does this mean the core is also connected by this?
Note all posts concerning this are using WiFi.

Plz note this Roon recommended network practice

Ethernet Over Power (EoP)

The quality of Ethernet Over Power solutions varies quite a bit, and generally it will be less reliable than Ethernet. There are times it can work well, but if you’re having a problem and powerline ethernet is involved, we recommend temporarily replacing the ethernet over power connection with a real ethernet cable to see if things improve.

Plz read more here

And yes it could have worked for years but what if something from the neighborhood starts interfering with your WiFi network?

1 Like

Hey @Andrew_Cherry,

Following up on this thread, does this only happen when using the search function? If you play roon without using search, does the same issue occur?

If you could, please share a timestamp the next time you run into this issue, that would be helpful.

Hello, @benjamin ,

Thanks for your response. There did seem to be a correlation with search when the problem was occurring. But I also did see the problem without performing a search, too.

Since the build 1232 update, it’s been working fine, though. As a test, I tried performing some Roon searches on my iPad, and didn’t see a big jump in memory usage on my core. I haven’t installed the 1234 release from today. 1232 seems to have improved search speed quite a bit!

1 Like

Thanks for the update @Andrew_Cherry!

I’ll keep this thread open while you continue to test things out. If you run into this issue again, sharing the specific date and time and the device (and track name, if applicable) would be great for our team to have on hand to review your account diagnostics. :+1:

1 Like

A post was split to a new topic: Roon server process reaches 9.9G of RAM

I just discovered this thread and am experiencing the exact same issues. I thought my ROCK nuc was in its final state of life.

When this problem occurs Roon handles very sluggish. Starting playback of any song, locally as well as Qobuz take ages to start. Using search is tedious as its extremely slow and occasionally errors our. Rebooting the NUC appears to be the only solution.

1 Like

I installed Roon Rock on a NUC i5 250Gb-SSD en 8GB memory 115.000 tracks library for a friend lately. He is not a communitiy user but I think he will become one. After a few hours, ROON gets slow switching tracks. I’ve had the same issue after the latest update on my own NUC but it is gone after a full reboot (power off-on). My NUC has 16Gb memory and 55.000 tracks so my hardware is bigger an library is smaller than his. His problem is gone after reboot but comes back after a while. It seems as some kind of memory leak that he runs into faster because of less memory and a double-sized library.

Question 1: is 8Gb on the i5 NUC enough for his 115.000 tracks library or will an upgrade to 16Gb solve his slowness issue?
Question 2: can a memory leak be the cause of the slowness after a few hours of playing?

Running Roon OS build 256 and Roon Server 2.0 build 1259

1 Like

My understanding of rock is it is the same as RoonServer on Linux but the OS is made by Danny specifically for RoonServer. It has one task, Run RoonServer.

RoonServer on Ubuntu seems to use more and more ram the longer it is running. It is not a memory leak, it’s just the way it works on Ubuntu. I recall users recommend changing the swappiness setting in Ubuntu. This isn’t an option with ROCK, but I wonder if there is something in ROCK that is causing this ram behavior. I don’t know though as I believe the only similarity is they use the same RoonServer and it’s Unix based.

I can’t convince myself the increased ram usage is a memory leak based off the behavior RoonServer show with Ubuntu.

Just found this thread and this is precisely what I’m experiencing with my Ubuntu-based Roon Core. I’m considering creating a cron job to restart Roon every morning to avoid this issue.

1 Like

I have considered the same. But sometimes it will do it twice a day!
I opened a support ticket over a month ago. One reply and that’s it!

What you are describing is pretty much a memory leak!
Linux will not just lose memory for no reason. If this is the way it works on Ubuntu, then there is a bug in the Roon code that is not handling Ubuntu correctly!
If there is a memory bug in Ubuntu itself, then this is major! And a patch would be on its way.

1 Like

I’m testing the recommendation I read on a different thread: to lower vm.swappiness. I set mine to vm.swappiness = 10 and so far so good, fingers crossed.