Missing Airplay devices in Roon

How does this work? I have the ugly flat white Airport Express, and the nice one that looks like a charger( 7.8.1 ). I also have AppleTV 4 and 4K, none of them show up in Roon.

I’m unable to see any of them in Roon – I’m in Roon -> Settings -> Audio

All items are available in iTunes.

I’m stuck here: https://kb.roonlabs.com/AirPlay_Setup even though those are all woke up

Set Up

Start by opening Roon on your Windows or OSX computer, or Roon Remote on your iOS or Android device.

In Settings, click the Audio tab – in the Networked section, you should be able to see your AirPlay devices. Sometimes Roon has trouble discovering AirPlay devices that are sleeping, so if your device isn’t showing up in the list, try waking it up first.

Finally, enable the device (or devices) you want to use, and play some music!

The flat white Airport Express now runs 7.8 as I rolled back from 7.8.1

There is still no listing of any Apple devices in Roon.

This Airport Express is in bridge mode.

How can I learn the version of the Airport Express? I assume I have the 2nd generation Airport Express 802.11n and the 3rd generation flat Airport Express that looks like AppleTV 3, but is white.

This is getting nowhere. What are options to airport express? I need something that takes RAAT over ethernet and makes a minijack output for my B&O 8000 of the 80s.

Hi @Gjermund_Thorsen,

I’ve moved your post over to its own topic.

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Thank you.

I will add what is not already mentioned above in this post as follows; if anything is still missing please ask.

My LAN is I run hypervisors in the, routers and WiFi accesspoints in, DHCP clients/workstations in general in, and servers/static IPs with services in

The /24 is not subnets, it’s an attempt to describe parts of the /22 network.

My Roon Server and Roon both run on an iMac for now, for initial testing, I will move Roon Server to an LX zone or BHYVE w/some sort of linux once I have the house and garage all figured out.

SkullCandy running Joyent SmartOS as home router
iMac 27"
iPad 10.0.2.x/22
iPhone 10.0.2.y/22
Airport Express( charger like )
Airport Express( AppleTV like )
AppleTV 4
AppleTV 4K

The goal is to move the Roon Server to however I’m still questioning which distro is better.

Hi @Gjermund_Thorsen,

I see that the Core is on the IP range of 10.0.2.X while these devices are on the range of 10.0.1.X. Roon requires all devices to be on the same IP range to properly function. Can you try putting the Airport devices on the sames range as the Core and let us know if that helps?

It’s a /22 subnet.

Let me repeat: The /24 is not subnets, it’s an attempt to describe parts of the /22 network.

Hi @Gjermund_Thorsen,

Can you please check to see if Roon is allowed past your MacOS firewall by using these instructions?

Just to confirm, what is the current IP address of the Core and the missing Airplay devices?

There is no firewall between the mac and the Airport Expresses. Update, today the AEs and AppleTVs all show up.

Hi @Gjermund_Thorsen,

Thanks for the update here! It seems like things are working as expected now, but do let us know if you have additional issues!

This topic was automatically closed 25 hours after the last reply. New replies are no longer allowed.