Missing codecs AAC Synology NAS database on external SSD

Roon Core Machine

CPU INTEL Celeron J4125
DSM 7.0.1-42661 Update 4
Roon Core version 2 v1128
Roon Client 2 v1127 running on Chromebook / Windows PC / Google Pixel 6

Networking Gear & Setup Details

Wifi (Fitzbox) + Ethernet (1GB)

Connected Audio Devices

Naim Atom & Naim Muso (Gen 1)

Number of Tracks in Library

5,000 tracks

Description of Issue

Cannot play live Radio AAC streams

Steps taken:

I have downloaded [ffmpeg-git-i686-static.tar.xz], uncompressed and then uploaded said file to external SSD location RoonOnNAS/bin


Stopped Roon server and then restarted.

AAC stream still not working ‘playback was interrupted because a track failed to load’

I have seen other threads on this but not seen a definite resolution?

Hi Paul,

You have downloaded the i686 version instead of the amd64 version which is the one you need.

Hope this helps.

Hi Scottav thanks. I have an Intel processor on the NAS so I think I have the right one?

Hi Paul,

It doesn’t matter that you have the Intel processor Roon uses the ffmpeg-git-amd64-static.tar ,try it and see.

Ah ok. Uploaded the amd version of ffmpeg to the bin location. Stopped and started Roon server on the NAS.
Sadly still does not work and gives the same message: ‘playback was interrupted because a track failed to load’.
I assume what I am facing is a codec issue but I do not know what my next step should be?

You have the wrong one as @Scotav said. You want the amd64 version.

See here:

Hi thanks. I am not sure if you have seen my last post I have now used the amd version to no effect.
The problem remains. Grateful for the help so far.

Hi Paul,

Can you confirm that you have completely unpacked the .tar file as the main compressed file needs to be unpacked twice to obtain the ffmpeg file? You should end up with this; -

ffmpeg unpacked

The ffmpeg displayed is the one you should use. You may have already done this but just need to check.

Hi Scotnav,

Yes opened on Chromebook so did not need to unpack twice. End result below:

Then uploaded to bin location on external SSD attached to NAS. I wonder if the external location is causing issue?

Thanks for persevering.


The files should be in “/user/bin” and not in some random directory on an external drive.

As above I have located the ffmpeg file in RoonOnNAS/bin not in a random directory. Are you suggesting it should be a different location? The text file(Info about this folder.txt) in this folder reads:
‘You can provide your own version of ffmpeg in this folder.
ffmpeg is a software component of your diskstation. However it might not include all required audio codecs. Therefore Roon might not be able to play some media files.
If you provide your own version of ffmpeg in this folder, you’ll need to restart Roon Server afterwards in the Synology package center.’

So I think the file is in the right place but refreshing RoonServer I still cannot stream AAC for example.

What are the permissions of ffmpeg file(s)?

1 Like

Hi Paul,

I had this setup some time ago on my QNAP and it worked perfectly using the external ssd. Chris changed the method of adding ffmpeg on QNAP to the same method as Synology. If you are using the USB SSD storage method for your Roon Server the ffmpeg should be stored in the bin directory of the RoonOnNAS as you’ve already described. This should be working for you but at the moment I don’t understand why.

When you open the Roon App on you Synology does it state that you are using the “User Supplied Version” similar to the QNAP? (ignore the versions): -

Thanks people. I turned off my firewall(fw) to no effect.
I then checked on the permissions for the ffmpeg file (thanks musicjunkie) and execution was not set. Set execution to on and it worked :slight_smile:
Set fw on again and it did not work. Turned fw off and tested several times and all working well.
This is solved for me - confident I can work out the fw. Many thanks.


Good spot :ok_hand:


At least you’ve got it sorted.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.