"Missing codecs": ffmpeg not recognised? [Permissions not 755]

Can’t seem resolve the missing codec status.

New NUC (NUC7i3BNH), followed the guide, tested with two different version of ffmpeg (git and release), copied over (data/Codecs), rebooted the NUC, same message. ffmpeg works on the extracted linux client so I know theres nothing wrong with the file.

I also reinstalled (clicked the button on the page), so I have the latest ROCK version (Version 1.0 (build 159) stable).

Everything else works, restored from backup etc. Just the missing codec.

Since I cant ssh in, I can’t debug this any further on my own.

Tested with the extracted ffmpeg binary from these archives:


You need to extract those twice to get to the ffmpeg binary did you do that? Then just copy the file in the folder that just says ffmpeg. Then restart

Yes, thats what I did. The ffmpeg binary is 65.4MB, located in data/Codecs.

I can even run it directly of the mounted share:


ffmpeg version N-47330-g4a976200d7-static https://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 6.3.0 (Debian 6.3.0-18+deb9u1) 20170516
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disableindev=sndio --disable-outdev=sndio --cc=gcc-6 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzimg
libavutil      56. 21.100 / 56. 21.100
libavcodec     58. 34.100 / 58. 34.100
libavformat    58. 19.102 / 58. 19.102
libavdevice    58.  4.106 / 58.  4.106
libavfilter     7. 39.100 /  7. 39.100
libswscale      5.  2.100 /  5.  2.100
libswresample   3.  2.100 /  3.  2.100
libpostproc    55.  2.100 / 55.  2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Far-fetched: Is it a permission problem?

-rwx------ 1 user user 63M  1 nov 06.33 '/run/user/1000/gvfs/smb-share:server=192.168.xx.xx,share=data/Codecs/ffmpeg'

@support can you help here.

Ok. Should i cross-post?

They will likely move it, just wait until they respond.

Moved to #support.


So, any ideas?

Hello @Magnus_Wihlborg,

Can you please let me know where you’re seeing this error and how exactly you uploaded the ffmpeg file? Have you tried rebooting the ROCK yet and verify that it is still showing this error after a reboot? Please let me know when possible.



I’m seeing that error on the ROCKS webpage (ip of the NUC).
I mounted the share in Nautilus, copied the ffmpeg binary to /data/Codecs on the share, and rebooted.

After reboot, same error about the missing codecs. So I thought there was something wrong the ffmpeg file and downloaded the other archive, extracted that and copied that ffmpeg binary over.
Rebooted, still the same error message.

I can execute the ffmpeg binary directly from the share, and it works fine.

Hello @Magnus_Wihlborg,

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

If there’s any other details you can tell us about how you’re copying the binary over, that might help us understand why you’re getting a different result than everyone else who’s set up ROCK. Are you using a Windows/Mac or Linux machine to copy this file over?

Please let me know if you can think of anything else that you’re doing different when possible.


Ok, great.

The NUC is on right now, but I will not be home until after midnight (6h from now).
I guess you want me to reboot it so it will provide som logs on boot, so i’ll do that when I get home.

On the computer I uploaded the binary from, I use Linux (I thought that was clear when I mentioned Nautilus). More specifically Qubes OS, with Arch Linux as template. Nautilus is the filemanager in Gnome3, which I mounted the share from, and copied the binary over with. And then rebooted the NUC by clicking the button on the ROCK webpage.

What else… I use a 2.5" SSD-disk (on the NUC with ROCK), and not a NVME-disk if that matters (it should’nt).

Hello @Magnus_Wihlborg,

Thanks for letting me know the additional information. I’ll let you know when we have some feedback for you based on the diagnostics but in the meantime, if you have another machine around running Windows or Mac, it might be interesting to know whether you have the same experience moving the binary into place from one of those machines.


Did you try changing the permissions on the binary file before moving it to the Roon core?

I was thinking the same. Probably want to set permissions to 755.

I checked the file permission (as written in the first post), and it was/is 700. I read the other threads with people having the same problem and they didnt change the permission?

I just downloaded ffmpeg on my MacBook, copied the file to the desktop and checked permissions:

8625650151 -rwxr-xr-x@ 1 martin staff 65440616 1 Nov 05:33 ffmpeg*

So, I suggest you make sure permissions are 755 which is the default for executable files. Essentially, your file is only executed by the owner, i.e. uid 1000.

I’ve tried these steps on a setup DietPi-ROCK. And in my case file is being copied over with execution rights. Maybe this has something to do with the samba implementation on the machine you are copying from ?

Well, it seems I got it to work (not home yet).

  1. ssh’d in to my server, mounted the share, noticed that the ffmpeg file now had 755 as permission (strange)
  2. Still, copied ffmpeg to the local filesystem, changed the permission to 777 (just to verify).
  3. Removed ffmpeg from the share.
  4. Copied ffmpeg back to the share, noticed that it got 755 again (?).
  5. VPN home from my phone, checked NUC/ROCK webpage, and the error is gone (did not even reboot)?
  6. Rebooted anyway.

Will check if webradio is working when I get home, but if so, this was solved quite strangely…

Edit: and this time I used “sudo mount -t cifs…” from bash instead of gvfs-smb that Nautilus is using.


Finally. It worked.

You can turn of the diagnostics now.

One would have guessed ROCK would be able to fix the permissions by itself, if wrong.


1 Like