Missing CODECs?

Try rebooting the NUC.

Based on your picture this has not been done for at least 1+ days. Not restart Roon Server, but reboot of the NUC (available in top right) via web interface.

Thanks. Rebooted several times this morning. No joy.

After 9:31 this morning? Because at that time your server has been running since 1 day 14 hours (ie not been rebooted)… which is what your screenshot above says that @Tor_Gunnar_Berland was referring to.

Maybe switch off altogether. Give it a rest for a good minute, then try again switching it back on… Use the hard button on the NUC for this.

Yes, after 0931.

ok, I‘m lost…

Maybe a permissions thing seems to happen on Linux, chmod the permissions and see if that helps.

This is the file I’m using (zip-compressed the file directly from my ROCK NUC).

You have a linux desktop - have you tried running the ffmpeg file? It posts a version number etc.

Clutching at straws…
Can you post an image of the directory above Codecs ? I want to make sure we haven’t got directories in a twist.
You should see RAATServer, RoonServer etc.

Thanks. That’s super helpful. I unzipped and copied your file but unfortunately I’m still getting the missing codecs message. It’s most curious!

Here’s an image of the directory above:

I remember the codec was kind of challenging initially as well, but when I finally got it working it has not failed ever again. I hope @support can guide you better to find a solution.

Just in case it is somehow connected to decompressing the zip file. Here is the untouched file.

Hope this will give you success.

When you connect to the Data directory of ROCK are you using the IP address?

This is a strange enough problem I’m wondering if you’re actually connected to the correct share.

Then, if you mount that Share on your Linux desktop you should be able to execute the binary directly from the share verify 1) It’s not corrupted 2) The version.

I remember having some weird issues myself many years ago. Very similar; I think solution was to copy the file from windows client. Somehow it never worked when copying from Linux or macOS.

It has been a while…

1 Like


Take a look here: "Missing codecs" after installing ffmpeg with Linux - #4 by Nickpi

You will have to this as root (or with sudo in this case) from a terminal:

  1. Mount the ROCK data folder to /mnt/ on your computer
    sudo mount -t cifs //rock/Data -o vers=1.0 /mnt/
  2. Maybe you will have to change the directory where your extracted file is first, e.g.
    cd /home/user/Downloads)
  3. Copy your ffmpeg file to the mounted ROCK folder
    sudo cp ffmpeg /mnt/Codecs

After that a reboot can not hurt.

Forgot to mention:
I wrote a bit about my ROCK project (to remind myself) on github. Maybe there is one or the other interesting information here.


I just did this not too long ago and if my memory is correct you need to reboot your Rock after uploading the codec. My Rock had a question mark also until I rebooted it, then it was corrected. It probably reads that folder upon bootup of the device.

Hey Dafydd_Waters,

Just to be sure:

You still have problems? You have an amd64 CPU in your ROCK?

Hi all. Thanks everybody for responding. In the end, I borrowed my partner’s Windows laptop, redownloaded the file and made the transfer all in a Windows environment and Hey Presto! it works. So I reckon it was something to do with permissions in Linux but I couldn’t be arsed to figure it out. Thanks again everyone who took the time to try and help. Now I can listen again to the approximately 9 out of six thousand records I still have as .mp3 files :slight_smile:


Glad you managed to make it work. Maybe next time the question pops up we will remember? (probably not!).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.