Mobile app skipping tracks

Has anyone else experienced the mobile app randomly skipping tracks? For me, it isn’t frequent…generally when it happens, the track will start then playback will stop for a few seconds and then the next track starts playing. It’s random and difficult to nail down.

Running mobile on iOS.

I suspect you mean the Apple iPad/iPhone Control app for Roon is what you are using to select tracks. But what is the Roon Core running on? Its specs, and those of your setup generally, are what determine playback performance.

Can you elaborate?

I think your question probably answers it for me. I’m running roon on a standard laptop, nothing special. I only have a tiny personal library and do a lot of listening away from home (@ work) so I felt that a roon ROCK setup is maybe overkill for me. But maybe not - I really don’t know.

I have also noticed with the remote control app that many times it loses the artwork on the lock screen, so I thought maybe since both of these issues are related to the mobile app, that it had more to do with the app itself rather than the core.

My core never skips, only the remote app. Somes times it says “Tidal is loading slowly”, but would it then skip the song entirely rather than waiting for Tidal to load & then continuing to play?

Ok…i have noticed the message “Tidal loading slowly” (or something like that) when using the roon remote from iOS. I can listen fine from my PC fine…no skipping. As soon as I listen via the remote, “Tidal loading slowly” message appears.

@support , I’m getting “Tidal loading slowly message” when using the remote app. I can listen fine directly from my core or from Tidal. But when using the remote I frequently get the loading slowly message and then the app skips to the next song.

I’m running roon server and roon remote on the same PC. All works great until I use the remote app (iOS)

Is this request ok where it is or do I need to move it to the support thread? Is tagging support enough?. I’m new here so sorry if I’m following proper procedure.

Hello again @m_p! Glad to see you back on the forums again :slight_smile:

I’d be happy to take a look at the issue you are facing, thanks for confirming that it only occurs on your iOS device and not the Core itself.

Can I ask: have you by any chance tried re-installing the iOS app yet to see if that causes a change in behavior? Does this issue occur across all of your iOS devices or only one one of them?

You may also want to try “disabling” and re-enabling your TIDAL account from Roon Settings -> Services -> Edit Button next to TIDAL -> Disable -> Re-Enable. The setting should look like this:

Please let me know if the above steps help, otherwise we can look into additional troubleshooting options here.


OK - I’ll try that. I have RoonServer (with Roon installed as a remote on same machine) running on 2 different computers that I switch back & forth between. Happens on both devices when I run remote from iOS…not when I run Roon directly from the computer.

Hello @m_p,

In the past we have also seen Google DNS help with similar reports. If you try using Google DNS, do things improve? This DNS setting would be applied in your Core as the first step to see if there are improvements or in your Router as a second step if this issue affects more than just one device. The instructions on how to set up your DNS on a Windows Machine can be found here. Please let me know after you have had a chance to try both possible solutions!


Tried all of the suggestions. I was able to listen to a full album with no issues…then suddenly started having problems with Tidal loading. So, nothing works. I have to listen on my mobile devices via Tidal. I have 2 iOS devices and have the issue on both.

Hello @m_p,

Thanks for trying the suggestions, sorry to hear they didn’t work out as well as expected.
Just to confirm, you’ve tried re-installing the iOS application on both devices as well and still no luck?
Can you also let me know if this issue occurs only at work or both at home and at work?
Do local tracks in your library have any sort of issue playing or is this only affecting TIDAL?

Please let me know when possible.


Actually, I didn’t reinstall the iOS app. I thought it odd that it happens on 2 different devices (iPhone & iPad). I’ll try that. I only listen on the remote app @ home, not @ work. have no issues with local tracks only Tidal.

I reinstalled the app on my iPhone and listened on my work network and still having the same problem.

Hello @m_p,

Thanks for confirming my questions. Can you please try clearing your TIDAL cache to see if that has any effect here? To do so please:

If the same issue still occurs after doing so, can you please confirm if it exists on another Core as well or just the current Core? Also what is the output you are using when this issue happens? Is it the iOS device output or are you streaming TIDAL to a DAC? Please let me know your findings when possible.


I deleted the cache folder and still have the same problem. When I listen on my mobile devices, I bypass my DAC and listen straight from the device. So, far I have only deleted the cache on one Core.

Hello @m_p,

Thanks for trying to clear the the TIDAL cache. Since it is still not working as expected, would you be able to provide more information regarding your network setup here? Please let me know the make/model of your Router and how your Core is connected to the Router, via WiFi or Ethernet? Do you have any network switches in between the Router and the Core? Have you made sure that any firewalls on the Core have been modified to allow Roon? I would also double check the DNS settings on the router itself and add the Google DNS if possible.


I just tried from my home and same problem.
It happens on every network I use it on. Tried it @ friend’s house…same problem.

I don’t mind doing a bunch configuration changes, but it seems like there must be something else going on since it happens everywhere I try it, no matter the router or network configuration.

EDIT: I’m connected to my router via wifi. I reset my network adapter last night and was able to listen trouble-free for about 1.5 hours. I was able to listen this morning for about 1.5 hours with no problem.
I wouldn’t call the problem resolved yet because in the past I have been able to listen for days with no problem and then suddenly have issues. So, we’ll see what happens.

Still doesn’t explain why it happens on every network I listen from. My work network is super fast, ~500 Mbps download speed.

Hello @m_p,

Thanks for testing on a different network and confirming that you run into the same issue there. I would agree that it is probably not due to your Router setup but something going on in the Core side of things.

I just want to clarify on a few points:

  • Are you using Apple Headphones connected via lightning when you experience this issue or are you using a DAC connected via USB to your iOS devices? If you are using a DAC please provide the make/model.
  • Are you playing regular TIDAL content or MQA content when this issue occurs?
  • Can you please provide more information regarding your Core? What kind of processor/RAM amount/OS you are using?

Please let me know when possible.


  • No DAC when streaming from iOS. I use either blue tooth or direct connection to the lightning port
  • Regular Tidal content not MQA
  • 2.4 GHz, I5 CPU with 16 GB of RAM
  • Windows 7 & Windows 10 OS (2 different computers)

Hello @m_p,

Thanks for confirming those questions for me. Just a slight question regarding your most recent update:

Does this mean that you are seeing this same issue in two different computers on the same network?

I have discussed your case with a few of my colleagues and they suggested the following test to narrow down if it could be your Core or your iOS devices. Can you please try the following:

  • Install Roon as a Remote on one of your Computers and use Roon Core on the primarily affected computer
  • Connect both computers directly via Ethernet to your Router
  • Try playing back TIDAL content from the Roon Remote PC for a few hours and see if you notice the same issue
  • If you do, please let me know the exact time of failure (ex. 11:45PM).
  • If you do not notice any issues after a few hours of playing using the other PC as a remote, please revert back to the iOS device and play TIDAL content again until you run into the issue
  • Please let me know the exact time of failure on the iOS device

I have enabled diagnostics mode for your account and what this action will do is next time your Core is active a set of logs will automatically be generated and uploaded to our servers for further analysis.