MOCK - Tell us what strange gear you've installed ROCK on!


(Rene Bouwmeester) #41

4 posts were merged into an existing topic: KEF LS50 wireless - roon ready?


(Andrew Cox) #42

I’ve finally successfully installed ROCK on a Gigabyte BRIX. The difficulty was that I already had Windows Server 2012 and Debian installations on a partitioned mSATA 128 SSD. Gigabyte motherboards appear to have a continuing inability to see a USB boot drive if they can see any fixed boot drive. I had to format the mSata drive using an external mSATA-USB casing and then play Gigabyte USB hokey pokey a few times before the USB ROCK installer showed up as a boot drive in the BIOS.

After that it was plain sailing. A 2TB internal SSD for music was formatted and available in the ROCK/Data share without a problem.


(Richard Hicks) #43

Forgive me if someone has already posted something similar to this…

Yesterday I installed ROCK on a computer with a Gigabyte Z270N-WIFI motherboard and an i7-7700k cpu overclocked to 4.8GHz in a fanless case. :dizzy_face: So far no problems and the case barely gets warm.


(Mike Davis [ Banned ]) #44

Good thing for that overclocking. Wouldn’t want to be underpowered for the application :slight_smile:


#45

Anyone have an issue installing on a desktop where after install, on bootup, Roon Rock coukdnt find Network address?

Mines is stuck on this!
Its a Gigabyte Z-77 board with onboard Lan.

Ive disabled Network boot, and all EUFI related settings…so stumped!

Thanks.


(Henry) #46

Mine didn’t for a while. A couple of reboots did it and that was on supported hardware.


(Danny Dulai) #47

nothing to be stumped by… I just never added ethernet drivers/firmware for all cards, and probably not yours. If you boot Ubuntu on it and send me your dmesg, I can look to see if it would be interesting to add…


#48

Danny…
You da Man.

Thanks Bro, will do exactly that and post back. :thumbsup:


(Henry) #49

Any reason why it might not work to a USB to Ethernet adaptor we know should work OK with ROCK?


(Mark Edwards) #50

ROCK installed on an ASUS ROG STRIX H270I motherboard with an Intel Core i7 7700, Samsung 960 EVO 250GB M.2 SSD and 8 GB Corsair Vengeance Ram and a 1TB Samsung 850 EVO SSD.

Seems to be running beautifully, took most of the day to get everything running properly. Restored from my backup twice as somehow a lot of my metadata grooming disappeared. Even on the second attempt it was the same. PITA. Quite a few album merges had split and one album was showing as another artist entirely and I could not work out what was going on but I got there in the end.

This is my first P.C. build and I can’t say that it was a particularly enjoyable experience but its done now. Quite a few things missing from the HDPlex carton and the SATA power cable was too short, Larry from HDPlex is extremely helpful and quick to respond but overall I wasn’t that impressed with the documentation but then maybe fanless case builds aren’t really for people who don’t know what they are doing. Hopefully it will be better than running my beast of a MacPro 24/7.

Whilst Roon was scanning my library the HDPlex case was almost too hot to touch. I was a bit concerned about it but the cooling fins were obviously doing their job. I was also apprehensive when I first turned the unit on as I have never built a computer from scratch and it’s a fairly difficult build with the cooling pipes, arctic silver and not placing too much pressure on the processor. Hopefully it will continue to run but I know that ROCK isn’t supported on anything but NUC’s.

I was hoping to use one ethernet direct to my Meridian MS600 and the other to my router, eventually the router will be 10 metres away from the HDPlex and I can’t see the point in having two 10 metre patch cable runs. I could not work out how to get my MS600 to show up in Roon when it was connected directly, hopefully with some help from clever people I can figure it out.


Is there a well-designed fanless NUC enclosure out there?
(James Antognini) #51

I have a hardware setup that’s quite similar, based on a Streacom FC10 Fanless Heatpipe. But I had EndPCNoise.com build the system (they did a fine job). You took the harder path of building your system yourself.

I should add I run Roon under Win10 x64 Pro, so my software setup isn’t ROCK.


(Mark Edwards) #52

From a cosmetic viewpoint I really would have preferred the Streacom case, the finish complements my Meridian gear but I was put off by the fact that it only has four heat pipes for the processor cooling. The HDPlex has eight.

What processor are you running and what is it’s TDP?

I was given the i7 processor, if I had purchased one I would have gone for an i5. The i7 has a TDP of 95W and as I said in my earlier post the side of the case was almost too hot to touch whilst Roon was scanning my library, it was 36°C here in Adelaide yesterday so our house was quite warm. Our summers can have extended periods above 40°C and even with air conditioning the house can be fairly warm. Efficient cooling was a priority for me.

That being said if I had to choose again I think I would opt for the Streacom case. There were many little details with the HDPlex that bugged me.


(James Antognini) #53

I’ve not noticed any real heat on the case in the few times I’ve touched it. But I’ve not really pushed Roon, eg, I moved in a library already “massaged” by Roon on the computer I was replacing, and I don’t use options in Roon that generate a lot of CPU use.

The CPU is an Intel i7-7700, with TDP of 65W. Since your TDP is 95W, I would guess you have an i7-7700K. I looked at that but was a bit concerned about the heat generation and didn’t feel I needed the extra power.

Here are more details of my system:

  • Fanless Case: Streacom FC10 Alpha Fanless ATX Media Case (Black) (No Optical Drive)
  • Motherboard: Asus Z170-Deluxe (1151/Skylake) Motherboard
  • Skylake/Kaby Lake CPU: Intel i7-7700 (Kaby Lake, 3.6 GHz, 65W, Benchmark 11035)
  • DDR4 RAM: 16GB Corsair DDR4 2666 (2x8GB - CMK16GX4M2A2666C16)
  • Fanless Power Supply: External Pico PSU (Fanless, 150W)
  • Quiet Video Options: Use Onboard Video (Onboard Video Only- CPU Determines Video Series)
  • Operating System: Windows 10 Pro (64bit) (Up to 512GB)
  • Quiet System Drive: Samsung 960 EVO 500GB M.2 NVMe PCIe 3 x4 SSD (3200/1900 MBps R/W

Once I received the built system, I added a Samsung 850 EVO 1TB SSD (from Amazon, where the SSD was cheaper than what EndPCNoise asked for the same) and, under Win10 x64 Pro, combined that SSD with a slightly older 256GB SSD to form a 1.12TB storage space (handled like a drive). This (D:) is where I keep my music library; the OS and Roon itself are on the 500GB NVMe SSD (C:).


(Andrew Cox) #54

7 posts were split to a new topic: RoonServer on a laptop?


RoonServer on a laptop?
(Mark Edwards) #55

Just realised that my processor is the same as your at 65W, don’t know why I thought it was 95W TDP.


(Mark Edwards) #56

Just a question to all that have installed a MOCK, have you had any issues with grouped zones?

I am having issues with my Airplay zones, I have a Bowers & Wilkins A7 and Zeppelin Air, they have been grouped as a single zone, the Zeppelin is hardwired with Ethernet and the A7 is connected via wireless.

Individually I have no issues with music played to either of the units but when they are grouped as a zone sometimes they work together other times I get music coming out of the Zeppelin and nothing from the A7. One time they were playing together and when I adjusted the volume via my iPhone the music stopped and would not start. Other times the grouped zone is rock solid and sometimes you can see a song playing on Roon but nothing is coming out of either unit.

Its very frustrating (but I guess thats what you get for playing with a MOCK).


(Andrew Cox) #57

Do you have Roon on another computer ? If so try running a new Core (may have to transfer licence back and forth) with a small library and see if this behaviour persists. If so, we’ll know it’s not a MOCK issue and can take it up with Support.


(Mark Edwards) #58

Hi @andybob I have just transferred the license over from my MacPro and had migrated my Roon database from said setup (where it had never missed a beat), so either my database was somehow corrupted or it’s an issue with my MOCK.

I did migrate my database twice because some of my grooming had gone awry, double albums were once again split into two separate entities. Roon scanned the entire library, which I didn’t think would happen if you were just migrating your database. The same thing happened the second time I did the migration.

I’ve now gone into the BIOS and turned off the onboard wireless and Bluetooth and will report back my findings later.


(Chris Keller) #59

Did it!

I put ROCK on a NUC like “Mini-PC” from eglobaltech.cn. It is basically a standard Intel Kaby Lake NUC PC without fan with some 16GB RAM, and two 512 SSD with the American Megatrend BIOS and an aluminium alloy case. I didn’t find the UEFI BIOS settings so left the BIOS untouched. I have 10 SONOS speakers all around the house, 2 Apple TV 4, 1 Bluesound Powernode2 connected via LAN via HP Aruba 2920 POE Switch connected to the NUC. All the internet, router, networking / NAS / NUC is in a rack in the basement.

The first installation of ROCK worked out well (less than 30 seconds) by booting from USB, I added the libraries from the NAS (30 seconds) once Rock was up, added Tidal (1 minute) and added the radio stations (10min). The scanning/indexing of the albums took some time (33k titles) and the iOS/PC Roon UI lost connections during that time initally.

Having said this the experience to setup was straightforward. Most importantly the establishment of the connection from the iOS UI to the Roon Rock is now faster for all users than with the previous Win10/RoonServer setup on the same box! Well worth the (not so demanding) tinkering in my case!


RoonServer on a laptop?
(Mark Edwards) #60

No change to my Airplay grouped zone issues, you can see from the signal path that Roon is processing and playing music to both units but nothing is coming out of the speakers, I have logged in to my router and it’s not receiving anything from the Ethernet port of my MOCK. As soon as I un-group the zone both airplay speakers work perfectly.

Maybe it’s an Ethernet driver issue? I might try the second port on the motherboard and see if it makes a difference.