More RAM to Fix Roon Stopping During Playback?

I have Roon 1.7 running on a MacMini (4,1 Mid 2010) with OS 10.13.6, 4Gb RAM, 40Gb HD (6Gb available), Minimserver

The MacMini is connected to a Lumin U1 Mini via WiFi ethernet, and also to a Yggdrasil DAC via USB.

At times, Roon stops playing mid-track…whether streaming via Qobuz or playing local files from a 1Tb Firewire drive connected to the MacMini. Roon will stop, and then skip to the next rack, then play for a minute or do, then skip ahead again. I receive a Roon warning about a networking or processing issue. If I restart the MacMini and Roon, the problem clears (but eventually returns). No other applications are running on the MacMini other than Roon and Minimserver.

The issue occurs whether listening via the Lumin U1 Mini (ethernet) or Yggdrasil (USB).

My question…would increasing the MacMini’s RAM fix the problem?

Hi Grant, whilst playing a song, in your Signal Path, is it displaying a ‘Processing’ value? It will show as a multiple, such as ‘3.5x’

If nothing is showing then I believe this indicates that Roon isn’t being taxed from a processing perspective (which may indicate the issue lies elsewhere).

An answer to this will help with diagnosis and a response to your question.

Good luck in finding a solution

Hi Stampie,

Roon shows “Processing speed: 12.2x”

I have Roon Sample Rate Processing set to Max Sample Rate, which is converting FLAC 44.1kHz 16 bit to 192 kHz 32 bit.

Hi Grant. Welcome to the Roon Community!

Just to rule out any hardware failures/issues, I would do a hardware diagnostic check.

Did you look at the CPU/Memory usage using Activity Monitor to see if indeed inadequate hardware is causing performance issues? For reference, I run Roon on a 2014 MacMini with 8GB RAM with no issues.

I need instruction for how to read and evaluate Activity Monitor.

Anything over 1.0x, some say over 1.3x, indicates it isn’t a processing problem.

Thank you. Processing speed goes above 13x at times.

Also see this post -

Can you free up some space on your system drive maybe, 6gb sounds low

I am not sure how much drive space is used for library

I had a similar issue , clearing space helped

I’ve cleared out every possible unused, unnecessary file (including system files).

I would need to install a new, larger SSD drive.

You didnt say is the system drive an SSD or HDD ?

Solid State SATA Drive

What happens if you do not do any DSP, at least as a test? The Yggdrasil’s internal upsampling filter is excellent, I doubt you can do better with external upsampling.

As some others have suggested, 6GB left on the HD is really low. Roon Core is quite a large process (3GB virtual right now on my Linux NUC core machine) and macOS can choke when disk space needed for paging idle pages of a large virtual process is scarce. If your Roon Core process is as large as mine, I’m sure there’s a bunch of paging going on because macOS and its helper processes need quite a bit of main memory too.

Activity Monitor, Memory tab, can tell you a lot, but in your shoes I’d try to upgrade both main memory and HDD, they are really small for modern software that expects more memory to perform well.

I think I’m simply going to send it to OWC for hard drive and memory upgrades. Less than $260 including shipping seems like a no-brainer.

1 Like

It is based on roon’s minimum specs well below what’s recommended. i3 Ivy Bridge.

I have a practically non existent local library, and running Roon Core in an Ubuntu VM in Freenas has been perfect for a couple days.

The FREENAS server is directly connected to a gigabit network. My two outputs are one PC in the main listening room that is directly connected to the gigabit network. The second output is in my bedroom, a very old laptop (core 2 duo with windows 7 and 4GB RAM), connected wirelessly to the network. I have been streaming from Tidal in Roon and also some dics from my very small local library and everything has been perfect.

The VM has only 4GB of RAM provisioned, two virtual CPUs and is under Ubuntu server 18.04 LTS.

The server has a weakish Pentium G4400 and is running three separate jails (VM) with transmission, Plex server and OpenVPN. It has 16GB RAM, The storage I dont remember what kind of RAID I implemented. I am not versed in storage solutions. I think it was RAIDZ1: I have three disks and two of them have to fail in order to have data loss. So far it is working quite well.

If you find that MAC OS with 4GB is at fault of your issues, I’d suggest trying installing ubuntu 18.04LTS and then the easy Roon Core install. I had issues but they were layer 8…I had used ubuntu 14.04 and didnt know in 18.04 networking configuration had changed from what they used to to netplan.

Sorry Rafael, I’m not an IT specialist, and I don’t speak that language! LOL :wink:

Thank you for your reply, though.

I had similar issues recently. It seems ROON likes a robust network and data packet losses can trigger this issue. My network is a convoluted setup including multiple switches around the house. I used a ping monitor to assess the packet loss on my network to my ROON endpoint, which was about 2.5%. I rewired things and got the packet loss down to less than 0.5% and the skipping problem went away.

I notice you are using WiFi, which makes me wonder whether the connection is robust enough…

1 Like

Your using WiFi. This really is not recommended to use WiFi on your core and is 99% likely to be the root cause of your problem. Roon is not lightweight on the network as it’s a server system it is pulling data from the internet if streaming from services such as Tidal an Qobuz and then pushing them to your streamer it Al has to go in/out through the core.

WiFi only sends data from one device at once and the bandwidth is limited constantly changing and shared between all devices on your network so as Roon is pulling and pushing it’s eating away at your available bandwidth for other devices. If your just using the Lumina inbuilt streaming from then it’s only that device using bandwidth and Lilkey to be ok.

Whilst I know it’s not practical try hard wired in some cases it’s the best option try it to your router and then see if it sorted out your issue, or look at more robust WiFi solution.

@Mark Harding and @Simon_Arnold3, yours were good suggestions, so I ran Speedtest on the MacMini. The results were 64.7 Mbps download, Ping 14 ms, Jitter 1.2 ms and 0% packet loss.