Mouse pointer too small to see on 4K displays [Ticket In]

Hi, when moving the pointer across the roon screen, and only the roon screen, instead of changing from the arrow to the hand pointer the arrow changes into a single pixel. As stated this only happens when i’m moving within roon. If I uninstall and reinstall the mouse driver it may fix the problem for a while or not. Anyone else had this problem?

I have the same issue, but only on parts of the Roon screens. And I don’t think it’s a single pixel, but a very tiny hand with one finger extended (like ready to click).

I still have this problem and I have tried all things that I can think of, I have even created a custom hand pointer that in other programs works but not in roon. The arrow pointer in other programs when hovering over a selectable link changes into my custom pointer giving the arrow a blue surrounding circle but in roon it changes into the normal hand pointer… that is when it works… I still have randomly the arrow changing into a 2 x 3 pixel rectangle on my 4K monitor and is almost impossible to see/find. My question is: Where does roon get it’s cursor styles from, obviously not the system. I need to fix this or it’s goodbye to roon.

This is a combination of a scaling issue (you’re using a 4K monitor with a high resolution) and the fact that Roon uses the OpenGL graphics library for its UI. I’m flagging this to the support folks - @support - to see if there’s a fix for this currently available, or for them to pass the issue on to the dev team.

Thank you Geoff but just to clarify sometimes it works perfectly, then perhaps the next time I open roon without changing anything it doesn’t, it really is random. If I have multiple windows open the pointer behaves correctly in all of them except roon… so perhaps as you suggest it is the OpenGL but then why randomly?
Again thank you for your attention.
Regards, Phil.

Hi @Philip_Lockton1 ---- Thank you for the report and sharing this observation you have made with us. The feedback and insight are both very appreciated!

I would like to get your information over to our QA team to see if we can reproduce this behavior in house but before I do that my I very kindly ask you to please provide me with the following:

  • A brief but accurate description of the device currently displaying this behavior. The more detail you can provide in regard to the specs of the machine the better,

  • Just to confirm, are you only seeing this issue on the mentioned 4K monitor OR have you verified that the behavior is consistent on another type of monitor?


Hi Eric,
I have tried it on another 21" 1680x1050 monitor and have the same problem, the same with a different mouse. Below are my system specs.
|OS Name|Microsoft Windows 10 Home
|Version|10.0.17134 Build 17134|
|OS Manufacturer|Microsoft Corporation|
|System Name|PHILZ370|
|System Manufacturer|Gigabyte Technology Co., Ltd.|
|System Model|Z370 AORUS Gaming 5|
|System Type|x64-based PC|
|System SKU|Default string|
|Processor|Intel® Core™ i7-8700K CPU @ 3.70GHz, 3696 Mhz, 6 Core(s), 12 Logical Processor(s)|
|BIOS Version/Date|American Megatrends Inc. F6, 3/04/2018|
|SMBIOS Version|3.0|
|Embedded Controller Version|255.255|
|BaseBoard Manufacturer|Gigabyte Technology Co., Ltd.|
|Platform Role|Desktop|
|Secure Boot State|Off|
|PCR7 Configuration|Binding Not Possible|
|Windows Directory|C:\WINDOWS|
|System Directory|C:\WINDOWS\system32|
|Boot Device|\Device\HarddiskVolume6|
|Hardware Abstraction Layer|Version = “10.0.17134.1”|
|Time Zone|New Zealand Standard Time|
|Installed Physical Memory (RAM)|32.0 GB|
|Total Physical Memory|31.9 GB|
|Available Physical Memory|27.2 GB|
|Total Virtual Memory|36.7 GB|
|Available Virtual Memory|29.6 GB|
|Page File Space|4.75 GB|
|Page File|C:\pagefile.sys|
|Kernel DMA Protection|Off|
|Virtualisation-based security|Not enabled|
|Device Encryption Support|Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and the device is not InstantGo, Un-allowed DMA-capable bus/device(s) detected, TPM is not usable|
|Hyper-V - VM Monitor Mode Extensions|Yes|
|Hyper-V - Second Level Address Translation Extensions|Yes|
|Hyper-V - Virtualisation Enabled in Firmware|Yes|
|Hyper-V - Data Execution Protection|Yes|

Monitor Philips BDM4037U connected via display port to GTX1080Ti 11Gb ram
|Name|NVIDIA GeForce GTX 1080 Ti|
|PNP Device ID|PCI\VEN_10DE&DEV_1B06&SUBSYS_37521458&REV_A1\4&2DB3ECDA&0&0008|
|Adapter Type|GeForce GTX 1080 Ti, NVIDIA compatible|
|Adapter Description|NVIDIA GeForce GTX 1080 Ti|
|Adapter RAM|(1,048,576) bytes|
|Installed Drivers|C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_38c9bee769f9ef1f\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_38c9bee769f9ef1f\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_38c9bee769f9ef1f\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_38c9bee769f9ef1f\nvldumdx.dll|
|Driver Version||
|INF File|oem17.inf (Section090 section)|
|Colour Planes|Not Available|
|Colour Table Entries|4294967296|
|Resolution|3840 x 2160 x 59 hertz|
|Memory Address|0xEE000000-0xEEFFFFFF|
|Memory Address|0xD0000000-0xDFFFFFFF|
|Memory Address|0xE0000000-0xE1FFFFFF|
|I/O Port|0x0000E000-0x0000E07F|
|IRQ Channel|IRQ 16|
|I/O Port|0x000003B0-0x000003BB|
|I/O Port|0x000003C0-0x000003DF|
|Memory Address|0xA0000-0xBFFFF|
|Driver|c:\windows\system32\driverstore\filerepository\nv_dispi.inf_amd64_38c9bee769f9ef1f\nvlddmkm.sys (, 16.37 MB (17,168,744 bytes), 10/05/2018 23:02)|
Please let me know if more info is needed.
Regards, Phil.


I’ve had this problem for a long time. Is there a solution?

Hi @Esskay,

Thank you for pinging us again regarding this issue and apologies for any frustration.
Can I please ask you to let me know a few additional details?

  1. What kind of Core are you using (model/manufacturer) and what kind of graphics card do you have?
  2. Is your graphics card driver up-to-date on the newest firmware?
  3. Are you using any scaling options for your PC?
  4. Are you using a single monitor or a multi-monitor setup?
  5. What is the model/manufacturer of your monitor(s)?

The core is a Dell Inspiron 5558 laptop running an Intel i7-5500. But that’s not where the little hands show up.

The little hands are on a Lenovo Yoga 920-13IKB running an Intel i7-8550U. That computer is running Roon for control only. I use that computer to edit tags and edit Roon’s album settings.

The graphics are Intel UHD Graphics 620, and are up-to-date, at least according to Lenovo.

The scaling is set at 250% with 4K resolution. The only monitor is the laptop’s built-in screen.

I tried changing the standard hand for a larger one. It changed the hand display with most software, but not with Roon. So I set it back to the default.


Hi @Esskay,

Thanks for letting me know that information. I just wanted to follow up with you to let you know that we’re still looking into this and are trying to see if we can reproduce this issue with the 4K monitor we have in-house. If you do make any new findings regarding this issue in the meantime, please do let me know. Thanks!

Hello @Esskay,

We have taken a look at this behavior on a 34in 4K monitor but have been unable to reproduce your findings, even with the same scale factor of 250%. This may sound like a simple question but I have to ask - have you rebooted your Core PC after changing the scaling factor?


Both the scale setting and the small hand problem have been stable for a long time. Both the core and the control computer have been rebooted many times.


Hello @Esskay,

I appreciate your patience while we have looked into this behavior further. We were able to reproduce similar behavior on another staff-member’s 4K display and have submitted this information into a ticket with QA.

I can’t comment on a specific timeline of when this behavior will be addressed, but getting this behavior reproducible is a critical-first step, and it is great news that we have been able to do so.

Thanks again for your report and for bringing this to our attention!

Hello @Esskay,

We’ve recently released Roon 1.7 (Build 521) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:

The Team at Roon Labs

Nope. The tiny hands persist.


1 Like

same here…

I have exactly the same issue

Hi @Esskay/@gmit2/@FredB,

I want to take another look at this issue to see what can be done here. Can I please ask all of you to provide the following information?

  1. What kind of Core are you using - what is the OS and the specs for it?

  2. What is the reported resolution of your display(s)? On Windows you can right-click on your Desktop -> Display settings and it should list the resolution there.

  3. What GPU and GPU driver version do you have? If you are running Windows, you can find this by searching for “System Information” in the Start menu -> Components -> Display.

  4. Which version of Roon are you running? Are you on build 528? You can find this info in Roon Settings -> About.

  5. Can you please use these instructions to access your Roon logs and provide a set from the affected machine? The best way to get them over to me would be via a shared Dropbox / Google Drive link, but if you don’t have either, just let me know and I can provide alternate upload instructions.

  6. Can you please provide a short .GIF or video of the behavior of the mouse in Roon compared to another application? If you can have the two applications side-by-side and record the .GIF/Video of what the mouse looks like when moving from another app to Roon, it would be very helpful. To create a .GIF you can use LICEcap.

Thank you!

I believe it’s because of Roon not handling correctly DPI on Windows.

I have 4 monitors, all of them have different resolutions and DPIs.

The main monitor is 4k 225%, and the one where I use Roon is FHD 125%

Roon always starts on the main monitor (which is probably a part of the problem), after which I move it to the smaller one.

In Control Panel/Mouse, I have ‘extra large’ set of pointers. When Roon is on my main monitor, Roon hand pointer is about twice smaller than Windows pointers of ‘standard’ size - it’s clearly custom, not system.

If I move Roon to the other monitor, Roon hand gets even smaller, being almost a dot.