Moved core to ROCK, now PC won't play [Resolved - Avast firewall settings]


I’ve been using Roon on a single laptop (DELL XPS 15/Windows 10) and decided to move my core to an Intel NUC7i5 running ROCK. The NUC is connected directly to my wireless router as is the NAS that stores my music.

I can access Roon ROCK thru my laptop that originally served as the core, but can no longer play music on this computer. When I go to Settings/Audio the laptop does not show up under networked devices.

I have uninstalled/reinstalled Roon on the laptop and deleted the database files as recommended in the FAQ.

What am I doing wrong?

I would try completely disabling firewalls on the Dell first, to see if that helps.

If it does, you’ll need to make sure you have exceptions in place for RAATServer and Roon.

If that doesn’t help, let us know and we can take another look.

1 Like

Thanks. I changed the Firewall settings, and that seems to have solved the initial problem. I can now see the audio devices connected to the laptop (I’m using an iFi iDAC2). However, there is now a new problem. I am still unable to play any music. The system just goes quickly from track to track, and posts the error message: “Transport: Failed to load media” or “Transport in use.”

Any suggestions? When I go to Settings/Storage it shows the NAS as connected. Not sure what else to check.

Update: Tried something obvious: Turned of the Firewall (Avast) again and music is now playing. However, going without the Firewall is obviously not wise. It was allowing Roon and RAATServer. Anything else I would have to configure on the Firewall?

OK, never mind. Resolved problem with the advice given here:


Nice job – and thank you for sharing the solution!

No problem. I must express my appreciation for this forum (and member LowKey in particular). There is absolutely no way I would have been able to figure out that solution on my own.