DAC not detected on Roon Core [Resolved]


Hi there, since last night, Roon 1.4 could not detect my ifi Nano DSD DAC connected to my Core Computer (Win 10 64bit PC). I am able to playback videos or music outside of Roon to my speakers via the ifi Nano DAC. I tried rebooting the PC multiple times and also restarting Roon but the DAC still won’t show up. I checked my windows driver for the ifi DAC and it works.

My other devices (Bluesound Vault, Node and Lumin Streamer) works fine and can be detected.

I went to settings > search for devices but the screen could not find any devices (after waiting for 10 mins - it still shows “searching for devices”)

Attached prn screen

Can you please help troubleshoot?


Thanks for the report @Joseph_Ow, the feedback is appreciated. Sorry to hear of the troubles.

Moving forward, can you please confirm that there are no active firewalls or antivirus applications currently running on your Core machine? If there are indeed, may I kindly ask you to temporarily disable these functions and verify if this actions yields a change in behavior with iFi Nano.


Eric, thanks for getting back. @support

I have Windows Defender firewall and AVAST Anti Virus active. Both app were enabled previously and Roon was able to detect ifi Nano DAC on the Core Win 10 PC.

I temporarily disabled both apps, restarted Roon and the ifi Nano DAC still did not show up. I unplugged the DAC, restarted it and still doesn’t show up.

Hi @spiderjoe ---- Thank you for the update and sharing your observations after giving the proposed test a go. The insight is appreciated!

Moving forward, I have went ahead and enabled diagnostics on your account so our team can try to get a sense as to what could be causing the issue with the iFi Nano. What this action will do is automatically generate/upload a diagnostics report containing a fresh set of logs the next time the application is launched on your core machine. Once I have seen the report come in I will follow up to confirm that it has been received.

In the meantime, I remember that some of our users ran into issues with their Avast firewall settings after receiving an update from Avast (example #1, example #2, example #3). What was interesting is that in all of these cases things had functioned without issue with Avast active and then after the update the “problems” started to occur.


Eric, @support

Since I was using Win Defender firewall, I went back to check Win Defender firewall settings to ensure roon.exe app was allowed to pass through. (Roon was ticked)


Anyway, I rebooted Roon one more time and voila! I can see my ifi nano DAC and it plays. Not sure if it had anything to do with other activities your team were doing with diagnostics, but now it works. If it becomes a problem again I will reach out. Thanks, Joe

Thanks for the update @spiderjoe! Glad this was sorted out!

Moving forward, I am going to be closing this thread out and marking it "resolved ". However, should you experience this issue again, drop me a PM and I will gladly re-open to continue troubleshooting with you.

All the best to you and your family this holiday season!