MQA-CD file support


I bought a Japanese MQA-CD.

I tried to rip it into flac.

roon have identified MQA.

There are a total of 15 songs, 1, 5, 6, and 15, which cannot decode MQA.

I tried adding extension .mqa .mq .mql but it didn’t work.


I bought two MQA CDs and had similar problems.

Turns out that the MQA folks have a program ( for Windows or Mac ) that will analyze and correct the track information after an MQA CD has been ripped. It worked for me.

Just download the MQA Tag Renaming App and let it process the files you ripped.

I found I needed to run it against a copy of my ripped files in a folder that Roon was not watching and then copy the processed files into a watched folder.


Is it possible that the rip wasn’t entirely bit-perfect? Did you use a program like dBpoweramp that checks against a checksum database?


I use dBpoweramp, Exact Audio Copy, foobar2000 rip, the result is the same.


Thanks you help.

I tried the MQA Tag Renaming App and let it process the ripped files.

1, 5, 6, and 15, which cannot decode MQA.


Sorry the app did not fix the problem. It’s always possible there is something about those tracks that cause the MQA App / Roon not to see them as MQA.

Where did you purchase the album? Having trouble finding the MQA version here in the US.



Purchased at the tower records store in Japan.


Lucky you! We had a Tower Records here in Memphis Tennessee but they closed in 2006 / 2007. Our last chain record store ( Spin City ) closed last year.


This issue may be related:

I sent a message to to ask about this MQA-CD.

I hope I can get a reply.

With your NT-505, you can also use the TEAC app to play those rips from MinimServer or USB flash drive. See if the problem tracks can be authenticated as MQA this way.


Audiophile bought the same one and tried it.
After using MQA Tag Renaming App first in W20
In the case of the source, dcs rossini can correctly read the MQA of all songs.
But with Roon, there are a few that can’t be decoded.

Can you try NT-505 with native app instead of Roon as suggested above?


I use the TEAC app to play those rips from MinimServer .

All track can decode MQA. ,it’s work.

@noris based on the results here I believe this issue can be grouped into the same ticket for MQA CD.


Thanks for flagging me down here @wklie! I can certainly ask QA to take a look at these files @Kevin_Chi, would it be possible for you to send them over to us for analysis?
I will private message you upload instructions shortly.


Hi @Kevin_Chi,

Thanks for sending those files over. I can reproduce your findings and have submitted the files to QA for analysis. As soon as I have an update for you I’ll be sure to let you know.


Hi @noris

Is there a fix for this in the pipeline? I have the same issue with the following MQA CD:

Grits, Beans & Greens - Tubby Hayes Quartet (Fontana 2019)

I’ve ripped it to ALAC using DB Poweramp - Track 5 is not decoded as MQA in Roon but all the other tracks are ok.

I also used the MQA tag renaming app mentioned above but it didn’t fix the issue.


Hi @Daniel_Murphy,

Welcome to the community! We have an active ticket surrounding MQA Sniffer issues, but I cannot comment on when it will be reviewed by the devs. Can I please ask you to upload the affected media to Dropbox / Google Drive / and then send it to me via a private message? You can click on my name and then “Message” to do so. Once I have these files I can send them over to QA and attach them to our investigation ticket. Thanks!

Hello all,

We’ve just released Roon Build 536 which includes changes that we believe will help improve things here. Please give Roon an update on all of your devices and let us know if you still have any trouble!

You can read the full release notes here:

The Team At Roon Labs


  1. I bought a Japanese MQA-CD.
  2. I ripped it into flac by JRiver MediaCenter 26.0.73
  4. roon 1.7(build 537) works good.