Music suddenly turns to pink noise

I am running Roon Server on a SonicTransporter with HQPlayer played from a Mac Mini. I’m using a microRendu as an NAA.

Intermittently as music is playing, it suddenly turns to pink noise and I have to stop the track in Roon, otherwise it will continue on as the track progresses. I’ve tried everything I can to try to resolve this, but I’m not having any luck.

I checked HQPlayer logs, and there is nothing there. It just shows that I pressed the Pause button, which is what I have to do when the noise happens.

Below is about 15 seconds of the Roon Server Diagnostic file. Does anything look wrong? The noise began approximately at the 18:21:45 mark:

05/07 18:21:42 Trace: [zone] [HQPlayer] auto-swim based on Ryan Adams - To Be Without You 
05/07 18:21:42 Trace: [library] finished with 1 dirty performers 0 clumping tracks, 0 clumping auxfiles 0 compute tracks, 0 deleted tracks, 0 tracks to (re)load, 0 tracks to retain, 0 auxfiles to (re)load, 0 auxfiles to retain, and 1 changed objects 
05/07 18:21:42 Debug: [library/index] updating search indices: 0 ops 0 adds, 0 removes 
05/07 18:21:42 Trace: [dbperf] flush 0 bytes, 0 ops in 21 ms (cumulative 14722 bytes, 23 ops in 13861 ms) 
05/07 18:21:42 Trace: [zone] [HQPlayer] Playing Swim 
05/07 18:21:43 Trace: [hqp/client] [] GOT UNSOLICITED 
05/07 18:21:43 Info: [zoneplayer/base] Queueing: /storage/music/flac/usb/Hi-Rez/Ryan Adams/Prisoner/02 - Prisoner.aiff 
05/07 18:21:43 Info: [zoneplayer/base] Open result (Queueing): Result[Status=Success] 
05/07 18:21:43 Trace: [prebuffer] ready 326400/960000 (34%) @ 0/191 sec 
05/07 18:21:44 Trace: [hqp/client] [] GOT UNSOLICITED 
05/07 18:21:45 Trace: [prebuffer] status 471374/960000 (49%) @ 196/201 sec 
05/07 18:21:45 Trace: [hqp/client] [] GOT UNSOLICITED 
05/07 18:21:45 Trace: [prebuffer] status 432974/960000 (45%) @ 197/201 sec 
05/07 18:21:46 Trace: [hqp/client] [] GOT UNSOLICITED 
05/07 18:21:46 Trace: [prebuffer] status 384974/960000 (40%) @ 197/201 sec 
05/07 18:21:46 Trace: [prebuffer] status 346574/960000 (36%) @ 197/201 sec 
05/07 18:21:47 Trace: [prebuffer] status 288974/960000 (30%) @ 198/201 sec 
05/07 18:21:47 Trace: [hqp/client] [] GOT UNSOLICITED 
05/07 18:21:47 Trace: [prebuffer] status 221774/960000 (23%) @ 199/201 sec 
05/07 18:21:48 Trace: [hqp/client] [] GOT UNSOLICITED 
05/07 18:21:48 Trace: [prebuffer] status 173774/960000 (18%) @ 199/201 sec 
05/07 18:21:48 Trace: [zone] [HQPlayer] PlayPause 
05/07 18:21:48 Trace: [zone] [HQPlayer] Pause 
05/07 18:21:48 Trace: [zoneplayer/hqplayer] State transition Playing => Paused 
05/07 18:21:48 Trace: [hqp/client] [] SENT 
05/07 18:21:48 Trace: [hqp/client] [] GOT 
05/07 18:21:49 Trace: [hqp/client] [] GOT UNSOLICITED 
05/07 18:21:53 Trace: [zone] no playback for 5s, suspending to release audio device 
05/07 18:21:53 Trace: [zone] [HQPlayer] Suspend 
05/07 18:21:53 Trace: [zone] [HQPlayer] Stop 
05/07 18:21:53 Trace: [zoneplayer/hqplayer] State transition Paused => Stopped 
05/07 18:21:53 Info: [audio/env] [zoneplayer -> stream] All streams were disposed 
05/07 18:21:53 Trace: [hqp/client] [] SENT 
05/07 18:21:54 Trace: [hqp/client] [] GOT 
05/07 18:21:56 Info: [stats] 1587mb Virtual, 468mb Physical, 189mb Managed, 0 Handles, 38 Threads

Hi @Gary_Gil ---- Thank you for the report and sharing your feedback with us. To help aide in my evaluation of this behavior you are experiencing, may I kindly ask you to please provide the following:

  1. An expanded description of your current setup as seen here.

  2. Do you notice any relation between this behavior and the file type/sample rate being streamed? In other words, is there a specific type of media you are noticing this with or is not media dependent?

  3. Can you provide some insight into what troubleshooting you’ve tried thus far?


Hi Eric,

Thanks for the response. I finally had a chance to evaluate this issue further.

Here is a description of my setup per the link you provided:

I’m running Roon Version 1.3 (build 223), with the core on a SonicTransporter.
Music library is on a 4TB HDD connected to the SonicTransporter via USB. My library has 17,800 tracks and consists of Redbook, hi-rez and DSD material.

I have a Mac Mini running OS X (El Capitan) that runs HQPlayer and I have a microRendu as an NAA connected to my DAC.

After further testing, I can confirm with about an 90% confidence that I am experiencing this issue (music playing suddenly turns to pink noise) on the following file type/sample rates:


I am not hearing this behavior on the following file types/sample rates:


I’ve done the following troubleshooting so far, and everything continues to have the same issue:

  1. I setup my Mac Mini in Bootcamp mode running Windows 10.
  2. I have connected directly to my DAC via USB, running Roon directly.
  3. Recently I am connecting directly from my Mac Mini to the microRendu.
  4. Bypassed HQPlayer entirely and used Roon playback (connected via microRendu)

The only troubleshooting I have yet to try is loading a sample music library somewhere other than the sonicTransporter to see if the problem persists, but I’m not sure how to implement this test. I suppose I can create a music folder somewhere else (on my Mac Mini perhaps) and Add a Folder to my Storage section of Roon.

Any recommendations/advice?

  • Gary

Hi @Gary_Gil ---- Thank you for touching base with me and taking the time to answer my questions/share the observations you’ve made during your troubleshooting. The feedback is very appreciated!

I have meeting scheduled with my team for later this week to discuss this behavior you are experiencing so we can try to determine what could be causing this to occur. I also remember another report that was posted a few months ago which seemed similar to yours. Can you give that link a look for me?

Lastly, can you please provide the make and model of DAC you are currently working with.


Hi Eric, I read the other report and it sounds similar, but in my case, it happens whether I’m upsampling or not. But oddly it only happens on 24 bit high-res tracks.

Tonight I tested 11 high-res tracks and played them directly from HQPlayer and bypassed Roon, and there is NO NOISE at all. Not only did the static noise never happen, but during sample rate changes with Roon + HQPlayer, I could here some noise. Not loud, but just noise. With just HQPlayer, there is no noise at all. I don’t know if this is related or not.

So this test seems to isolate the problem to Roon and perhaps having Roon Core running on sonicTransporter? Or perhaps having the music library located on a USB drive connected to SonicTransporter.

I will do more testing now with Roon and bypassing HQPlayer (again). I will report back shortly.

  • Gary

Another quick data point. I just tried microRendu in RoonReady mode bypassing HQPlayer and I did NOT hear the static noise, HOWEVER… when I changed to a track that’s 174.4/24 there was a LOUD white noise for about 1/2 a second. I stopped the track, so it might have gone longer.

I don’t know what to make of this. I will continue testing.

  • Gary

Hi @Gary_Gil ---- Thank you for the follow up and providing the results of the testing you’ve done thus far. The insight is very appreciated!

As mentioned I am planning on running this report by my team and I am certain they are going to want to know what DAC you’re working with. Please provide this information for me so I can complete my report. Many thanks!


Hi @Eric my DAC is the HOLO Audio Spring DAC Kitsune Tuned Edition.

I will continue testing to see if I provide any other data points to work with.


  • Gary
1 Like

Hi @Eric - today I added in a Singxer SU-1 digital to digital converter into the chain, but the same behavior continues. Now the signal is as follows:

Mac Mini -> Sonore microRendu -> SU-1 out via I2S -> DAC

To too see and hear what I’m talking about, I set my iPhone to record a video while listening to a hi-rez track (176.4/24) and sure enough, the noise happened.

Here’s a link to an Unlisted video on YouTube:

Once again, I don’t know what specifically is causing this issue, if it’s the combination of Roon + HQPlayer, or I suppose it could be my DAC. I’m not entirely sure.


Hi @Eric, I wanted to post an update with more findings after further testing:

The noise DOES NOT happen under the following scenarios:

  1. When I use Roon alone in RoonReady mode using the microRendu (not using HQPlayer).
  2. When I use HQPlayer and bypass Roon entirely and everything else in the chain identically setup.

This leads me to the conclusion that this problem is specific to running Roon + HQPlayer in NAA mode.

Do you have any suggestions on other tests I can do, or changes to my configuration to check?



Hi @Gary_Gil ---- Thank you for touching base with me and providing a video highlighting the issue you are facing :clap: :thumbsup: Apologies for the delayed response.

Moving forward, my assumption is that all of your settings have remained the same during your troubleshooting but just in case, may I kindly ask you to please provide the following screenshots:

  1. When music is turning to “pink noise”
  • Your “device setup” screen (i.e Roon settings).
  • HQPlayer settings.
  • Signal Path
  1. Roon alone in RoonReady mode using the microRendu (not using HQPlayer).
  • Your “device setup” screen (i.e Roon settings).
  • HQPlayer settings.
  • Signal Path
  1. When I use HQPlayer and bypass Roon entirely and everything else in the chain identically setup.
  • Your “device setup” screen (i.e Roon settings).
  • HQPlayer settings.
  • Signal Path

Lastly, just to confirm, you’re running the latest version of HQPlayer, correct?


I may be way off on this, but I have had the exact same problem for a year, and I’ve been through several computers and now an sms-200. Also the problem has persisted through two different dacs and different software: Audirvana +, jRiver MC, and Roon. I often got the hash/ pink noise when I touched my dac for some reason; so I decided to try running a ground wire from a chassis screw on my dac to the screw of the face plate of the electrical outlet I use for my audio system. I have had no noise for 3 or 4 days now. It’s undoubtedly too soon to declare victory, but you might try something similar. It’s easy enough to do.

Hi @Eric,

For #1 When music is turning to “pink noise”, the screenshots are below. Note, #2 and #3 do not have the problem, but I will still upload the screenshots for you in separate posts.

Yes I’m running the current version of HQPlayer - version 3.16.4

  • Gary

Hi @Eric,

Here are the screenshots for #2 - Roon alone in RoonReady mode using the microRendu (not using HQPlayer).

Hi @Gary_Gil ---- Thank you for the follow up and providing the requested screenshots, both are appreciated!

We are going to do some testing on our end to see if this behavior can be reproduced and once my tech team has updated my report I will be sure to reach out with our thoughts/findings.


Hi @Eric, one other data point I may not have mentioned. I am using the volume control in Roon because I don’t have a preamp at the moment. I don’t know if this could be related to the issue or not, but I thought I would mention this.


1 Like

Hi @Eric,

One more scenario that I just confirmed HAS the problem where a hi-rez track (any track other than redbook or DSD) suddenly turns to pink/white noise.

Direct USB connection from my computer to my DAC, without the Sonore microRendu NAA in the chain. Playback is with HQPlayer + Roon, the same as the other scenarios.

Here are some screenshots of the settings:

1 Like

Hi @Eric, did you find out anything more about this issue?

I can replicate the problem consistently when I use Roon + HQPlayer, whether I connect via USB or ethernet using the microRendu as an NAA. The only file types affected are hi-rez (anything other than Redbook or DSD).

I am now running Windows on my Mac Mini, and the same problem occurs. I have even gone to a direct ethernet connection from my Mac Mini/PC to the NAA (microRendu) hoping this would solve the issue, but the problem is still happening.

Note, Roon is running from a sonicTransporter and I’m controlling it via an iPad. Is there any way I can try to install Roon on my Windows machine temporarily just for testing purposes to see if the problem persists? Perhaps a new installation with a temporary license using a different email address that I install directly on the Windows machine, so my main account with my library stays intact?

Any ideas @agillis?

We’ve found some steps for a similar issue, but the report is still with our development team so I don’t have a firm sense yet whether this is an issue with Roon, or HQPlayer, or if something else is going on here.

Having the reproduction steps is a critical first step, so we’re hoping we can make some progress on this soon. The report is in our queue, and we’ll follow up once we’ve had time to analyze the problem.

Thanks for your patience here @Gary_Gil.

1 Like

Ok great! Thanks @mike