Music will not play - errors reported

(JOHN COULSON) #1


I recently switched to Windows 10 64 bit and just installed another “critical update”.
Whether or not this is responsible I cannot tell but Roons behaviour has been a bit odd lately under Windows 10. I’ve had to load up the 16k albums and restore the backup a couple of times this last week.
The PC here is custom made with a Z87PRO motherboard and, ASAIK, is OK. I’ve used CCcleaner and System Mechanic to clear out rubbish and the report is that the system is “Good”. Other PC functions appear to be working without issue.
Has the Roon program developed a glitch and needs reinstallation or ???
The little wheel top right is turning incessantly. I can access and play internet radio and all functions, except play, appear to be working for the music.
Suggestions please.
And I should add I’ve done the obvious reboot of Windows and reboot of Roon which is painfully slow to load :frowning: . All yield the same result - no music play.
LATER: All of a sudden Roon lost contact with drive R with all the music on board and hunted for music in Drive D. So I deleted those folders and it is again reinstalling all the music from the 8TB HDD, a process taking several hours + reinstalling the backup will take a couple more.
The whole Roon setup appears unstable.
Do I blame Windows 10? I’ve already had to effectively reinstall it under “repair” when a non Roon related problem arose…
But this is the first time I’ve struck problems with Roon with Windows 10.

LATER AGAIN: Still loading albums but they are now playing OK. Any clue what is going on???

(Noris) #3

Hi @JOHN_COULSON,

Can you please open up the “activity spinner” and post a screenshot of what activity is going on in the background?

What kind of drive are you using for R, can you let me know the model/manufacturer? Since it appears that the tracks are failing to load and this storage location disappeared, can you also verify the drive’s integrity by using Windows’ Disk Check Feature?

(JOHN COULSON) #4

Both R, and its backup are Seagate BarraCuda Pro 8TB HHDs. R registers usage of 4878 hours on Sea Tools for Windows. I used that program to run a S.M.A.R.T , Short Drive Test & Short Generic test and all were OK.

I’m unfamiliar with “activity spinner” and Googling it let me down a confusing path so, please give me specific links so I can do that.

On going into File Management it said there was no need to test as it was OK - I guess the Sea Tools result had been registered. I ran the check anyway and, as expected, no errors.

But there is something weird going on. Last night I again restored the backup only to find no albums for R loaded this morning but there were some from two other drives. So I again went into settings, deleted access to those other drives, and re-pointed it to R. It is still down loading but the situation is odd. The files are appearing with all edited data so the backup should not need restoring again.

Maybe part of the answer lies in me having drive R too full. It has a capacity of 7.27TB, 6.62 is used leaving 666GB free. I’m in the process on installing another drive (but am having problems - another story irrelevant to this). When this second HDD is operational I’ll move files across to it and put new ones there. Advice on the max. data which should be in R would be appreciated - internet searches have yielded conflicting advice and might not be relevant to Roon anyway.

I’m still suspicious of Windows 10 but none of the above is making sense to this old brain!! I’m tempted to change Roon back to the Notebook and Windows 7 but that would pose difficulties when the second music data drive finally swings into use unless I use a USB hub, something I’m not keen to do as, even powered, I’ve had problems with some hubs. I have an Ankor on the way so guess I could use that.

Advice appreciated -

  • should I switch ROON to use via the Notebook or should I persist in solving Windows 10 problems on this PC?
  • what is the max. data I should leave on drive R?
  • any other ideas on what to do?

All very frustrating - problems I’ve not encountered in over 2 years of using ROON.

POSTSCRIPT LATER: I’m having to re-instate the backup after all. No idea what is going on.

(Geoff Coupe) #5

What Dylan means by this is simply to click on the rotating arc spinning in the top right of Roon, and Roon will display a window telling you what the activity is that is causing the activity spinner icon to display…

It strikes me as there is trouble with the R drive. Is the SATA cable good and properly seated internally?

(JOHN COULSON) #6

Ahah, I’ll check that next time.

BUT, here we go again. All albums loaded from R, steadily and without problems, but no edited data. So I just finished a restore and …. the whole library vanished and Roon was finally detected loading from those other drives again . So I’ve shut them down and Roon is loading up from R again.

Looks like I need to reinstall ROON, but I’ll wait for more advice.

Drive R continues to check out OK. It is a fairly new Constellation drive and I would think that if there was a cable connection problem, I would have trouble loading the library.

(Geoff Coupe) #7

OK, but while you’re waiting, do use Windows to check that drive (Properties/Tools/Error Check), and even though Windows will inevitably first pop up a window saying that you don’t need to scan this drive, go ahead and scan it anyway. Windows doesn’t always catch the problems until it’s told to do as you say…

(JOHN COULSON) #8

As reported before, no problems

I just did this as the backup (a different one this time) is being restored for the umpteenth time. We shall see what happens tomorrow after it has restored overnight.

Clicking on the rotating spinner central, up a bit, gives no response.

(Geoff Coupe) #9

That’s odd - it certainly should report why it’s spinning. We are talking about the same thing? - it’s the blue arc spinning in your first screenshot next to the Bookmark and Search icons - what you describe as the little wheel top right…

(Noris) #10

Hi @JOHN_COULSON,

To clarify, this is the activity spinner that we are describing in the thread:
image

Once you click on it, it should reveal a similar tab to this one outlining what is going on in the background:

I don’t believe that the free space on the drive is the issue here, it appears to be some sort of communication issue where the R drive is inaccessible by Roon.

You can try as a temporary test to see if the old notebook behaves the same as the Windows 10 install. You mentioned that this is a new drive, so I would be curious to know if it exhibits the same behavior on a different Core.

(JOHN COULSON) #11

Back at the PC again this morning. Yes all the backup installed BUT as soon as the re-launch button was pressed, Roon would not load Continual pressing of the icon eventually revealed it doing the same thing - ignoring R and loading from 2 other drives.

So, I’ll uninstall Roon and then reinstall it and go through the whole torturous process again.

LATER: Done. This time Roon went straight to drive R without me needing to point it there.


Hopefully all will be completed without error this time.
I’m suffering withdrawal symptoms - no ROON music for days now :frowning:

LATER AGAIN: The albums are loading much faster than previously. Albums are loading with all edited data so “uninstall” only partially did the job and there might be no need for any re-install of backups.

The other difference is that playing an album is now instant where previously it took seconds to gel. Hopefully the glitz has been nuked.

(JOHN COULSON) #12

FINALLY: All OK

Windows 10 has been rebooted a few times while performing other tasks and each time Roon has loaded with eveything intact.

My only conclusion is that the Roon program had become corrupted so “uninstalling” via Windows 10 (something obviously only partial and incomplete) then reinstalling fixed it.

I guess I might eventually grow to love Windows 10, but getting everything installed and running smoothly has been, and still is, a hassle. Getting there but …

1 Like
(Noris) #13

Hi @John_Coulson,

Thank you for the update here and glad to hear that uninstalling and re-installing has resolved the issue!

(system) closed #14

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.