MX Linux / Roon Bridge Installation error

Problem: Can’t install Roon Bridge inside Mx Linux. Can anyone help.

This is the error

Copying Files…Done
System has not been booted with systemd as init system (PID 1).
Can’t operate. Failed to connect to bus: Host is down

Installing /etc/systemd/system/roonbridge.service

Enabling service roonbridge…
Service Enabled

Starting service roonbridge…
System has not been booted with systemd as init system (PID 1). Can’t operate.
Failed to connect to bus: Host is down

The RoonBridge installer did not complete successfully.

Personally I use Ubuntu as it’s simple and pretty much every question or problem has an answer somewhere on the tinterwebs.

1 Like

Can’t use the Ubuntu Distro as I need the Debian Mx flavor for my needs. I use DAW software and MX is the cat’s meow when it comes to this. Most of the Ubuntu flavors like mint too have issues with drop outs when I use my Daw software. With MX its smooth sailing for the Daw. I did manage to get Virtual box working so I may try Mint inside of VB.

But your needs are to run Roon, seems strange to run an extremely locked down distro for music?

I fear you’ll be on a hiding to nothing trying to run Roon on that.

It’s quite a basic software package and picky how/where it runs.

I run roon on a core not this pc. I want to install Roon Bridge on this pc.

You can alleviate dropouts in your DAW by switching to the realtime kernel. You don’t really need any specific distribution for that


What do you think about my original question. Look at the first post.

It’s still the same package just a different mode. I’m afraid you’re fighting a losing battle, go with something known & proven.

Thanks for your input. I agree you can do it with other distros but I am looking for the answer to the first question. Again thanks but I want to solve my problem. I am finding more about this problem on other sites. If I find the answer i will post it for everyone in our community. I now have Oracle VM running on the MX PC and Linux Mint is running inside VM and I loaded RoonBridge successfully inside Mint. Always more than one way to skin a cat. Thanks again

Not going to happen, it’s a non standard distro so why should Roon support it?

Why are you running an app inside a VM on a host, you’re just creating problems for problems sake.

Thanks for the help.

Thanks for your thanks.

This topic led me to the idea. Found several users with VM needs and sucess.

Try instaling the bridge manually instead of using the installer

First of all Thanks for the info.
I was kicking that around too but after I read what Chris posted.
Looks like no hope for MX due to Systemd vs Sysinit
Virtualbox has hope but the core system/audio can’t see it yet?
but other VM containers may work out.

I have use the low latency kernels for my Daw too but Mx is my choice now. Mint debian also works with the Daw well but again not with Roon. Live and learn as the linux roadmap is huge.

You need to change the network type from NAT to bridge in order for it to be visible to the other devices on the network.
Or you could use my script to create a RoonOS based VM

It all depends on your Linux knowledge, and how many hours of futzing around you’re willing to spend on this. It looks like Roon Bridge is expecting Systemd, and so you’d need to replicate the steps the installer is doing with suitable modifications for Sysvinit. It also looks like you might need d-bus running. Installing a VM will be a much better documented process….

Good luck!

I have an instance of Dietpi running roonbridge inside Oracle Virtual Box.
Virtual Box is running inside MX linux OS on a PC.
The Roon Core now connects the audio devices connected to Dietpi instance.
Thanks to this community I solved my problem with another application.

VM works…dropping my FrankenDebian path. Chris sent me a link that killed that.
Dietpi works, Mint Failed.
Both VM instances let me install roonbridge but the core only displays dietpi in Setting/audio
not mint. Although both run roonbridge.

Thanks…yikes I got to try this too