My DACs show in the Audio section under preferences, but not in the audio zones (yesterday it worked)

Hey guys,

all of a sudden my Topping and iFi DACs connected to my Mac cannot be seen anymore in the audio sources: they show up in settings, they are enabled, but can’t be selected (see screenshots). I can use them in the Tidal app, though.

Tried turning them on and off, unplugging them, restarting everything, re-installing the roon app. Same on my iOS device.

Can anybody help? Cheers!

Add images

1 Like

I am having this exact same issue. The DAC connected to my macbook isn’t showing up in the zones, but I see it in the audio settings. My Sonos device also shows up in the zones like the screenshots above, but not my local DAC.

My setup:
ROCK running on a NUC with the 1.8b756 stable build
Macbook running the same 1.8b756 stable build
Auralic Vega DAC over USB

Tried quitting and reopening Roon, tried turning the DAC off and on. No luck.

2 Likes

Same for me. I have my PS Audio Sprout connected to my Windows 10 PC while my Roon core is running on a NUC - all connected via ethernet. Upon booting up my PC and starting Roon - I can see my Sprout in the audio section of settings and it is enabled. It just isn’t showing up in the zone list. I have to stop and then start the core and then it works. This is new from 1.7 to 1.8.

1 Like

There is a ticket open for this. @moderators please add this to the thread

Found a solution that worked for me.

I stopped and restarted the Roon core on my NAS, restarted the NAS and the DACs were magically there again!

there you have it

@moderators

That’s not a solution - no one should be required to restart the core to fix that bug. Moreover, such a workaround only lasts a few hours. The ticket is already open and we hope for an update very soon.

1 Like

So is there an official thread about this issue somewhere? If so, can someone link me?

I have to restart the core multiple times per day…

Hi @Marco_Patruno

We released a change here that should help:

Please let us know if things are working for you on the latest version!

1 Like

It’s going well but now the core takes a few secs to load on the iOS app and sometimes it says it can’t find it and if I want to select a different one