My iTunes library has disappeared from Roon

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue

I have an iMac and a Nucleus and I have most of my music (39K tracks) in iTunes from my Mac.

Since the last iMac software update my iTune tracks have vanished from Roon.

I’ve tried to re-add the iTunes files to Roon but I kept getting “Invalid path” notification. I have followed the launching iTunes library numerous times but I still get the some invalid notification. I my frustration I have deleted all the folders that were in the Roon storage settings.

My question is how do I get Roon to acknowledge my iTunes and other music folders on my Mac.

Your help will be appreciated,

Hello @Neil_Perryman,

Try adding your Music folder to the “Shared Folders” list in System Preferences and then adding smb://your-ip-address/Music in Roon. If this works, you are likely hitting this broken “feature” in macOS 10.15 Catalina:

To resolve this issue, try the following steps:

A. Open Finder.
B. In the menu bar, click “Go” > “Go to Folder”.
C. In the folder prompt type /usr/sbin/ and then click “Go”.
D. Locate the “smbd” file in the folder.
E. Open System Preferences > Security and Privacy > Privacy > Full Disk Access
D. Drag the “smbd” file from finder to the System Preferences list for apps given Full Disk Access
E. Restart your Mac.
D. Once your Mac has rebooted, attempt to add the directories via SMB again.


1 Like

Hi John, I’m still not able to access the folders, I’ve spoken to Apple Help and they share screened with me for about an hour to try to rectify the problem. We followed your step instructions but we had problems at step D. I’ve included some screen shots to help explain the situation.

This shot shows no folders available.
This shot shows where my music folders is on my Mac
This shot shows my iTunes music library with 39000+ tracks.

This shot shows my Roon library details, notice only 16000+ tracks (all of those are Tidal tracks).
Prior to this problem my Roon library had over 54000 tracks.

This shot shows “” for my Nucleus and connect action. I don’t know my Nucleus password.

This shot shows the apparent connection process, it has been apparently connecting for about
2hours so far. The blue line indicator is moving.
Any more help will be appreciated.
Best, Neil.

Hi @Neil_Perryman,

Thanks for sharing those screenshots. It looks like you’re trying to add a Mac share to the Nucleus, and you would need to use this guide to do so, the network share wouldn’t automatically populate in the “Choose Music Storage Folder” tab.

I suspect that something might have changed here leading your Nucleus being unable to access the Mac music directly and it should show an error on the Roon Settings -> Storage page indicating what storage location is currently inaccessible.

The music wouldn’t be located on your Nucleus, but on your iMac, so getting the share up and running again would be the best way to troubleshoot this behavior.

For future reference, if you wish to connect to the Nucleus Data location via SMB, you would use Connect as: Guest or use registered user and put guest as both the name and password.

You won’t however need to do this to add the iMac again, just letting you know in case you do need to access the data drive in the future.

Hi Noris, Thanks for the help. I’ve followed the the steps you suggested and when I get to the “Choose Music Storage Folder” there is nothing to choose, see screen shot.

I keep going around in circles following the steps but I always end up a blank
“Choose Music Storage Folder”.
I’ve followed “this guide” you suggested but still not working.
Best, Neil.

Hi Again Noris, I can’t work out if it is an Apple problem or a Roon problem or both but right now my frustration is building as
Roon is now just an extension of Tidal as I’m unable to access my much larger music library which is on my Mac.
What would happen if I was given a new Roon software A/C,
would this get things working again.
I don’t know how much more time I have to dedicate to get things operational again, as I said frustrated.
Best, Neil.

HI @Neil_Perryman,

You wouldn’t see anything there if your Nucleus does not have internal storage. You need to click on the “Add Network Share” button and type in your MacOS shared folder credentials. Please refer to the previous guide I mentioned on how to do this:

Hi Noris, I’ve followed the steps again but still no success,

This is screen shot of my “shared folder” page.
This a screen shot after I’ve pasted the address and tried to add. More suggestions please.
Best, Neil.

Hi @Neil_Perryman,

Thanks for the screenshot. It looks like you’re missing some information from the “Add Network Share” window -

  1. You’ll want to specify the folder instead of just the smb location, Network Share Location should read: smb:// You can also try smb://IMAC-2.local/Music as the network share location.

  2. There’s no password/username login that I’m seeing on your Add Network Share tab. You should try using Neil Perryman as the user and put in your Mac login password under the Password field.

Hi Noris,
I just tried those options, here are the screen shots.

Now what?

Hi @Neil_Perryman,

I was looking over your previous threads and it appears you’ve raised this issue a few times, see:


In the second thread you seem to be using smb://IMAC-2.local/neilperryman/Music as the watched storage location and you mentioned this worked in the past. Does that by any chance work?

It seems like your network might have trouble resolving an address from just a hostname, I would also try rebooting the Nucleus and you networking gear as well.

A post was split to a new topic: My iTunes library just disappeared from Roon

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.