My Local PC Is Missing from Audio Settings

Roon Core Machine

Small Green Computer SonicTransporter Ver. 2.8 ST9, Intel i9, 8GB RAM
Roon Version 1.8 (Build 846)

Networking Gear & Setup Details

Hardwired Ethernet

Connected Audio Devices

Dell XPS PC with 16GB of RAM
ROON Version 1.8 (Build 831)
Connected on same home network

Number of Tracks in Library

Description of Issue

When launching ROON, to play music on my PC, I noticed that “This PC” was missing as if Roon doesn’t detect it. As you can see from the screenshot, all other Roon Ready devices are detected on the network but not the local PC which has ROON installed.

I am unable to set anything up to play the files as Roon doesn’t see that it exists. There was an update this morning for all Roon devices.

Did this cause the problem?

I’ve tried uninstalling ROON from my PC but didn’t check off the 2nd box which asked me if I wanted to delete my library. Since ROON Core is on my SGC SonicTransporter with my files sitting on a NAS, I wasn’t sure checking this off would delete those files.

Regardless, the uninstall/reinstall did not work. ROON refuses to detect this PC.

I installed ROON on a Dell laptop that has never had ROON installed. The installation went quick and immediately was recognized. I was playing music from my library in minutes.

So, my question now is, how do I get a fresh installation of ROON on this PC without affecting my ROON Core and files on my NAS?

Should I be clearing some hidden files on my PC for a fresh install?

Need some help please.


Did a full uninstall of ROON on my WIN10 PC. Shut down the Roon CORE and library files at the NAS before doing so.

Did fresh re-install of ROON, fired up the Roon CORE, and library files and ROON does NOT see my PC. I am using an Audioengine D1 DAC with desktop speakers for this listening station.

I’ve never had an issue with ROON detecting this PC. I have no idea why this is happening.

Looking for help please.

It may be that the Firewall exception rules for Roon have gone awry and need to be corrected. You can test this by temporarily turning off the Firewall on your PC and seeing whether the Audio devices then appear.

It’s probably the setting for the RAATserver that needs attention. See here for more information:

If you’re not sure how to proceed, come back here and we’ll try and help further.

Fantastic, Geoff!

That is exactly what the problem is. Once I turned off Windows Defender Firewall, everything in Roon looked correct.

I then edited the “Private Network” settings in the Firewall to make sure that Roon.exe and Raatserver.exe were both enabled.

All working perfectly now!!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.