My Nucleus+ core is intermittently dropping connection

Nucleus + OS 1.0 (Build 254)
Roon Server Version 2 (Build 1182).
QNAP TVS+h1688x to store music.
Roon Remotes: Mac Studio M1 Processor 32GB RAM, iPhone 14 Pro Max and iPad Pro.

Networking Gear & Setup Details

Everything is connected with ethernet and several switches.

Connected Audio Devices

BlueSound Node.
Control 4 to distribute Roon all over the house.

Number of Tracks in Library

About 300,000 tracks so a large library.

Description of Issue

I’m having a real issue with my Nucleus+ Core losing connection with my network.

When the Core does down, none can access. Occasionally I’m unable use my Mac browser to access the Nucleus+ so I’ve lost connection completely. This happening intermittently every day and multiple times a day.

I was wondering if I should reinstall my Nucleus+ software but I get a warning that doing so will be destructive. I am also unable to get a current backup. Probably due to the intermittent drops.

Thanks for your help! Bill H

That doesn’t sound right - reinstalling the Roon OS will not destroy your settings or database. See the article on the Web Administration interface.

I was referring to the Nucleus+ firmware. It says right before you reinstall it may be dostructive.

Can you post a screenshot of your Nucleus Plus’ web administration page? I am wondering if your RoonOS database drive may be full with such a large library.

Here you go…Thanks.

That’s interesting. Your Nucleus Plus has been operating for almost 5 hours but the Roon server application seems to have rebooted in that timeframe and has been running less than 90 minutes. Your database storage looks fine.

Have you restarted your Nucleus Plus manually in the past 90 minutes?

Sorry. I’m not sure I addressed your question. No. I have not restarted my Nucleus+ since this morning.

I’ve been restarting it regularly. Sometimes the only way to get it to show up on the network.

If you think it will help, I can restart now, wait a few, and send another screenshot.

When you are restarting it, are you selecting the “Restart Server Software” Restart button, or rebooting the Nucleus Plus entirely?

Mostly been restarting the nucleus itself. Did the restart from the web interface twice.

I am tagging @support, the Roon staff may want to review your logs when they contact you.

1 Like

Hi @William_Howard,

A couple of observations from looking at diagnostics. I am seeing connection failures in the logging that indicate connection issues in general and this lines up with what you’re seeing. One of the failures is connecting to Cloudfare DNS (

Some ideas.

  1. Do try reinstalling from your Nucleus WebUI. It doesn’t affect databases. There is a chance something could go wrong but I don’t see the situation being any worse than it already is.

  2. Try changing your DNS to Google instead. and

  3. Can you please explain your modem and router setup (make/model for both)?


1 Like

Thanks. I’m not familiar with changing the dns. is that the Gateway and DNS server boxes at the bottom of the web interface? Sorry.

Typically you can change these in your router also. I did that due to DNS problems with my ISP, and it solved every connection issue in my home immediately.

1 Like

Hi @William_Howard,

These would be changes to your router. We might be able to get you a guide or general sense of direction in doing so if you provide us with your modem and router make/model.


1 Like

I have a standard Spectrum modem. Picture attached. I have an Apple router. Picture also attached.

Hi @William_Howard,

Can you please supply the make/model of the Spectrum modem? I’m thinking this is a modem/router combo and if that’s the case, there might be multiple subnets in use and two devices doing routing. A likely cause of your issues if this is the case.


1 Like

@Wes, the modem appears to be a Hitron EN2251 DOCSIS 3.1 modem with a 2-port eMTA for SIP voice services. I am not sure if the eMTA would interfere with data routing and act in some way as a gateway/router. There is no WiFi on the EN2251 from what I can see in the specifications.

Given the age of the Apple router, that may be a factor here also.

1 Like

I didn’t have any issues with Roon until the 2.0 update came out. I reinstalled the nucleus operating software and restarted Roon server. It worked for several hours. Then when I tried to force a backup it locked up again. I believe it has something to do with the backup. Would that make sense?

Hi @William_Howard,

It may very well have something to do with it. Let’s try this then. Please ensure you get a new backup and when done, try things out testing everything thoroughly before attempting to reimport a potential would-be problem. Please let me know how it goes. If this indeed proves a database issue is at play we have few options but we’ll try everything we can.

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database