My Nucleus+ suddenly doesn't see my external SSD storage drive

Roon Core Machine

Roon Nucleus Plus. Ser # 94C591A018C5. There is a 4TB WD Elements external SSD drive connected for my library storage.

Networking Gear & Setup Details

Netgear Orbi Mesh Router

Connected Audio Devices

Connected via network cable (cat5) to MSB Select DAC. I am also connected via WIFI to a Naim Unity Atom, a Chromecast device, and to an Oppo UDP205.

Number of Tracks in Library

I think this may be the problem. I didn’t know how many tracks I had until this issue happened and I checked and found that I had 205,000 tracks. I deleted one of my file folders that contained mp3 files and have now reduced it to 86,878 tracks that are CD quality or better. However the Nucleus still will access the drive or see it.

Description of Issue

The Nucleus doesn’t see my SSD drive. I can’t access any of my ripped CD’s or any of my high resolution downloads. It is also not scanning the drive to look for new content.

It also doen’t see any folders when I try to edit the folder

1 Like

What’s the disk format of the disk, Windows’s NTFS?

Did you have it attached to the Windows machine and maybe unplugged it without doing a proper “remove safely”? Did you recently install the RoonOS update for the Nucleus?

If yes:

And welcome to the forum :slight_smile:


Hi @Bill_Robertson,

Please see the post from @Suedkiez (thank you!) and let us know how things are going.


1 Like

Thank you, gentlemen. The problem seems to be solved. I put the SSD drive back in the Windows machine and ran chkdsk. I ran check and repair errors. It took a couple of hours to run, and reported “no errors found”, but then I put it back into the Nucleus and it recognized it and ran perfectly. Before disconnecting it from the Windows machine, I shut it down comepletely. Probably overkill, but better safe than sorry. Thank You!


Hi @Bill_Robertson,

I am glad to hear you’re back to enjoying the music. Happy holidays to you.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.