Mytek is enable but deteced as no audio device..?

Mytek is enable and connected to Nucleus+ via USB cable.
But no audio devices found. I can’t see ’ Select Audio Zone.

I can see 'Select Audio Zone ’ only when I reboot the Nucleus+.

Why is it like that ?

Can you post some more screenshots? What happens when you try to play music? I would expect you would only see ‘Select Audio Zone’ if there was more than one. If there is only one audio device, then surely that would be the default device?

Only when I reboot the Nucleus+, I see Nucleus+ and Mytek Brooklyn Dac+ work fine.

If I just turned the Mytek Brooklyn Dac+ off and on again, Nucleus+ and Mytek Brooklyn Dac+ are disconnected though both are shown enalbe from the fomer attached screen shots.

This phenomenon seems to pop up after 1.8 update.

Are Nucleus+ and Mytek Brooklyn Dac+ compatible only when they are power on /off together ?

After both devices are powered off and on together, then it works properly as per the screen shot below.

There is a long running support thread on this behaviour. Lots of us it’s happening to with DACs attached via USB to core and other computers that are zones, they drop off and dont appear as a zone anymore even though they are active in audio settings and can be seen by Roon.

Hi, lots of people with the same issue
See this post:

@moderators someone please sticky this for everyone… @support