NAD M33 not playing sampling rates 88kHz and 192kHz

Core Machine (Operating system/System info/Roon build number)

Win10 on a NUC i5, Roon Server 1.8 build 783

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet cabled with Broadband Internet, Ubiquity USG and Switches

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAD M33 wired, Blusound Node wired, Pulse wireless

Description Of Issue

My M33 not playing the sampling rates 88 and 192kHz through Roon. I plays all other rates like 44, 48, and 96kHz. With the two rates it tells about Audio Data is loading slowly. It does not matter if its from NAS content or Qobuz. I have checked with other Server machine without success. The M33 is playing this rates through BluOS without problems. All other players on the same network are playing all files and rates without problems through Roon. It seems to be a specific problem with M33.

Just as a workaround I have testet it with sampling rate conversion from roon an it works fine.
So if I covert from 88 to 96kHz and 192 to 96kHz the Music is playing correctly.
Based on these tests I think its impossible to have a performance problem of the server or the network.

Any suggestions?

Well I wish I had some advice, I am not that savvy !. Mine is playing everything I have including 176, which you did not mention. Do you have the latest updates from 4/8 and 4/13 ? You might have to do a reset of the M33 or maybe you accidentally did something in ROON. I would hope ROON has a suggestion for you or somebody smarter than me. Good Luck. Let us know the fix.

Hey @flan,

I am so sorry it took us this long to reply - please, accept my sincere apology :pleading_face:

I’m very sorry to hear about the trouble playing 88 and 192kHz through Roon…is this still happening? Is Roon updated to the latest build?

If you navigate to Settings → Audio and click on the gear icon :gear: next to your M33 and select Device Setup, is there a limit for the device? (You might need to click on Show Advanced on the pop-up window).

Can’t wait to hear back from you :nerd_face:

Hi @beka

See my Post on the NAD M33 Forum about further investigations…

The main problem still is the Bug not playing 88kHz sampling rate with enabled Dirac. Seems to be a gneral bug because other members repartet it too! John from Support has noted that, we hope he has made some progress about it.

Thanks for your ongoing support.
André

Hey @flan,

Thanks for keeping in touch and keeping me updated. I appreciate it!

John is actually our expert, when it comes to devices, their capabilities and certifications. Watching for his updates would be the best way forward.

Thanks for being so understanding :relieved: