NAD M33 settings

Roon Core Machine

The core is Intel NUC 7i7BNH based Rock and library is on a Seagate 6TB HDD connected to it via USB there are nearly 4TB of FLAC files on this.

Networking Gear & Setup Details

My network set up is based on a TPlink mesh system utilising 3 x Deco P9 units throughout the home and the NUC is connected via ethernet and a 6 port switch to one of these units. I have roon remote on my android smartphone and 3 laptops: 2 W10, 1 W11. I use Nord VPN on all 3 laptops but not my phone. Hi-fi system is based around a NAD M33 and also a second system using a NAD M10.

Connected Audio Devices

M33 and M10 are connected to network by ethernet.

Number of Tracks in Library

94242 tracks on HDD
also use Tidal

Description of Issue

Hi I just got a new NAD M33 and noticed in the roon set up that the while my NAD M10 is listed with just its IP address, the M33 is listed with Airplay / IP address. The M10 is also listed separately with Airplay/IP address but this is not enabled. What is the reason for this? Is there a difference in sound quality over Airplay?

Currently latest BluOS firmware has broken Roon across the NAD and BluOS range. Roon are working with them to fix it as it should show as Roon Ready allowing the best quality and highest rates of supports. If you check out the support thread you will see.

Well, that can’t be a universal statement: My NAD M17 is working fine as a Roon-Ready device with BluOS 3.20.45. Though I had to install/upgrade it twice to get it to properly recognize the HDMI ARC port. (Which has nothing to do with Roon, just with my TV not being properly integrated.)

It may not affect every device model and IIRC there may have been some prerequisites in how/when the firmware update was performed, but it very much looks like the M33 is affected based on existing reports, and Bluesound have acknowledged the firmware problem. From the link that @ged_hickman1 posted, a few posts up from there:

If you did a factory reset or power cycled it affects the device. If you didn’t then it doesn’t seem to until you do.

1 Like

A power cycle is part of the BluOS upgrade; no need to do that again. A factory reset should not be necessary for that upgrade, that is total overkill.

What ever it seems to be prolific and only since their last firmware update.

1 Like

Oh well that’s £4.5k down the pan. Just shocking.

They will fix it with the next firmware update. Relax

1 Like

I had a similar issue to you and wanted to share how I solved it.

I own a NAD M10 V2 all-in-one streaming amplifier, which was always Roon-ready and I always upgraded to the latest firmware online. The latest upgrade version is BLUEOS 3.20.45.
In the latest version, roon-ready is also used normally

A few days ago, I accidentally restored the machine to factory settings, and after rebooting, I encountered the same issue as you: the device only appeared in “other network devices” in AirPlay mode, and disappeared in Roon-ready mode. I contacted technical support from our country’s distributor, but the methods they suggested couldn’t solve the problem.

Finally, I found BLUEOS v.3.20.25 from last year’s web-ftp directory list on NAD’s official website, which is applicable to M10V2. I downloaded and extracted the .img file to a fat32 USB drive and inserted it into the machine to revert to version 3.20.25. After that, the problem was solved, and Roon-ready came back. I then upgraded to the latest version 3.20.45 online, and Roon-ready did not disappear.

It is recommended to download the v30.20.25 version from this website and restore to the old version to try:

After the download is complete, extracted the .img file to a fat32 USB stick and inserted it into the machine .According to the manual, press and hold the standby button and then plug in the power supply, then release the standby button,and then wait for the downgrade to the old version.Then roon-ready may return to work. Afterwards, upgrading to the latest version online should not affect the work of roon-ready.

As mentioned above, I was successful in the experiment on M10v2, I think the same may be true for M33

hope this can help you.

1 Like

Thanks for this solution , it works for me !! ( M33 )

Thank you very much for this suggested fix. I have downloaded the zip file as recommended but I can’t find any instructions in the manual for installation of the OS via a USB stick. Perhaps you could point me in the right direction please.
Am I correct in thinking that I have to switch off the power to the M33, insert the USB stick, and then power on whilst holding the standby button. Then I release the standby button to initiate the downgrade.
Is it necessary to unplug ethernet and switch off wi-fi during this process?
Many thanks

I unplugged the network cable and then refreshed the firmware, I suggest you do the same. But the NAD device cannot turn off the wifi alone, and the wifi settings should be gone after restoring the factory settings, so I think the wifi will not work when the firmware is refreshed.

On my M33 running the latest Bluos version, M33 via Airplay is also not shown as enabled, but I am able to enable it as a separate device if I wish. Is the original poster not able to do this? I have left mine disabled since airplaying from Roon to the NAD via airplay definitely sounds inferior to the ‘full fat’ native route.

Sorry for not understanding what you mean, this thread is only discussing the problem of NAD and BLUEOS device’s roon-ready disappearing.
In fact, roon ready is bitperfect, and airplay is lossy sound quality

Hi Ben,
I have airplay mode, it is the roon ready “full fat” that has gone. This is what we are trying to fix.

Hi Robert,
This doesn’t seem to work for me with the M33. Can I ask a few questions?
Do you just extract the download to a formatted USB (I use 7zip)?
After inserting the USB stick do you turn on the M33 using the rear power switch?
Is this done while holding down the top front standby button?

All I get is a message on the touchscreen saying USB connected and an OK button. I touch this and nothing happens.
Any help would be appreciated.

Hi , as far as I know I extracted the file and put it on my USB.

  1. M33 power on ( simply on the remote)
  2. Put USB in.
  3. Go on display to “other” / Bluos upgrade / yes

Afterwards you can download the latest version of Bluos.( remove usb ) The M33 will stay vissible as Roon ready.

Succes !

Perfect. So easy when you know how. Thank you so much.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.