Need help with setup to run ROON headless on QNAP 471 with TOTALDAC server as endpoint [SOLVED]

Hi All,
First-timer here.
I found Roon super easy to set up on my macbook running directly to my DAC via USB.
Now I would like to run Roon headless on a QNAP 471 NAS and use my TotalDAC server as the endpoint and connection to my TotalDAC DAC. I can’t figure it out.
I really need straight forward step by step instructions through the process. (An explanation of what accomplishing each step should look like would also be helpful.) So far, I have followed a bunch of disparate instructions from around the Roon databases and they haven’t added up.
Some straight forward linear directions would be very much appreciated. I am happy to uninstall Roon and start again, or migrate, whatever is easier.
(I’m not completely technologically disinclined, however NAS drives, Roon and the TotalDAC server are all new to me.)
Thanks for your help with this.

Have you read this:

I followed this to install Roon on a QNAP TVS-471. It was easy to do. Is that DAC Roon Ready?

Thanks for reply John.
I have read that and followed the instructions to the letter.
However, after managing to install the package on my NAS, Roon did not see it.
Can you help here?
Once you install Chris’ Roon package via app manager on NAS, what exactly do you do next? Also, where is it located? How do I even point something to look for it?
Your help would be much appreciated.

If you did it correctly when you go into the App Center in the QNAP you should see Roon Server. If it’s running it should have a small banner underneath that says Open. Let’s start there.

I do see Roon Server in App Center and it says “ON” with green tab. I assume that is what you mean.
Continued thanks for your attention on this.

Okay so I am assuming that you moved your core over to the QNAP as per the instructions? What happens when you try and access Roon from your computer? The Computer should now be acting as a remote device.

Hi John,
After installing package and seeing it “ON”…
I then turned it off, then migrated my Roon database to a folder called RoonServer on the SSD drive in one bay of my NAS (as per recommendation), then turned app back “ON”.
I then fired up Roon remote on iOS (and tried on macbook as well) and got “Choose your Core” page. It then went into a loop of “Looking for remote libraries…”. If you click on help message it takes you to a page that has a box to insert an IP Address or host name… I typed in the IP address of the NAS, but it gave me an error message INVALID.
That is where I am now stuck.

I would start by checking the firewalls on the Mac. Turn it off and then see if you can then see the new RoonServer.

You might want to check that the wifi and LAN based address ranges are in the same network range…if your wifi is on a different subnet and your laptop and tablet are not on the same LAN segment then you need to address that.

Thanks for jumping in Daniel.
I turned off firewalls and restarted room and still not finding any remote libraries. Now it is even letting me scan the IP address of the NAS without an error message and still nothing.

Not sure how to check that. Please elaborate. FYI, if its relevant: right now the NAS is plugged into the wifi router directly.

Can I ask what room remote is looking for? Is it trying to find the app on the qnap, or the roonserver database in the roonserver folder?

Im assuming you installed the roon server to its own volume on the QNAP as if not then I am not sure it will work.

for finding the IP address of you devices you should be able to use FING app on the iOS/android devices. on a mac or windows it should be shown in the wifi properties under advanced for mac (i don’t have any windows wifi setups)

if one says like 192.168.1.x and the server is on 192.168.0.y then its not going to work…the first 3 numbers need to be identical

add’l Note:
For the sake of trouble shooting, let me mention a few minor concerns I have re: my installation:

  1. I created a folder on the same SSD drive in the qnap called “Roon” before I realized I needed to call it RoonServer. I then created the RoonServer folder. I did not erase the Roon folder. Not sure if this matters.
  2. When I migrated my database, I simply copied all the contents of the Roon folder in my Library to the RoonServer folder on the QNAP. I did not copy the Roon folder itself, just the contents. Not sure if this matters.

I checked the IP addresses and they all have the same first 3 numbers separated by “.”. So that should not be an issue.

To be clear, I do not know where the Roon Server App (Chris’ package) installed itself. I certainly created a share folder called RoonServer that sits on its own in the SSD volume. (I have 3 drives, 1 SSD and 2 regular).


In that RoonServer folder I copied the contents of the Library/Roon folder from my macbook (which I then changed the name of on the macbook)

You need to install the server to a different VOLUME on the QNAP, which ideally should be a new SSD either internally mounted or on USB3 port

That appears to be where your install went off the rails.

When you say “install the server” what part of the process are you talking about? I manually installed an App called Roon Server and was given no choice as to its destination. I then migrated my database.

Which process do I need to redo, and how would I do it differently.

Please give me clear (layman’s) steps.

Many thanks,

In the instructions to move the db Roon say the following

2. Copy Your Roon Database
Copy your Roon folder to the appropriate database location on your new operating system using an external hard drive or network transfer.

Note that if you are migrating from Roon to Roon Server, you will need to rename your Roon folder

From my understanding you only copied the contents?


@crieke I think the master of the package maybe best to get in on this…