Network Error: Please check you internet connection

Roon Core Machine

Windows 10
Intel(R) Core™ i5-6600K CPU @ 3.50GHz 3.50 GHz
16.0 GB (15.9 GB usable)

Networking Gear & Setup Details

Edge Router (ubiquity)
1000gb internet connection
Server plugged by cat 6 to router

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Network Error: Please check your internet connection
Same error on Android, win 11 machine and on the local server above
All other internet services is fully working


Multiple reboot - same result
Disabled VPN start at boot (NordVPN) - same result
Uninstalled all roon apps and reinstalled - same result
Cleared cashe in roon server folder and roon client folder + ipconfig/flushdns - same result

Checked win firewall and ticked off all access to roon & roon server - same result

Any suggestions how to solve this?

Turn off your VPN completely? See also:

Not running VPN, as you can see above. The VPN software isn’t started. And no data goes through any VPN connection.

I found a VPN service still running, shut it down, still same result.

The only thing I can think of is to try disabling IPv6, as this has been known to cause problems with Roon.

Hmmm I got this for a while yesterday afternoon with Qobuz content. Network and internet where perfectly fine. Roon was ridiculously slow at loading anything from Qobuz. No issues at all with music playback infact it was streaming fine from Qobuz just took an age for it to load any metadata. I think their metadata servers are having issues again.

Disabled IPV6 - still same issue


How is Roon installed on the Core? Using the all-in-one or using separate Server and Remote installation?


Note: is the local loop-back interface - impossible to reach the internet over that address, but may (or not, can’t test this) be shown on a Remote when connecting to Server running on the same machine. At lest a Remote on another device like your Windows 11 machine should show a different IP-Address.

First I installed the separate server (RoonServerInstaller64) on the Core machine, then installed RoonInstaller64 on a different machine. Got the error message.
Tried then to also install RoonInstaller64 on the core, same error. Then installed android version on my phone. Same error.

(from remote machine)
Can connect to the Core, but not able to log in afterwards.

Are there all the exceptions being made in the firewall? Do you use other Antivirus/Firewall software too?
Does connecting work if you temporarily disable all the above as a test.

Note: On the core you need exceptions for RAATServer.exe, Roon.exe and RoonServer.exe.

Same error if I turn of local Microsoft Defender (firewall) on core machine.
I cant see that there should be any issues with firewall in Edge router, but that’s probably the only thing left where it can be. Will play around with it. I know it drops invalid stat, but allow all established connections.

Had exceptions for all files, RAATServer.exe, Roon.exe and RoonServer.exe.

Please provide the output of route print

As there also is an firewall in my edge router, is there any specific port that need to be opened there as well, that’s now blocking the login. I do not have any other issues with any other software.

Added rules to the edge router firewall to allow all traffic. same response

Anyone able to help?
Not to nag, but getting frustrated here…

I had a similar issues about a year ago. I had tried everything except replacing my LAN cable. Turns out that was the issue. New LAN cable and everything worked again. And no, this isn’t a joke - Roon seems to be far more sensitive to degraded cables than anything else on the network.

At this point I’d take a packet capture to figure out what the network response is. That is probably beyond the level of troubleshooting most people want to do. Also I’m a network engineering (network whisperer) so that’s my language.

You can also look through the Roon logs and try to identify if anything shows up there related to issue:

Anyone able help me interpret this?

12/03 11:35:21 Info: [brokerserver] Client connected:
12/03 11:35:21 Trace: [SOOD] Adding User IP
12/03 11:35:21 Trace: SENT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=8068df27-fd97-4c1d-8275-2d2e390a5324 BrokerName=’********’ }
12/03 11:35:21 Trace: SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status=‘Error’ HasChangeLog=False CurrentVersion={ MachineValue=100800831 DisplayValue=‘1.8 (build 831) stable’ Branch=‘stable’ } }
12/03 11:35:21 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
12/03 11:35:21 Trace: [push] retrying connection in 47493ms
12/03 11:35:22 Info: [stats] 4848mb Virtual, 62mb Physical, 13mb Managed, 1028 Handles, 38 Threads
12/03 11:35:23 Trace: [broker/accounts] doing auth refresh in EnsureAuthReady, next=12/03/21 11:35:22
12/03 11:35:23 Warn: [auth] EnsureAuthReady failed: Result[Status=NotLoggedIn]
12/03 11:35:23 Debug: [easyhttp] [46] GET to returned after 484 ms, status code: 401
12/03 11:35:31 Trace: [broker/accounts] [heartbeat] now=12/03/21 10:35:30 nextauthrefresh=12/03/21 11:35:22 nextmachineallocate=12/03/21 12:55:30
12/03 11:35:31 Trace: Successful POST response from
12/03 11:35:31 Trace: [push] connecting to
12/03 11:35:31 Trace: [push] connected
12/03 11:35:37 Info: [stats] 4864mb Virtual, 62mb Physical, 14mb Managed, 1069 Handles, 42 Threads
12/03 11:35:43 Trace: [fiveaccountserver] POST
12/03 11:35:43 Trace: [fiveaccountserver] BODY email=**********&password=<<>>
12/03 11:35:43 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
12/03 11:35:43 Trace: [push] retrying connection in 15121ms
12/03 11:35:43 Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=
12/03 11:35:45 Warn: Error in web request NetworkError (Unable to connect to the remote server)
12/03 11:35:52 Info: [stats] 4856mb Virtual, 63mb Physical, 14mb Managed, 1069 Handles, 40 Threads
12/03 11:35:53 Trace: Successful POST response from
12/03 11:35:53 Trace: [push] connecting to
12/03 11:35:54 Trace: [push] connected