Network Sharing in Windows 10

Roon Core Machine

NUC Rock Core
Lenovo ThinkPad Remote

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I really want to love Roon…I have had a number of issues getting it operating.
I have installed a new Roon Rock server and I am having difficulty having Roon find my music folder on my laptop and begin to sync with Rock. It doesn’t find it automatically and it doesn’t like any of the paths that I enter which I have cut and pasted from the directory path line. The instructions in the Help area of network sharing seem to refer to an earlier version of Windows or something because they don’t work with Windows 10.

I have posted here before and have not been able to fix the issue. I have not received a response from Roon Support (I guess that is who I contacted. I wrote to the generic Contact Us area where the drop down was very generic and non-technical.) Is there a real Roon Support contact area? For a subscription service one would think you could get ahold of a person to help you. Very frustrating and unacceptable.

Can anyone help me? I am about ready to ditch Roon, despite loving the features.

Do you have SMB1 sharing enabled on your win10 laptop

I do. But I get this error:

I don’t see a password - you should have one and use it?

These might be helpful:

I did not in that example but I did use a usermame and password and got the same error

Then the next questions are:

  • do you have SMB1 sharing enabled, as TheHammer suggested?
  • did you follow the steps to share your Music folder on your laptop in the Help article suggested by bearFNF? The steps are valid for Windows 10 systems.

Yes and yes. Firewall issue perhaps?

Just type WORKGROUP in the box, it took that for me even though workgroup no longer exists ?

On thinking about it may be a bug.

I set up my backup location using this

What box are you referring to?

“Unauthorized” usually means that the network share location is correct but the server denies access to the share because the user (username/password) is incorrect or doesn’t have the right to access the share. You should check the corresponding settings on your Windows laptop.


It all works on windows 10 and has for years so it’s a setting that needs tweaking.

Thanks, Blackjack. I allowed exceptions to the firewall for Roon and RAAT and tried again, but no success.

It was working on my old Win 10 laptop, so I know it works…Just trying to find that stupid setting that is preventing it.

What @BlackJack said, it’s a permissions setting on your Music folder; nothing to do with the firewall settings for Roon and RAAT…

You’ve now said “…working on my old Win 10 laptop”. So is this a different Win 10 device that you are now trying to set up? Does it have the same username and password as the old one?

The one at the Bottom labelled Workgroup. I just entered WORKGROUP in caps in that box nd it connected . I went around in circles until I tried that. All Google instructions failed !!

I had no user names or password set

This was on Windows 10 , most recent updates

As Geoff says, you need to go into the actual properties of the Music Folder you want to share and enable the permissions on that actual folder.

I had to do it on both my win10 machines to get a network share to work.

Not at home so cant post a screenshot of actual changes I made i am afraid

You need to set the permissions as well . Sorry to Conffuse

This is my Backup Folder on an Internal HDD of my main Computer , the core is now on a NUC

So, for me I don’t need to enter any user name or password, just the path works. I usually share by doing this (adding “everyone” and changing hte permission level to Read/Write):

Of course I live in the sticks and no one else has access to my network…so YMMV.

I believe that is exactly what I had to do for my pair of win10 machines.