Network stability after a few hours of Roon [Solved]

My first post, so apologies if I don’t provide the correct sort of information.

I just built a new Roon server (i5 NUC) yesterday, and began my long awaited Roon experience (2500 albums). Unfortunately, after a few hours the switch the server and NAS are plugged into became saturated and everything unreachable (no ICMP, no SSH). Some specifics:

Roon Server: i5 Intel NUC running Ubuntu 16.04 LTS fully patched
NAS: Synology 415 running latest OS
Both wired into an old gig Cisco unmanaged 8-port switch

Wireless router: Apple Time Capsule I believe

25-30 total nodes on the LAN, with no prior networking issues that I am aware of. Wired ping intervals usually under 1ms, wireless varies in the single digits, typically.

Endpoints: Pi w/ HiFiBerry, one wired through another identical switch, and one wifi, also 7 node Sonos deployment


I had originally set the audio analysis to “fast” (2 core), and then this morning after re-booting everything changed to “throttle” in case that was the issue. Things died by noon anyway.

My questions for @support:

  1. Can you point me to what in the logs I should look for to determine what the errors might be on the Roon Server?
  2. Is there a list of switches that are recommended? Or known not to work?
  3. My Sonos network is not using my wireless network directly but obviously connected through a Boost. Are there any known incompatibilities with Sonos devices? I have 3 Connect, 1 Boost, Play 3, Play 5, and 2 Play 1, and a Playbar.


Thank you for any pointers or guidance. I’ll have some questions later about metadata and best practices (2/3 classical collection, from 10th C to 21st C).

Power cycle your switch without rebooting anything else. If that makes the network operational again, your switch needs to be replaced.

People here often had problems with managed switches, flow control settings, and jumbo frame.

Thanks for the suggestion. Power cycle of the unmanaged switch was not sufficient this evening, but power cycle of Roon server cleared it up. I noticed that the activity lights were extremely active on the NAS and server (and SSH impossible to do a graceful restart).

I turned off the audio analysis to see how the evening goes. I also will search the forum for any special settings for SMB on the Synology NAS.

Thanks again.


1 Like

in case you missed it Jumbo Frames is always an issue it seems…so make sure that is off everywhere.

Also your NAS should be using SMB-3 ideally (under File Services - SMB Advanced)

What is the Network usage looking like is the resources app on the NAS?

Thanks for your note.

Interestingly, regarding the Synology unless SMB1 is enabled Roon is unable to view the directories. I am mounting directly from the app (I have not tried mounting outside of the app.)

Network usage on NAS when streaming over Ethernet is around 300k with a 96 recording. When attempting to stream same file over wifi the other Pi usually dies quickly. (Just because, I rebuilt that Pi using DietPi this evening to see if that impacted performance.) A Sonos Connect physically situated nearby (plugged into the same Bel Canto) plays fine (but down samples of course). As reference, 2g file transfers from W10 Surface3 are in the 4-6MB/s range, physically near the same wifi endpoint.

I don’t really know where to look for jumbo frames — the switch is unmanaged (mostly because years ago I couldn’t get multi cast right for Sonos at the time, and a generic switch “just worked”). Edit: I just edited the MTU on the Synology manually to 1500, and I’ll see how that goes.

Thanks for the suggestions.


Jumbo Frames are Ethernet frames with more than the standard 1500 bytes of Maximum Transmission Unit (MTU), allowing Ethernet transmission of large files to be more efficient. It can only be enabled under Gigabit network environment. To ensure Jumbo Frame works properly, all the computers and devices across the network accessing your Synology NAS must support it and use the same MTU value.

From the LAN help page on DSM

Is it also possible the switch is not operating at Gbit speed?

Hello, thanks for your suggestions. This morning I woke up to the same scenario: all devices plugged into “switch1” inaccessible (Roon down, Sonos down). Reboot of switch didn’t fix the problem, but a hard reboot of the Roon server cleared everything up. Other part of network fine (wireless to internet for example),

Made a further change to Synology SMB settings: turned off opportunistic locking, as I remembered that Sonos is set to do a full directory scan early every morning, and wondered about that.

Using read only accounts for Roon access and Sonos access, BTW, in case that matters to Roon.

To your questions:

  1. Setting the MTU at the LAN interfaces on the Synology to 1500 didn’t seem to have any impact (I set these last night).
  2. Confirmed gigabit link:

root@perotinus:~# ethtool eno1
Settings for eno1:
_ Supported ports: [ TP ]_
_ Supported link modes: 10baseT/Half 10baseT/Full_
_ 100baseT/Half 100baseT/Full_
_ 1000baseT/Full_
_ Supported pause frame use: No_
_ Supports auto-negotiation: Yes_
_ Advertised link modes: 10baseT/Half 10baseT/Full_
_ 100baseT/Half 100baseT/Full_
_ 1000baseT/Full_
_ Advertised pause frame use: No_
_ Advertised auto-negotiation: Yes_
_ Speed: 1000Mb/s_
_ Duplex: Full_
_ Port: Twisted Pair_
_ PHYAD: 1_
_ Transceiver: internal_
_ Auto-negotiation: on_
_ MDI-X: on (auto)_
_ Supports Wake-on: pumbg_
_ Wake-on: g_
_ Current message level: 0x00000007 (7)_
_ drv probe link_
_ Link detected: yes_

By the way, checking /mount/proc, I notice the mount using smb v1:

\134\13410.0.1.2\134music /mnt/RoonStorage_bbe67008d66664e25b882a64d041e3d89f31ea1c cifs rw,relatime,vers=1.0,cache=strict,username=nathan,domain=codexwilkes,uid=0,noforceuid,gid=0,noforcegid,addr=,file_mode=0755,dir_mode=0755,nounix,serverino,mapposix,rsize=61440,wsize=65536,actimeo=1 0 0

Does anyone know how to change this to SMB3, as has been suggested optimal?

This might be part of the issue. Roon is doing a RW mount, but if the user account on the synology doesn’t have write permissions there could be an unforeseen issue during analysis.

As for the SMB version, I’m running an i5 NUC running Ubuntu 16.04 mounting shares from a Synology and my roon-initiated mounts are all SMBv1. I haven’t had an issue like this at all.

You don’t mention the switch model, but I’ve had issues with some of the old Cisco/Linksys 8 port switches that sound very much like what you’re experiencing. During heavy load the processor in the switch would overheat and cause all kinds of problems. In most cases a power-cycle of the switch would solve the problem, but depending on how the interface goes down I can see needing to reboot the clients as well.

Thanks for your note. The switch is a SE2800, so likely one you remember as being a problem. Any recommendations for 8 port switches?

I noticed the rw – in fact, the account “nathan” that is used has read / write (a mistake on my part) – so not likely the problem.

Yep. The plastic case had no way to dissipate heat and those things can cook a bit when there’s a lot of traffic.

In an 8 port switch I’ve been having good luck with the Cisco SG110d-08. In fact the entire 100 series of Cisco switches has been an absolute workhorse for me.

If possible, try to move your Roon server and NAS to another switch or router temporarily to prove if the switch is indeed the problem.

Generally, a switch with a metal case is preferred. I’ve read that people had problems with TP-Link switches for Roon usage, and I’ve not come across problematic reports of Netgear unmanaged switches (not to imply there aren’t any).

I seemed to have solved my network issues. The culprit seems to have been “Opportunistic Locking” in the SMB advanced SMB options on my Synology 415+. I also have a new Cisco switch on the way, just in case.

Thanks for everyone’s help and support. I just paid for my lifetime Roon membership, and donated to DietPi. :slight_smile:

To answer my questions posed to Roon support earlier, in case helpful to other new Roon users:

Roon logs typically found in linux builds at /var/roon/RoonServer/Logs/ and /var/roon/RAATServer/Logs/. In my case, not helpful. (Nor were standard system logs helpful either.)

Avoid switches which are prone to overheating (metal case preferred), and there are reports that some cheap switches fail under load.

Sonos proved to not be relevant to the network issues I experienced.