New 14-day trial and Roon is a disaster. Roommate's trial was flawless on the same equipment. Please help

Core Machine (Operating system/System info/Roon build number)

Intel Core i3
Ubuntu 18.04.5
Roon Framework v6-22-06

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Cable modem (100Mb/s d/l)
Untangle router
Netgear managed switch
Ceiling AP

Roon Core is wired directly to the switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All on Wifi:
Chromecast audio X3
Nvidia Shield
Squeezebox on RPi with picoreplayer
Ropieee Roon endpoint (HiFiBerry Digi+ Pro, Topping E30 DAC via coax)

Mac mini

iPad mini v4

Description Of Issue

My roommate signed up for a 14-day trial of Roon. He didn’t care for it but I thought it was amazing. Not a drop-out or glitch or one issue in two weeks. I was sold.

He discontinued his sub. I was sure to log out of (MY) Tidal account and log out of his sub from the Roon install before he cancelled his trial. Then I signed up for a new trial with my email and credit card, and logged into the already-installed Roon with my new credentials and Tidal account. At this point Roon went to crap.

Everything is the same as when my roommate’s account was used, other than the audio library is now on an internal 1TB HD rather than being read on a network share. I’m having the following issues, which are especially bad with the Chromecasts:

  • The audio (especially on Chromecasts) is glitchy and distorted and has dropouts so bad it’s useless.
  • The Squeezebox device can’t be found.
  • When most devices start playing they start at nearly max volume even though it’s set low in the remote
  • I usually can’t change between audio devices. When I try to switch, often the new device tries to play the previous song I’d been playing on it, even if that was days ago, rather than the current track selected. Sometimes I have different songs playing at the same time from multiple devices, which I didn’t think was even possible.
  • When I try to select a different audio device the current device keeps right on playing. It will not switch, even though the blue checkmark moves to a different device on the remote.
  • Roon often says it loses communication with Chromecasts.
  • The ‘dot’ beside the song playing (to see signal path) is now green(?) I’m sure it was blue with his trial.
  • In the signal path I now have two ‘Equalizers’ (one for bass, one for treble) between Chromecast and Output, as well as ‘DSP Volume’ (which also has the green dot). These were not there during the prior trial period and I can’t figure out how to get rid of them.
  • I also have repeated issues logging into Tidal now. Roon gives me ‘invalid login’ a time or two before success.
  • The RoPieee device works pretty good. Hardly any issues with that, other than still not being able to change devices which is always an issue.

All of this continues to be an issue whether I’m playing music from my library or from Tidal. I’ve of course re-booted everything multiple times, including the network, but that didn’t help. I’m not really sure what happened to the Roon experience on this setup. It should work the same with the new trial as it did with the one that was just cancelled, but it hardly works at all. Aside from the new login credentials, the only thing that changed in the meantime was moving the library to an internal HD in the Roon Core machine and re-scanning the library (which was successful and took 24 hours). Any input into this would be appreciated. Sorry for the long post.

Did you completely remove and re-install Roon between trials.

I did not uninstall the Roon server software on the Core. I just logged out then logged back in with a new account.

I did uninstall and reinstall the iPad remote app.

Uninstall everything, including the Roon database, then install Roon from scratch.

Would that be a problem for you?

You can’t use a database created by one user for a different account.


The database was rescanned after the account switch.
That said I agree this is the best bet to fix the situation. I wanted to avoid waiting 24 hours for another rescan to complete.

Hi @Drew_Robinson,

I definitely agree with making sure to start “fresh” if there was a trial before. I’d uninstall Roon and make sure that the database folder are removed. Reinstall and if you’re seeing any issues still please let us know and we’ll be happy to help!

I really wanted this to work, but at this point I think I’ve given up. Still six days left on my 14-day trial and I don’t think I’ll subscribe.

Following the original post, I uninstalled Roon from the i3 box and completely disconnected it from my network (I was only going to use it as a Roon Core anyway). I instead installed Roon Server on my 2020 M1 Mac mini and pointed it to the network share where my music lives.

However I’m still having issues including connection troubles, especially with Chromecasts. Tracks often just stop playing in the middle with no known cause. Volume levels on Chromecast devices still blast out of the speakers at max volume for a second or so after a playback starts, even with the Roon volume set low in the remote. Speaking of volume, the volume level of my Squeezebox device is very low, and still not loud enough even with everything turned way up. After multiple library scans there are still several hi-res Flac albums in my library that aren’t available, so I have to play them with different software if I want to hear them. (I guess you can’t re-scan individual folders…?) Tidal issues persist also, and today Roon won’t connect to Tidal at all even after a re-boot. I can connect fine if I launch the Tidal app on its own without Roon.

The signal path with Chromecast devices continues to bug me. Here’s what it looks like:

I still can’t figure out why the two Equalizers and DSP Volume are there. I can’t get rid of them, and I can’t help feeling this is some symptom of the overall problem. I’m also having issues with Roon not advancing to the next track without the play/pause button being pressed twice, but I see that’s a known bug so I predict at least that will be fixed.

I’m tired of dealing with this and I plan to abandon the effort. I should have just taken over my roommate’s subscription because it worked perfectly when it was his account. Since I changed accounts it’s been nothing but trouble, even on a completely different computer. Thanks for all suggestions but it doesn’t appear this was meant to be.

Update: A re-boot of the computer seems to have solved my Tidal log-in issues, at least for now.

Don’t know about the playback problems (which sound like possible network issues). But, the part about changing output devices and the new device starting to play whatever it was playing days ago instead of what was playing on the device you switched from… that’s how it’s supposed to work. It sounds like you want to use the “transfer zone” feature, which does what you want, I think.

Transfer Zone

Roon allows you to transfer or move your current track, queue, and radio to another zone. While viewing the queue, click on the double arrow icon and select the new zone. On a phone, click the middle of the footer, on the song name, and select Now Playing. Just below Now Playing will be the double arrow icon . From there select your new zone.

the part about changing output devices and the new device starting to play whatever it was playing days ago instead of what was playing on the device you switched from… that’s how it’s supposed to work.

Yes, I wasn’t experienced with Roon when I wrote that and have since realized this is the way it’s supposed to work. Thanks.

The DSP volume would be expected if you are using Roon to control volume through Chromecast audio.
While you are in the Chromecast zone, click the speaker icon in the lower right corner. There will be some text about volume control. What does yours say?
While you have the box open from clicking the speaker icon, click on the DSP text. That’s where the equalization stuff is probably set.

Thanks for the reply. I am using Roon to control the Chromecast Audio volume, so at least that’s explained. What about the equalizers?

I don’t see any text when I click on the speaker icon lower right. Here’s what I’m seeing.

Click on the DSP text in that box. It will open up a whole panel devoted to DSP-related signal modifications.

It may be that since you are using Chromecast device volume isn’t an option, so there will be no choices. Hence no text.

Here’s what I see when I click DSP. Nothing selected in there.

If the equalization was coming from Roon, I believe that signal path would say Parametric EQ. Since it doesn’t say that, and there is no evidence of Roon setting the equalization. perhaps it is set somewhere else. I’m not familiar with Chromecast, but I see this:
Change your sound settings - Android - Chromecast Help (

Thanks. I looked at that and there are indeed bass and treble sliders on that screen in the Google Home app. There’s no way to turn equalization off – the sliders are just there.

In the original setup (with the previous Roon account) these equalizers were not there in the signal path, and the DSP Volume wasn’t there either. This is is why I though these were a symptom (or even cause) of all my new problems since the account switch.

Edit: I moved the sliders to the middle/neutral position and the equalizer entries still show up in Roon’s signal path, with +2dB for Bass and +3dB for Trebel.

Okay. It sounds like the bigger issues are somehow network related. @Dylan, who is with Roon, will have better tools to help figure that out. But two things he’ll probably want to know:

  1. Exactly how is the core (on the Mac Mini) connected to the network.
  2. You note a managed network switch. Where is that located in your network?

Thanks again.

  1. The Mac mini is connected directly to the Netgear switch by ethernet. Wifi is turned off on the Mac. The WHS server containing the library is also connected to the same switch, so presumably a direct wired path.

  2. The Netgear switch is technically a ‘managed switch’, but I’ve never gone in there and changed default settings. It’s therefore not really a managed switch all at the moment. Sorry for confusing the issue.

The switch is between my cable modem/router and the rest of my wired devices.

Managed switches, if not setup correctly, give Roon fits.

Can you (temporarily) take the switch out of your chain, just as a test?

Is this the same switch your roommate was going thru?

Yes, it’s the same switch and configuration as before (except now using Mac mini and different account.)
It would be difficult to circumvent the switch. I’ll give it some thought. Thanks.

Edited to emphasize: the switch remains at its default settings and has never been managed

Some managed switches have some of the “managed options” turned on by default. So don’t assume it’s not a managed switch issue. Sorry to hear of all the hassles you’re having. Typically it “just works” as you noted from the roommate’s trial.